272
OP2 [Q&A] The Ultimate OnePlus 2 Guide - Solutions e.t.c.

  1. Dhruvism
    Gingerbread Apr 29, 2016

    Dhruvism , Apr 29, 2016 :
    I liked Root Booster more,do let me know if L Speed is good enough or not
     

  2. Aj115
    Donut Apr 29, 2016

    Aj115 , Apr 29, 2016 :
    Havent tried root booster. L speed seems to have bad days. Today my battery is on 50% with 2hours sot. Ill give l speed a week and switch to root booster.
     

    Dhruvism likes this.
  3. Navbot
    Eclair Apr 29, 2016

    Navbot , Apr 29, 2016 :
    Lol okay? I know how to locate a file, the point I'm trying to make is when I hit "Install from SD" it doesn't go ANYWHERE. I can hit "Install from SD" all day long, but it doesn't go past that part, so I can't locate the file cause it doesn't go into the SD Card. The zip file is FOR SURE on the SD Card and not in downloads or anywhere else. Most likely there is something wrong with the phone itself.
     

    Dhruvism likes this.
  4. Kelticwarrior
    Cupcake Apr 29, 2016

    Kelticwarrior , Apr 29, 2016 :
    Hi I was wondering if somebody could help me. I am stuck in a boot loop. I can boot into fastboot Mode but not system or recovery. I tried flashing TWRP.img and also stock recovery but both do not boot. They both flash but I cannot get them to boot so phone is just a brick. Below is a screenshot from my computer in command prompt.

    [​IMG]
     

    Dhruvism likes this.
  5. Spannaa
    KitKat Apr 29, 2016

    Spannaa , Apr 29, 2016 :
    Your version of TWRP looks like it isn't compatible with your bootloader.

    TWRP version and ROM would be useful ;)
     

  6. laurab4369
    Cupcake Apr 30, 2016


  7. jyubil
    Gingerbread Apr 30, 2016

    jyubil , Apr 30, 2016 :
    Lags of 1 sec during closing and apps at recent menu.. Flashing wallpaper for 1 or 2 sec and after that it takes to home page.. Why? Frustrated...lags, bugs all time..
    We need stable bug less update... From every update you guys makes more bugy update...
     

  8. ROHANNNNN
    Cupcake Apr 30, 2016

    ROHANNNNN , Apr 30, 2016 :
    I am on the OOS 3.0 Beta and my secondary mic seems to record the voice very low while having video calls or speaker calls. So i opened the manual test mode on the device > Single mic test> Secondary supplementary mic. After speaking the word TESTING the secondary mic only records 100 ~ 500 units. But when i test using primary Mic It records 1000~ 5000 units. Is it a software bug. If so Please guide me on the fixing procedure
     

  9. Kelticwarrior
    Cupcake Apr 30, 2016

    Kelticwarrior , Apr 30, 2016 :
    I figured that out alright and used a modified TWRP to work with Oxygen 3.0 and the phone booted up fine. Thanks anyway.
     

    Alvie likes this.
  10. Dhruvism
    Gingerbread Apr 30, 2016

    Dhruvism , Apr 30, 2016 :

    Oh that means your recovery is corrupted (or something) I think ,you need to install stock recovery again do it via the fastboot method ,check one of the guides available
     

  11. Dhruvism
    Gingerbread Apr 30, 2016

    Dhruvism , Apr 30, 2016 :
    Go through the mega unbrick thread (and don't worry)
     

  12. Dhruvism
    Gingerbread Apr 30, 2016

    Dhruvism , Apr 30, 2016 :
    Hmm
     

  13. Shayadh
    Cupcake Apr 30, 2016

    Shayadh , Apr 30, 2016 :
    You can unbrick it. Google "unbrick oneplus 2" it's somewhere there on the Internet ✌
     

  14. Navbot
    Eclair May 1, 2016

    Navbot , May 1, 2016 :
    Alright, so I am trying to install the stock recovery using the fastboot method, but when I use the "fastboot flash recovery <filename> command it fails. It says remote deive: locked, cannot flash images. I also did a fastboot oem device-info command if that helps at all. Not sure what the next step is from here. Do I have to unlock the bootloader or something? device locked.PNG device info.PNG
     

    Dhruvism likes this.
  15. Spannaa
    KitKat May 1, 2016

    Spannaa , May 1, 2016 :
    Yes, you need an unlocked bootloader to be able to fastboot flash images.
     

  16. Harsimransingh26
    Gingerbread May 1, 2016


  17. Dhruvism
    Gingerbread May 1, 2016

    Dhruvism , May 1, 2016 :
    You didn't read the process properly
    Commands:
    - For Unlocking Bootloader write the following command:

    "fastboot devices"
    "fastboot oem unlock"
    "fastboot oem device-info"

    without the quotes

    & then


    - Flash TWRP recovery on your OnePlus 2 by running the following command:

    "fastboot flash recovery recovery.img"

    - Boot TWRP recovery on your OnePlus 2 now by entering the following:

    "fastboot boot recovery.img"
     

  18. Dhruvism
    Gingerbread May 1, 2016

    Dhruvism , May 1, 2016 :
    Onhax it ;)
     

  19. gauravfgc
    Eclair May 1, 2016

    gauravfgc , May 1, 2016 :
    sir my opt starts hang some time which irritate me please help me to over come this problem.i have purchased from amazone just before 3 months.
     

  20. 3393828
    Cupcake May 1, 2016

    3393828 , May 1, 2016 :
    My OP2 phone is not getting into custom recovery after upgrading to 3.0 phone get struck at oneplus icon please help