2
"Quick activate the assistant app" does not work on lock screen

  1. cdasart
    Cupcake Jan 15, 2021

    cdasart , Jan 15, 2021 :
    Problem(s)
    • On the lock screen, the power button .5 second hold does not launch the google assistant app. The haptic vibration happens as if the phone is trying to launch google assistant, but nothing happens. After 3 seconds it shows the side menu (power off, restart, lock down, screenshot, emergency).
    • The microphone button in the bottom left of the lock screen doesn't work either. It opens a white screen and then prompts me to unlock the phone. Then after unlocking the phone, nothing happens. I am only mentioning this because it may be related.
    What still works
    • When the phone is unlocked, I can open google assistant app with the power button .5 second hold.
    • When the phone is unlocked and on the lock screen, I can also open google assistant with my voice ("hey google").
    Here are the things I have already tried:
    • checking for updates (there were none) - current version is Oxygen OS 10.3.7
    • turning it off and on XD
    • switching launchers (oneplus default and microsoft)
    • clearing Google Services data and cache
    • turning off and then back on several settings (listed below)
      • Buttons & gestures - Quick activate the assistant app
      • google assistant - personal results
      • google assistant - lock screen personal results
      • google assistant - personal suggestions on lock screen before you ask
      • google assistant - voice match - hey google
      • lock screen - sensitive notifications
      • lock screen - notifications on lock screen - show important and other notifications
      • lock screen - app notifications - google
      • lock screen - app notifications - google play services
      • Trusted Agents - smart lock (google)
    • I made sure that Google Play services is not being denied any access.
      • Apps & Notifications - see all apps - google play services - permissions - denied - no permissions denied
    I'm not sure what else there is to try other than a factory reset and that is why I am here. I am hoping to avoid that unless absolutely necessary.

    Thanks in advance for any input!
     

    #1
    ryan.techguy and A1610794444930 like this.
  2. A1610794444930
    Cupcake Jan 16, 2021


    #2
  3. KLVN
    Cupcake Jan 19, 2021

    KLVN , Jan 19, 2021 :
    I'm also having this problem as of this week. I tried most of the steps from the original post but none worked!
     

    #3
  4. E1611505613351
    Cupcake Jan 24, 2021


    #4
    ryan.techguy likes this.
  5. ryan.techguy
    Cupcake Jan 24, 2021

    ryan.techguy , Jan 24, 2021 :
    Oneplus 7t on the lastest version, also not working. I also tried wiping system cache but no luck.
     

    #5
  6. cdasart
    Cupcake Jan 26, 2021

    cdasart , Jan 26, 2021 :
    Sadly I still have not found a solution.

    I am still putting off the factory reset too.

    I dropped this in reddit too and have had no bites yet.

    I am considering contacting OnePlus support, but I was hoping they would have joined the chat here.
     

    #6
  7. E1611505613351
    Cupcake Jan 28, 2021


    #7
    cdasart likes this.
  8. cdasart
    Cupcake Feb 2, 2021

    cdasart , Feb 2, 2021 :
    Hey everyone,

    I am happy to say that it has randomly started working on my phone (Still using the same build as before: Oxygen OS 10.3.7).

    I wish I could say that I did something that fixed it, but I haven't done anything since I made the post detailing everything that didn't work.

    If its still not working for you, it may be worth checking out the beta for build 11.
     

    #8