5
Other Random disconnects using Android Auto

  1. Danetrooper
    Donut Apr 27, 2020

    Danetrooper , Apr 27, 2020 :
    Hey!

    I´m having issues using Android Auto with my OnePlus 8.
    The Phone randomly disconnects while driving. This is not due to the cable unplugging or something like that. After it disconnects the car immediatley recognises the phone again, asking me if I want to connect to Android Auto via USB.

    Sometimes this happens every couple of minutes and sometimes there is an hour in between those disconnects, but it always happens.

    I tried disabling the battery optimisation for Android Auto because I thought that the Phone might be killing the Android Auto task after a while. But that did not fix the problem.

    I have been using a OnePlus 5T before an never had this issue. Im using the same car, same USB cable.

    The only real difference is that my OP5T ran Android 9 and the OP8 of course runs Android 10.

    I really appreciate your guys help! Thanks!
     

    #1
  2. cmercernewyork
    Cupcake Aug 21, 2020

    cmercernewyork , Aug 21, 2020 :
    just wanted to say you are not alone. I have the same issue and have been for many months. I have reset cache and data on AA and all google apps... did nothing. I cleaned my phone port... did nothing. I will try cleaning my car port today but I assume nothing there either. The disconnect is random. it is not due to bumps or moving the cable in any way. when it disconnects the only solution is to pull the cable and reconnect... it is then a crapshoot as to how long it will stay connected... seconds... minutes.... it causes very distracted driving. it is not a oneplus issue, the interwebs is full of articles from Pixel, samsung, LG, .... it is most likely a software issue.
     

    #2
    RobertRoth likes this.
  3. Les_Izmoor
    Cupcake Aug 22, 2020

    Les_Izmoor , Aug 22, 2020 :
    Out of curiosity, are either of you using a 1 meter cable?

    I was having the above described issues with Android Auto and my car and they were unresolved until I tried using the factory 1 meter cable. Obviously I can no longer route the cable out of sight, but I now have functionality.
     

    #3
  4. Sighn
    Gingerbread Aug 29, 2020

    Sighn , Aug 29, 2020 :
    The OP said that the cable he used with one phone worked perfectly fine. He used the same cable on a different phone with a different OS version and is now facing disconnect issues. The cause of these disconnects is likely different for different people.
     

    #4
  5. G_NTabor
    Donut Sep 16, 2020

    G_NTabor , Sep 16, 2020 :
    This is, unfortunately, an Oxygen OS 10 issue. I have been reporting this to OnePlus for almost a year. I have provided logs, used the Community app, called, and chatted, and get precisely nowhere. I have the issue on my 6T McLaren, and I have since installing OOS 10. When my phone was on OOS 9, AA was never killed by the OS.
     

    #5
  6. Swejuggalo
    OnePlus 9 Series Expert Community Expert Sep 17, 2020

  7. I1598275888248
    Cupcake Aug 26, 2021

    I1598275888248 , Aug 26, 2021 :
    Having same problem with Oneplus 8 Pro. Have replaced with factory stock usb cable and it still happens. The car slave end might be flaky but my previous phone was the pixel2 and I had no such issues with that one. This is serious enough for me to consider moving away from OnePlus in the future.
     

    #7