1
RCS features stopped working on One Plus 7pro after switching to Google Fi

  1. onewyldsubie
    Donut Feb 3, 2020

    onewyldsubie , Feb 3, 2020 :
    Has anyone encountered this issue yet? RCS was working fine when I was on AT&T and as soon as I switched to Google Fi it stopped working. My phone is on the latest update, I deleted and reinstalled Google Messenger to no avail.
     

    #1
    hugohca likes this.
  2. k9cop
    Cupcake Feb 7, 2020

    k9cop , Feb 7, 2020 :
    This may sound dumb, but this is what I did to make it work on Google Fi. First, and easiest thing to do is turn off your WiFi and ensure you are connected to a cell signal. Go into messages and try to enable chat features. If that doesn't work ensure you have Carrier Services installed. After installing it from the Play store try the above again. Clearing the cache and reinstalling the apps didn't work for me, but turning off my wifi made it work immediately.
     

    #2
  3. hfca
    Cupcake Feb 11, 2020


    #3
  4. svntsvn
    Eclair Mar 4, 2020

    svntsvn , via OnePlus 7 Pro , Mar 4, 2020 :
    Did you have any luck? I'd do a network reset and reinstall everything. FYI, I never used the hack method I just installed the beta and it works fine. I believe there is a carrier services system type app already installed as it works stock with beta messages app. I installed it a while back and it used zero data or memory so I think it was just dormant.

    Aside: Is wifi calling working for you? No luck her with 7 pro even when installing logkit and enabling the function switch, it won't make calls in airplane mode. (installing fi app and finishing activation removed my wifi calling toggle option so I think the fi app is to blame in my case) cheers
     

    #4