0
Receiving messages and mail notifications late

  1. G_Pallavi_Menon_vkdU
    Cupcake Aug 18, 2019


    #1
  2. Sridhar Ananthanarayanan
    Lollipop Aug 18, 2019

    Sridhar Ananthanarayanan , Aug 18, 2019 :
    Have you enabled aggressive battery optimization? If so, disable it.
     

    #2
    Starcommander likes this.
  3. tomkriplean
    Cupcake Aug 20, 2019

    tomkriplean , Aug 20, 2019 :
    I was having this same issue and found the setting under "Battery/Battery Optimization/Advanced Optimization/Sleep Standby optimization" had been turned on. Might be setting you also want to check.
     

    #3
  4. Gunnar Kris
    Donut Aug 21, 2019

    Gunnar Kris , Aug 21, 2019 :
    In cases like using the international version, that could work. However, on the TMobile variant, that is not an option. Some of the stuff they disabled for TMobile makes getting some apps to work properly a pain in the *** or downright impossible.
     

    #4
    ironass likes this.