0
Regarding ambient display not sleeping with AOD disabled. via OnePlus 8T

  1. Nikhil_Bhilai
    Honeycomb Jan 7, 2021

    Nikhil_Bhilai , via OnePlus 8T , Jan 7, 2021 :
    I want to share an issue with the OP community here...
    I sleep with my phone beside me (a bit far from me obviously) my phone lies flat on the bed... sometimes i wake up in middle of the night then i reach my phone to check the time so when i lift my phone, the ambient display wakes up and shows me the time and when i again lie my phone flat, the ambient display doesn't sleep!!! I then use power button to make it sleep or i just double tap to wake it again then unlock and press power button to make my screen sleep. Does anyone has any idea why is this happening? My AOD is disabled but lift to wake the ambient display and tap to wake the display is enabled. Any help will be appreciated.
    Thanks!

     

    #1
  2. Dresa91
    User of the Year 2016; Most Active User 2020 Jan 7, 2021

    Best Answer
    Dresa91 , Jan 7, 2021 :
    Okay, what OxygenOS Version are you using?
     

    #8
  3. Dresa91
    User of the Year 2016; Most Active User 2020 Jan 7, 2021

    Dresa91 , Jan 7, 2021 :
    What is your screen timeout/sleep setting?
     

    #2
  4. Nikhil_Bhilai
    Honeycomb Jan 7, 2021

    Nikhil_Bhilai , via OnePlus 8T , Jan 7, 2021 :
    15 seconds but that doesn't apply to ambient display, it gets turn off after 2-3 seconds
     

    #3
  5. Dresa91
    User of the Year 2016; Most Active User 2020 Jan 7, 2021

    Dresa91 , Jan 7, 2021 :
    So your screen never turns off, after you checked the time for example? Did I understand your problem?
    What OS version are you using?
    Did you restart your device?
     

    #4
  6. Nikhil_Bhilai
    Honeycomb Jan 7, 2021

    Nikhil_Bhilai , via OnePlus 8T , Jan 7, 2021 :
    I lift the phone to wake, lie it flat down but the ambient display doesn't sleeps. This happens only once and that too only during night. I have to turn off the ambient display by pressing power button twice or by double tap to wake then lock
     

    #5
  7. Dresa91
    User of the Year 2016; Most Active User 2020 Jan 7, 2021

    Dresa91 , Jan 7, 2021 :
    Sorry for this question: so you waited some minutes, right?

    so, what about to turn off Lift to wake in settings and enable it again?
     

    #6
  8. Nikhil_Bhilai
    Honeycomb Jan 7, 2021

    Nikhil_Bhilai , via OnePlus 8T , Jan 7, 2021 :
    Yes, i waited for it to sleep again but it didn't sleep so i make the screen to sleep manually. I have done that too, disabling and re-enabling the lift to wake option.
     

    #7
  9. Nikhil_Bhilai
    Honeycomb Jan 7, 2021

    Nikhil_Bhilai , via OnePlus 8T , Jan 7, 2021 :
    I am using the latest build of oxygen os for OnePlus 8t that is 11.0.6.8 (the latest build available for Asia)
     

    #9
  10. Dresa91
    User of the Year 2016; Most Active User 2020 Jan 7, 2021


    #10
  11. Nikhil_Bhilai
    Honeycomb Jan 7, 2021


    #11
  12. Dresa91
    User of the Year 2016; Most Active User 2020 Jan 7, 2021

    Dresa91 , Jan 7, 2021 :
    They are not always responding..
     

    #12
  13. Nikhil_Bhilai
    Honeycomb Jan 7, 2021


    #13
  14. Dresa91
    User of the Year 2016; Most Active User 2020 Jan 7, 2021

    Dresa91 , Jan 7, 2021 :
    Yeah, I think so.
    And if there are x reports to the same topic it is a kind of confirmation that is a kind of urgent - I guess
     

    #14
  15. Nikhil_Bhilai
    Honeycomb Jan 7, 2021

    Nikhil_Bhilai , via OnePlus 8T , Jan 7, 2021 :
    Okay, that's good if they see all our complaints.
     

    #15
    Dresa91 likes this.
  16. marius_902002
    Donut Feb 5, 2021

    marius_902002 , Feb 5, 2021 :
    Same here. I sometimes wake up and the Ambient Display is on. This happens only during the night.
    OP 7T 10.0.16
     

    #16
    Nikhil_Bhilai likes this.
  17. Nikhil_Bhilai
    Honeycomb Feb 5, 2021

    Nikhil_Bhilai , via OnePlus 8T , Feb 5, 2021 :
    I have fixed this problem, go to settings>>battery>>battery optimization>>three dots on upper right corner>>advanced optimization>>disable sleep standby optimization. 👍
     

    #17