0
removing country code

  1. M1517053337292
    Eclair Feb 22, 2018

    M1517053337292 , Feb 22, 2018 :
    whenever I try to call a helpline or any number,+91 is automatically added everytime,how to stop this?
     

    #1
  2. Gav_W86
    Starting Point Expert Feb 22, 2018


    #2
  3. O1548885481991
    Cupcake Apr 23, 2019

    O1548885481991 , Apr 23, 2019 :
    GAV_W86 that is not an appropriate answer. I purchased this phone in India and it works in North America. But after few secs it does add +91 to the number I have dialed making it difficult to re-dial. Due you have a solution to this issue?
     

    #3
  4. Gav_W86
    Starting Point Expert Apr 23, 2019

    Gav_W86 , Apr 23, 2019 :
    it was entirely the answer to the original poster more than a year ago, it is not really up to you to decide whether it is appropriate or not 14 months later.
    And it won't be an issue, it will be a setting made.
    Do you have Assisted Dialling turned on (Phone app > Settings > Assisted Dialling)?
     

    #4
    KeepTransisting likes this.
  5. O1548885481991
    Cupcake Apr 23, 2019

    O1548885481991 , Apr 23, 2019 :
    No I did not have that turned on. Thank you for responding and my apologies for framing my sentence that way which I did not really mean to. Going back to assisted dialing by turning the assistant does that resolve the issue?
     

    #5
  6. Gav_W86
    Starting Point Expert Apr 23, 2019

    Gav_W86 , Apr 23, 2019 :
    which country are you in now?
    which country are your SIM cards from?
    which country phone number are you dialling?
     

    #6
  7. O1548885481991
    Cupcake Apr 23, 2019

    O1548885481991 , Apr 23, 2019 :
    I am in Canada and my service provider is Koodo mobile. I try to dial a local number here for the first time no issues.when I hang up and try to redial after 5 minutes then it addes +91 by default. I have enabled the country code setting and it did not work.
     

    #7
  8. Gav_W86
    Starting Point Expert Apr 23, 2019

    Gav_W86 , Apr 23, 2019 :
    do you have any other apps that can access the phone like Trucaller?
     

    #8
  9. O1548885481991
    Cupcake Apr 23, 2019

    O1548885481991 , Apr 23, 2019 :
    no I don't I am using the native app for phone in one plus 6T
     

    #9
  10. manoharprvn
    Cupcake Jun 3, 2019

    manoharprvn , Jun 3, 2019 :
    FOLLOW THIS STEP
    1.Open Dial
    2.Setting/Call Settings
    3.Location
    4..Default country
    5.Edit/remove
    6.Uncheck Add Country Code/Show Location
     

    #10
  11. G_Dibyendu_Paul_YcwF
    Eclair Jun 6, 2019

    G_Dibyendu_Paul_YcwF , Jun 6, 2019 :
    Are you sure about this path. It seems wrong. Could you please check once again and post please. Having trouble with automatically addition of country code.
     

    #11
  12. D1566231017011
    Cupcake Aug 19, 2019


    #12
  13. G_Sagar_Desai_qXCR
    Cupcake Sep 10, 2019

    G_Sagar_Desai_qXCR , Sep 10, 2019 :
    I am using oneplus 5.
    I have saved all my contact number with country code +91 and default country code set as a +91 (india). So sometimes in incoming calls i get only number whether i am in roaming or not instead of contact name.
    how to resolve this issue ? is there any way to disable the default country option or any other solution ?
     

    #13