47
Guide Return OP2 to 100% Stock / Unbrick Soft Bricked OP2 / OxygenOS 2.1.1 Fastboot Images

  1. hauakaevaja09
    Cupcake May 12, 2016

    hauakaevaja09 , May 12, 2016 :
    Can you please give link or sth, same here 1+2 A2003 only turn phone on with Fastboot Continue command ;(
     

  2. dkryder
    Froyo May 17, 2016

    dkryder , May 17, 2016 :
    using the script i was able to recover my oneplus 2. after i was able to enter twrp i immediately wiped /cache /data /system /dalvik and installed cm13. i'm gonna stay away from oxygen and hydrogen for the time being. neither one seemed very good. sorta disappointing that oneplus can not create a decent o/s. anyway, i was happy that your script repaired my phone. thanks!
     

  3. kryddan
    Honeycomb May 18, 2016

    kryddan , May 18, 2016 :
    @Naman Bhalla
    I got a small problem here. I tried to revert back to 100% stock. So I was on oss3beta, so I used the switch from oos3xx to oos2.xx and then fastboot the file in first post. Everything seemed peachy. The phone worked great. But since I got 2.1.1 the phone told me I had OTA to install. Ok, so I did, but it didn't. The OTA won't install. It fails, every time. I even tried download it and install it from stock recovery, but still fails. What am I missing here? I even tried fastboot oem lock but still no dice.
     

  4. d1beats
    Jelly Bean May 23, 2016

    d1beats , May 23, 2016 :
    My phone works and boots but I can't get into recovery or boot into recovery. When I try, I just get the oneplus logo it doesn't finish booting up unless I hold the power button to turn it off and on again. @Naman Bhalla soft brick? I could go into recovery before, not sure what's going on now.

    Edit: nevermind i see you updated your guide. Got my recovery back and flashed the new version of OOS3. thanks again for your work.
     
    Last edited: May 23, 2016

  5. BruhBruuuh
    Cupcake May 24, 2016

    BruhBruuuh , May 24, 2016 :
    Alright, so far so good. Earlier I was stuck in fastboot mode coming from H2OS. I wanted to switch to CM13 but forgot to update the FIrmware and TWRP version. Now, I get stuck on the CM13 boot screen but can load TWRP. Should I try flashing CM again or some version of Oxygen ?
     

  6. seleftheriou
    Eclair Jun 2, 2016

    seleftheriou , Jun 2, 2016 :
    It worked like a charm Naman...!! You're life saver. I messed my OP2 trying to move from H2OS to Exodus.
     

  7. Robson
    KitKat Jun 8, 2016

    Robson , Jun 8, 2016 :
    Hey man thanks for the guide! Any way to restore directly to 3.0.2?
    And will this lock my bootloader aswell?
     

  8. Robson
    KitKat Jun 9, 2016

    Robson , Jun 9, 2016 :
    Bump @Naman Bhalla or anyone who knows
     

  9. Naman Bhalla
    Recognized developer Community Expert Recognized Developer Jun 9, 2016

    Naman Bhalla , Jun 9, 2016 :
    No and no
     

  10. Robson
    KitKat Jun 9, 2016


  11. Naman Bhalla
    Recognized developer Community Expert Recognized Developer Jun 9, 2016


  12. Saumya Pant
    Cupcake Jun 13, 2016

    Saumya Pant , Jun 13, 2016 :
    Help me please!! my phone is bricked ...it is stuck on boot logo .. I'm able to go into fastboot mode and twrp.. but can see any OS..disabled driver signature enforecement..updated driver.. opened recovery tool folder and run MSM8994DownloadTool.exe .. but still can't enter the recovery..nothing happened on my oneplus2 screen...!! what should I do??
     

  13. michaelliao07
    Gingerbread Jun 15, 2016

    michaelliao07 , Jun 15, 2016 :
     

  14. michaelliao07
    Gingerbread Jun 15, 2016

    michaelliao07 , Jun 15, 2016 :
    @Naman Bhalla Hi..im on official CM13 nightlies with garaksHybrid TWRP recovery... Can I use this method to revert back tostock?
     

  15. jhphung
    Cupcake Jun 16, 2016

    jhphung , Jun 16, 2016 :
    HELP. One Plus 2, China version. Updated to 3.0.2, was stuck in bootloop.

    Tried this: http://www.technobuzz.net/unbrick-oneplus-2/

    Restarted into: Disable Driver Signature Enforcement’
    Updated driver to current, and ran MSM8994DownloadTool.exe

    Finally got to Recovery where it showed the options of English > Install from Local, USB, Wipe Data and Cache, etc.

    Tried Helen's suggestion of:
    Recovery Solution #1 (Wipe cache, this will clear app setting data but will retain user data)
    Go to recovery by holding power button + volume down
    Choose English
    Choose 'Wipe data and cache'
    Choose 'wipe cache' (This will only clear app settings data, other data on the internal storage will not be erased)
    Choose 'Yes'
    Choose 'Reboot'

    But after choosing "Wipe Cache" and rebooting, now it only shows the one plus logo.
    Holding Power + Volume gets me to Fastboot Mode, but the recovery menu doesn't show up anymore.

    What can I do? Can I just do a reset of the OS? I don't even want to root, just want a working phone again.
     

  16. Naman Bhalla
    Recognized developer Community Expert Recognized Developer Jun 16, 2016

    Naman Bhalla , Jun 16, 2016 :
    Don't use. Infact flash OxygenOS 3.0.2 and then stock recovery from twrp.
     

    michaelliao07 likes this.
  17. michaelliao07
    Gingerbread Jun 16, 2016

    michaelliao07 , Jun 16, 2016 :
    Thanks @Naman Bhalla for the help..just one more question...before flashing the Official CM13 I had backed up my full Rom via TWRP....So can I just restore the backed up Rom via TWRP? or do I need to do a factory reset and flash just the OOS 3.0.2 Rom?
     

  18. oodonnell
    Donut Jun 25, 2016

    oodonnell , Jun 25, 2016 :
    when I click that link it says

    userdata_64G.zip
    access denied
    looks like you don't have permission to access this folder. Make sure you are signed in to an account that has permission, or check with the developer to request access.



    Selling my phone, but im using CM13 currently so just trying to revert it back to stock and do full wipe, would going in to TWRP and deleting everything do the same thing?? and then running fastboot after I deleted through TWRP ??
     

  19. imti.gr
    Eclair Jul 2, 2016

    imti.gr , Jul 2, 2016 :
    hi guys
    need help on my one plus two

    In recovery i have accidentally wiped my OS. now i do not have any rom n my memory to flash. I can access fastboot and TWRP but unable to push or side load the rom file to phone memory as im unable to enable "USB debugging" as i have no OS on my phone right now.

    Can anyone please guide me.

    Thanks in advance.
     

  20. imti.gr
    Eclair Jul 2, 2016

    imti.gr , Jul 2, 2016 :
    just tried the file but it says cannot load system.img and still the phone wont boot up. any solution