47
Guide Return OP2 to 100% Stock / Unbrick Soft Bricked OP2 / OxygenOS 2.1.1 Fastboot Images

  1. PRIYANSH JHARWAL
    Cupcake Jul 4, 2016

    PRIYANSH JHARWAL , Jul 4, 2016 :
    Hello, Naman
    Recently I flashed twrp and installed cm 13 but after 1 day the twrp recovery disappeared and cm recovery showed up then is factory reset the device , when I did that the OS and recovery both got deleted now when I turn on the phone it shows the oneplus logo only and I can only go to fastboot mode can you plz help to get my OP2 back?????
    Plz anyone??¿¿ i would be very thankful
     

  2. Rushabh Gohel
    Jelly Bean Jul 4, 2016

    Rushabh Gohel , Jul 4, 2016 :
    Is your phone recognized by PC ..?? If yes,

    Flash grerak recovery from fastboot mode and flash CM 13 again
     

  3. sjm92
    Cupcake Jul 13, 2016

    sjm92 , Jul 13, 2016 :
    I'm getting this exact error.
    Unable to unlock OEM - stuck in a bootloop so when the fastboot oem unlock happens, it reboots and gets stuck in a bootloop.
    When I follow your hardbrick guide; I get to steps 7 and 8 and the MSM8994DOwnloadTool.exe, nothing seems to happen. For 30 minutes it still remains as it is.
     

  4. sjm92
    Cupcake Jul 13, 2016

    sjm92 , Jul 13, 2016 :
    Update, repeated all the steps - this time slightly different.

    When MSM8994Downloadtool.exe is ran, it performs its tasks and then my phone reboots - but gets stuck in the bootloop instantly.

    Update x2. Issue seems to be resolved; not sure what caused it not to work but third time is a charm. Thank you Naman (and Lancelot).
     
    Last edited: Jul 13, 2016

  5. Sankeerth Shinde
    Cupcake Jul 27, 2016


  6. BhushanD07
    Cupcake Jul 30, 2016

    BhushanD07 , Jul 30, 2016 :
    Worked.. Thanks alot @Naman Bhalla @souvikdas95
     

  7. inot87
    Cupcake Aug 1, 2016

    inot87 , Aug 1, 2016 :
    Please help...

    My phone was soft bricked. It's can boot into CM recovery but no data in media. Also can boot into fast boot mode, but it's not recognized in PC device manager. try to hold vol+ button for 10 sec then connect it to PC, but it still not recognized. But, when device off and conected to PC, it's shows battery charging logo.

    Thanks in advance for solution. :)
     

  8. dndanny
    Cupcake Aug 10, 2016

    dndanny , Aug 10, 2016 :
    Similar issue to above, attempting to use the Qualcomm method. However, device doesn't appear on Device Manager. Any ideas guys?
     

  9. Shubham Mhashelkar
    Cupcake Aug 31, 2016

    Shubham Mhashelkar , Aug 31, 2016 :
    Thanks man, you saved my money!
    I had flashed miui beta ROM and was unable to get into recovery. So I did all the steps you mentioned without any modification.First boot took a lot of time.I had to clear data and cache in one plus recovery.
    Again, Thank You :)
     

  10. nelson pansare
    Ice Cream Sandwich Sep 8, 2016

    nelson pansare , Sep 8, 2016 :
    Hey guys anyone please tell me whether i will receive update if my phones bootloader is unlocked? I flashed stock rom on my oneplus two again so will i get ota if i left the bootloader unlocked?
     

  11. ashes0809
    Cupcake Sep 26, 2016

    ashes0809 , Sep 26, 2016 :
    Will definitely be needing this soon
     

  12. OPT2_Softbrick
    Cupcake Oct 1, 2016

    OPT2_Softbrick , Oct 1, 2016 :
    EDIT: I was able to solve my problem by flashing a stock rom via fastboot.


    --------------------------------

    Few days ago I got my OP2 with OxygenOS 3.1.0.
    I tried to get root acces following this how-to: https://forums.oneplus.net/threads/mac-user-guide-how-to-root-oneplus-two.438367/

    This didn't work so I tried other how-to's and ended up having TWRP 3.0.2-2 running on my phone.
    When I tried flashing I think Oxygen_OS3_v2.76_supersu through TWRP in order to get root access, the phone was soft-bricked.

    Googling alot I found this thread about how to un-softbrick the phone but I can't make it...

    I am working with OS X, Version 10.9.5.

    It is possible to boot in fastboot mode but I don't know how to run the batch file. Can anyone please explain to me step by step? Unfortunately I'm not really familiar with working with the terminal.

    Thank you a lot in advance :)
     
    Last edited: Oct 1, 2016

  13. soshyans
    Cupcake Oct 9, 2016

    soshyans , Oct 9, 2016 :
    Capture.PNG
    hey guys,
    could you please tell me that i've done the job right or not?
     

  14. Radiolunatic
    Cupcake Oct 15, 2016

    Radiolunatic , Oct 15, 2016 :
    @Naman Bhalla I'm on Marshmallow based custom ROM currently (RR 5.7.2) with latest twrp. Is this method still relevant for me if I want to go back to complete stock ROM + recovery?
     

  15. SuperOne3
    Cupcake Nov 16, 2016

    SuperOne3 , Nov 16, 2016 :

    Hi, so my op2 was rooted & running fine, I decided to change ROM to exodus, didnt like, wiped data, reverted to a previous back-up i made and boom. Was boot-looping, could still open twrp though, try wiping cache and doing restore again, this time my touch screen doesnt work so i could only look at twrp menu. I followed this post and ran cmnd file, it finally executed after a few tries. now phone is just stuck on menu that says powered by android when turned on, can still get to fast boot as well, just no recovery menu.. PLEASE help me if anyone has a suggestion, or has been through and fixed this issue.. I really appreciate everyone on here. Thank you. Especially the author of this thread!
     

  16. anyhow2004bc
    Cupcake Dec 30, 2016


  17. Vishal_khatri009
    Froyo Feb 10, 2017


  18. G_Yash_Emrith_AwuA
    Cupcake Feb 10, 2017


  19. jumpinkiwi
    Cupcake Mar 2, 2017

    jumpinkiwi , Mar 2, 2017 :
    Thanks for putting this guide together. Unfortunately it did not work for me. I downloaded the file, extracted it and ran the batch file flash_ox211.cmd. After the command ran I rebooted and just get the Oneplus screen and have lost twrp also. any ideas where i can go from here?
     

  20. Rishik999
    Honeycomb Apr 14, 2017

    Rishik999 , Apr 14, 2017 :
    The OP should update the main thread and specify that, you need to have your bootloader unlocked, I wasted my 1 gb bandwidth.

    Major EDIT:-
    Follow this guide for the guys you haven't unlocked bootloaders and softbricked their devices, I'm one of them. https://forums.oneplus.net/threads/...ck-guide-for-a-hard-bricked-oneplus-2.347607/ . This thread needs maintenance.

    EDIT2:-
    People stucked at fastboot screen, just enter this command, as mentioned by OP, fastboot reboot
     
    Last edited: Apr 14, 2017