0
[ROM][5.1.1][STABLE] CyanogenMod 12.1 for OnePlus X

  1. Beuti67
    Cupcake Dec 14, 2015

    Beuti67 , Dec 14, 2015 :
    Fantastic Rom, thank to the developer. No Bugs found yet. Best, Camera ist able to save pictures and videos on SD-Card and Bluetooth phonebook working in my car. Seems to be stable. I's amazing that the manufacturer OnePlus is not able to develop a rom that is stable. Others do.
     

    #41
  2. vaupi
    Gingerbread Dec 14, 2015


    #42
  3. Twunk
    Froyo Dec 14, 2015

    Twunk , Dec 14, 2015 :
    Hello, have the ROM flashed 5.1.1 Build Stable 1.0s weekend. Big thanks to MasterAwesome! Many of my problems have been solved.
    But I have a bug. The proximity sensor is not working. All settings set correctly. No indication of the time and alerts!
    And for me brand new: The OPX is off and it starts at the set time to wake up in the morning! But here the time is wrong, time stops when switched off!
     

    #43
  4. sunnyshaan
    Honeycomb Dec 16, 2015


    #44
  5. rockuppl
    Gingerbread Dec 16, 2015

    rockuppl , Dec 16, 2015 :
    CyanogenMod 12.1 for OnePlus X (E1001/E1003/E1005)

    [​IMG]
    Disclaimer: Rooting does not void the OnePlus X’s warranty, though damaging your hardware (i.e., burning up your CPU by overclocking, hard bricking the device) will. You proceed at your own risk! I accept no responsibility for what you do with your phone. Follow the directions closely, and the odds are you will succeed without any trouble. If you are not sure what you are doing, do some more research before you try. If you get confused with terminology, try looking here for answers or Google it. If you get stuck, post a question in the thread— I 'll help you.

    >This is an unofficial build of CyanogenMod 12.1 made by @MasterAwesome<

    ***Custom Kernels(blu_spark) is not compatible with this rom***

    Installation Procedure (First time Installations)

    • Nandroid Backup using TWRP
    • Wipe /System /Data /Cache /Dalvik
    • Install Cyanogen Mod 12.1 -------LINK-------
    • Install Gapps(Prefer Slim Gapps) -------LINK-------
    • Install Super Su -------LINK-------
    • Reboot System
    Bugs:
    No Major Bugs but still as ROM is in it's developmental stage, a few minor bugs can show up

    **A Daily Driver for me with no bugs at all **
    Contributers:

    >MasterAwesome (XDA Thread Link)
    >Cyanogen Inc.

     

    #45
  6. Funk Wizard
    Moderator Moderator Dec 16, 2015

    Funk Wizard , Dec 16, 2015 :
    Please search the right section before creating a thread, Moved and Merged
     

    #46
  7. vaupi
    Gingerbread Dec 16, 2015

    vaupi , Dec 16, 2015 :
    can somebody answer my question please?
     

    #47
  8. duvelyonker
    Honeycomb Dec 16, 2015


    #48
    vaupi likes this.
  9. vaupi
    Gingerbread Dec 16, 2015


    #49
  10. duvelyonker
    Honeycomb Dec 16, 2015

    duvelyonker , Dec 16, 2015 :
    theme manager is a killer feature of CM vs oxygenOS
     

    #50
  11. duvelyonker
    Honeycomb Dec 16, 2015


    #51
  12. aich
    Donut Dec 18, 2015

  13. darthrider
    Froyo Dec 23, 2015


    #53
  14. vaupi
    Gingerbread Dec 23, 2015

    vaupi , Dec 23, 2015 :
    So, ambient display is working in 5.0?
    Also haptic feedback on capacity buttons?
    I tested 3.0...it was really nice...but i cjanged back to oos with blu...
     

    #54
  15. legendary_knight
    Gingerbread Dec 23, 2015

    legendary_knight , Dec 23, 2015 :
    when i selected boot loader for fastboot mode my mobile is on the same screeen showing 1+ fastboot mode no matter even for 5 mins its same. is it take usally same time like this r it's an issue can anyone help me out ?
     

    #55
  16. vaupi
    Gingerbread Dec 23, 2015

    vaupi , Dec 23, 2015 :
    normal behaviour...fastboot mode is for adb connection with a pc...you will always see a screen with the 1+logo and fastboot mode...
    i think you want to go to recovery mode...
     

    #56
    legendary_knight likes this.
  17. anast68
    Cupcake Dec 23, 2015


    #57
  18. darthrider
    Froyo Dec 24, 2015

    darthrider , Dec 24, 2015 :
    Ambient display was removed in 5.0 and reenabled in 6.0.
    Now 6.0 as per the changelogs fixes most of the stuff.(yet to try it out)
     

    #58
  19. legendary_knight
    Gingerbread Dec 24, 2015

    legendary_knight , Dec 24, 2015 :
    i tried it says installation failed or insufficient space less than 500Mb kinda when i retry. Even i have more than 1Gb it shows these two messages alternative
     

    #59
  20. anyonex
    Cupcake Dec 27, 2015

    anyonex , Dec 27, 2015 :
    Hello to all,

    I posted a message few days ago in a related thread on OP X forum (https://forums.oneplus.net/threads/masterawesome-cm-12-1-stable-for-opx.419251/), but maybe some others OP X owners could be concerned / interested by this.

    Thus, I make hereafter a copy / paste of this message :



    Is it just for me on my OPX, or some of you also have experienced on CM 12.1 (and derived mods) that your external SD card (exfat formatted, for me) is no longer recognised after a while and thus no longer being accessible after a few moments (ie. explorer saying that "location does not exist"); this occurring randomly and not symptomatic of any action or app launch?
    To fix it, I found no other way to reboot the phone (until it arrives again after a while)… I thus cannot use this system on a regular basis, because the majority of my data are located on my SD card (DCIM, GPS maps, Downloads, Music, Movies, Sounds, …)
    I noticed this issue is happening for CM12.1 and every related mod inspired from it (I tried Mokee, Resurrection, ...) ; and for every install I made a clean flash (wipe Dalvik and Cache, Data and system) before install)…
    I use the kernel optimised by eng.stk (blu_sp★rk r68), but I do not think this could be the cause (because EVERYTHING seem to work fine with this ROM). Do you?
    Otherwise, everything else seem just to be fine! for CM 12.1

    However everything is working well when I am on OOS (2.1.3.x)...

    What is annoying / disturbing / questioning is that I did not read anything about this kind of issue on any forum about OPX and/or CM 12.1... Am I the only one having the privilege to encounter my own, private, particular, original issue?

    Can someone have experienced such a problem related to this in CM and derived OSes?

    Thank you for any kind of help about this!

    A.
     

    #60