48
ROM [ROM][LineageOS][Android 6.0.1] TugaPower

  1. msri3here
    Ice Cream Sandwich Nov 1, 2015

    msri3here , Nov 1, 2015 :
    Is it just me or is anyone facing issue with google contact sync?
    After installing gapps, "contacts" doesn't show in google sync options.
     

    #81
  2. Roshanghosh09
    Ice Cream Sandwich Nov 1, 2015

    Roshanghosh09 , Nov 1, 2015 :
    I m trying to flash 1/11 build as secondary rom but getting error stating that the firmware isn't updated...
    M on multirom TWRP 2.8.7. Followed all the steps said by @msri3here few pages back...
    M currently using the latest build of sultan's cm12.1 unofficial caf rom with stock kernel...
    Can someone plz help me out with my problem?
     

    #82
  3. TugaPower
    Jelly Bean Nov 1, 2015

    TugaPower , Nov 1, 2015 :
    Over mine it appears over Accounts.

    Flash TWRP 2.8.6.0 , then flash firmware. Its well know problem relative to new TWRP.
     

    #83
    Roshanghosh09 likes this.
  4. Roshanghosh09
    Ice Cream Sandwich Nov 1, 2015

    Roshanghosh09 , Nov 1, 2015 :
    but after flashing twrp 2.8.6.0 the multirom twrp doesnt appear. so how can i get it on multirom?
     

    #84
  5. TugaPower
    Jelly Bean Nov 2, 2015

    TugaPower , Nov 2, 2015 :
    Flash TWRP 2.8.6.0 , then flash firmware, then re flash twrp multi-rom. Then you can flash ROM.
     

    #85
    pikota and Roshanghosh09 like this.
  6. Roshanghosh09
    Ice Cream Sandwich Nov 2, 2015

    Roshanghosh09 , Nov 2, 2015 :
    Cool will give it a try n ll get back to u...
    Thnx alot buddy...
    N keep rocking mahn.

    Edit: it worked buddy...
    Thnx alot..
    Noticed few bugs till now that I would like to mention...
    1. Titanium backup FC and unable to backup apps n data using it.
    2. HW keys light cannot be turned off.
    3. Few settings missing.
    4. Multiwindow feature missing.
    5. While making an outgoing call the phone freezes and occurs soft reboot.

    Hats off buddy fr ur hard work...
    Lookin forward for nxt build
     
    Last edited: Nov 2, 2015

    #86
  7. msri3here
    Ice Cream Sandwich Nov 2, 2015

    msri3here , Nov 2, 2015 :
    Can you pls post a screenshot. Here's mine. Nothing here

    Did you fash 5.1 gapps before flashing 6.0 gapps?
     

    Attached Files:


    #87
  8. Gurutv
    Cupcake Nov 2, 2015


    #88
  9. TugaPower
    Jelly Bean Nov 2, 2015

    TugaPower , Nov 2, 2015 :
    Why are you flashing gapps 5.1? To night beta 0.5
     

    #89
  10. TugaPower
    Jelly Bean Nov 2, 2015

    TugaPower , Nov 2, 2015 :
    Build 2/11/2015

    TugaPower ROM G+

    #TugaPower vRC 1.0 CM13 #OnePlus #Android 6.0

    Change log:

    Importante:
    Even comming from another 6.0 base you must flash GAPPS...
    So, if you use OTA built in to flah after download, after reboot you must go again to recovery and flash Gapps.
    Still trying to find this issue.
    Something commited some days back because its happen in CM12.1 builds it also happens.
    If phone trow a bunch of FCs afeter boot make a factory reset.
    Then everything will be OK. Some sorter, dont forget this its still in progression :)
    Boot takes more time but dont horry, just wait, phone will boot.
    Just make a factory reset if you are in other base ROM just in case.
    This its WIP and you will find errors...

    Fixed Bluetooth
    Fixed Calls ( Ongoing/Incoming )
    Fixed Titanium Backup
    Kernel RC1 patched to multi-rom support - https://goo.gl/TFjSMj
    Powered by SuperSU 2.52
    More bugs to find...

    ROM script its improved, if you dont meet the firmware requisites ROM will not flash, you can find Firmware zip in the botton of post

    -- Change-log from Sync with CM Reposotories --

    power-8974: Implement bias modes for 8974
    power-8994: add support for bias modes on 8994
    Give Color32 weak attribute
    Opt out of clang till issues are fixed
    Update hooks and libaray dependency
    policy_hal: Fix build with Clang
    art: Build compiler with GCC if QC extension is used
    busybox: Disable build with Clang for now

    system_core cganhelog: http://pastebin.com/3UaHtuht

    Merge branch 'LA.BF.1.1.3_rb1.3' of git://codeaurora.org/platform/vendor/qcom-opensource/bluetooth into cm-13.0
    Merge "BTLogSave: Permissions check on Runtime"
    AppOps: relax some system appops for systemui
    SystemUI: Fix padding for text & hidden battery style
    Screenshots info is not updated when device is plugged in MTP mode
    base: Add theme support to Ringtone and Profile pickers activities
    location: Fix incorrect unused argument workaround
    power: Add CM performance manager
    Remove Qualcomm BoostFramework
    Merge branch 'cm-12.1' of git://github.com/CyanogenMod/android_packages_providers_DownloadProvider into cm-13.0
    DownloadProvider: Automatic translation import
    Fixed application/octet-stream to guess mimetype
    libc: arm: add optimized memchr implementation
    build: create dt.img task
    build: fix dopush with zsh
    build: Add support for device tree in boot.img
    build: Add -mfpu=neon-vfpv4 if cpu is krait
    stagefright: Fix size of metadata key
    Screenshots info is not updated when device is plugged in MTP mode
    cameraservice: Resolve message vs start/stop preview races
    camera: add ability for a device to specify MAX_CAMERAS
    Camera: Added null check for memory reference
    Camera: Support obtaining camera memory from MemoryHeapIon
    camera: Allow hardware/camera.h header to be overridden
    Revert "video: Avoid writing 0 sample count ctts entry"
    RTSP: add default implementations in NuPlayer for rtsp changes
    video: Avoid writing 0 sample count ctts entry
    nuplayer: Fix de-referencing NULL mSource
    Camera: frameworks: Add NULL check for callback
    stagefright: Remove additional deep-copy of encoder buffers
    ffmpeg: Don't build with Clang for now
    bacon Loosen up vsync phase offsets
    bacon: Enable performance profiles
    bacon: Fix SEPolicy denial in camera
    bacon: Fix GPS HAL compilation with Clang
    Merge "A2DP Sink: AudioTrack changes"
    Merge "Bluetooth: Create Custom Intent to avoid Force close."
    Merge "Bluetooth: Fix to avoid PAN JNI crash due to ENABLE_TIMEOUT"
    Merge "A2DP Sink: Fix the issue with A2DP connection"
    display: Fix issues when building with Clang

    Android_system_bt changelog: http://pastebin.com/fCabPJaV

    Screenshots info is not updated when device is plugged in MTP mode
    MediaProvider: Avoid null pointer exceptions inside getCompressedAlbu
    Automatic translation import
    mediaprovider: Add theme support to Ringtone activity
    MediaProvider: Avoid issue of android.process.media stop
    unrar: Disable Clang build
    stagefright-plugins: Fix compilation issues with Clang
    sepolicy: Include CM+QCOM SEpolicy
    Keymaster: Check if keymaster TZ app is loaded
    media: Fix issues when building with Clang
    Revert "hwc: Skip load based composition for video playback."
    printk: remove unused code from kernel/printk.c
    Revert "printk: fix buffer overflow when calling log_prefix function from call_console_drivers"
    printk: convert byte-buffer to variable-length record buffer
    kmsg: export printk records to the /dev/kmsg interface
    kmsg: use do_div() to divide 64bit integer
    printk: fix regression in SYSLOG_ACTION_CLEAR
    net: fix iterating over hashtable in tcp_nuke_addr()
    mm: mmap: Add new /proc tunable for mmap_base ASLR.
    arm: mm: support ARCH_MMAP_RND_BITS.
    Revert "SELinux: ss: Fix policy write for ioctl operations"
    Revert "SELinux: use deletion-safe iterator to free list"
    Revert "SELinux: per-command whitelisting of ioctls"
    Revert "security: lsm_audit: add ioctl specific auditing"
    selinux: remove unnecessary pointer reassignment
    security: add ioctl specific auditing to lsm_audit
    selinux: extended permissions for ioctls
    selinux: Android kernel compatibility with M userspace
    USB: gadget: midi: Fix deadlock unbinding driver while it is in use
    USB: gadget: mtp: Fix hang in ioctl(MTP_RECEIVE_FILE) for WritePartialObject
    usb: gadget: audio: Fix problem resuming playback on alt interface change
    USB: gadget: f_mtp: Fix integer overflow when transferring large files.
    USB: gadget: android: Integrate f_midi USB MIDI gadget driver
    bacon: Update defconfig
    keyhandler: Add wakeup reasons to PM calls
    torch_gesture: Use Android M setTorch instead of TorchManager
    Settings: Add preference for EdgeGesture service.
    Use 100K steps for color temperature sliders.
    Update example backup-transport resource overlay
    update app ops
    binder: MemoryHeapIon: fix unused parameters
    binder: Squashed commit of MemoryHeapBaseIon
    manifest: Point to CM forks of CarrierConfig, ExactCalculator
    manifest: Switch to new shiny messaging app from AOSP
    Trebuchet: Update default workspace to GMS 3.0 req
    su: update app ops index

    ROM -> https://goo.gl/HDIxAp

    Mirror MegaUpload -> https://goo.gl/smnNYD

    Mirror Android File Host -> https://goo.gl/LT2uEG

    MD5: 90500d2a3ad4197a5c4efc5c76252f90

    Gapps Download Android 6.0-> https://goo.gl/GYAJYF

    Happy flashing

    Firmware parts Recommended for better function over TugaPower ROM, flash this if ROM Flash gives firmware error
    Meocloud Firmware Download -> https://goo.gl/NV6OeM
    Mirror Mega Download -> https://goo.gl/5PZFMU

    MD5: 09411ce520b4916e2ce007dfa4af7e53

    Source:
    CyanogenMOD https://github.com/CyanogenMod

    [​IMG]
     
    Last edited: Nov 2, 2015

    #90
    pikota, Roshanghosh09 and msri3here like this.
  11. TugaPower
    Jelly Bean Nov 2, 2015


    #91
    pikota and Roshanghosh09 like this.
  12. Roshanghosh09
    Ice Cream Sandwich Nov 3, 2015

    Roshanghosh09 , Nov 3, 2015 :
    Tried updating to latest build...
    But getting a kernel related error msg...
    Don't remember the exact msg...
    Followed the following steps:
    1.flashed latest build
    2. Flashed gapps
    3. Flashed Rc1 kernal patch...

    PS. Flashing it as secondary ROM...


    Edit : I get an error msg stating " Kexec-hardboot required"
     
    Last edited: Nov 4, 2015

    #92
  13. mad-scientist
    Gingerbread Nov 3, 2015


    #93
  14. zjxpot
    Gingerbread Nov 3, 2015

    zjxpot , Nov 3, 2015 :
    did you try reading at least the OPs before posting?
     

    #94
  15. zjxpot
    Gingerbread Nov 3, 2015

    zjxpot , Nov 3, 2015 :
    search this thread or try reading it has been already answered...
     

    #95
  16. zjxpot
    Gingerbread Nov 3, 2015

    zjxpot , Nov 3, 2015 :
    @TugaPower or anyone-else I am having problems dialing extensions after making initial call and I am prompted to dial extension, I dial it eg4543 it appears on the dial pad but its not recognize as actual digits
    can you or any one try dialing into an office where you have to dial ext.x just want to know if it's just me
     

    #96
  17. Rasimsson_SA
    Gingerbread Nov 3, 2015

    Rasimsson_SA , Nov 3, 2015 :
    I get a boot loop when flashed as secondary ROM...

    Steps:

    Flash ROM
    Flash KernelPatch
    Reboot

    Stuck in boot loop :(
     

    #97
  18. Roshanghosh09
    Ice Cream Sandwich Nov 4, 2015

    Roshanghosh09 , Nov 4, 2015 :
    I m following this thread since day 1 bro...
    I didn't find ans to my query...


    Edit : I get an error msg stating " Kexec-hardboot required"
     
    Last edited: Nov 4, 2015

    #98
  19. TugaPower
    Jelly Bean Nov 4, 2015

    TugaPower , Nov 4, 2015 :
    It seems kernel must be flashed with rom to multi boot work, RC 2.0 will comme today and multi rom patch it's already included. As by pass you can try replace the stock kernel inside the rom zip by the kernel patch zip and re flash rom / gapps.
    Also don't forget your frist rom must have also a kernel patched to work with multi rom.
     

    #99
    Roshanghosh09 likes this.
  20. TugaPower
    Jelly Bean Nov 4, 2015

    TugaPower , Nov 4, 2015 :
    No problems over mine, just tested right now. Although my rom it's RC 2.0
    Stay tunned to OTA over the day/end of day...