58
ROM [ROM][LineageOS][Android 7.1.2][OMS7] TugaPower

  1. TugaPower
    Jelly Bean Oct 9, 2016

    TugaPower , Oct 9, 2016 :
    Build 08/10/2016

    TugaPower ROM G+

    Telegram Group: https://telegram.me/TugaPowerRom

    Telegram Channel: https://telegram.me/TugaPowerOnePlusOne

    #TugaPower N 0.9.1 RC CM14 #OnePlus #Android 7.0

    If you have some spare bucks consider donating, it will be really appreciated: https://www.paypal.me/TugaPower

    Please be sure you are using one TWRP that can handle firmware flash.
    Also be sure you are using proper firmware. The one recomended its the one from cm 13 nighly, you can find here: https://meocloud.pt/link/54c1eb88-f902-4411-aa7a-e1872ac5a47a/TugaPowerFirmwareCM13_v4.zip

    Here you have a build by me of TWRP: http://forum.xda-developers.com/oneplus-one/development/unofficial-twrp-3-0-x-tugapower-t3398366

    Relative to gapps, testing open gapps 7.0 nano package, working without issues

    http://opengapps.org/?api=7.0&variant=nano

    ROM have OTA updates already implemented, so next update you will be receving notification update, configure the CM Updater ( TugaPower ROM Updates) check sheduler.
    Kernel its permissive
    Gello removed and replaced by latest TugaBrowser beta v52.x Stable ( built in OTA for the Browser ) ( blocks ads and protect privacy)
    TugaBrowser -> http://forum.xda-developers.com/android/apps-games/app-tugabrowser-t3472457
    Viper4Android included and removed audiofx
    Multi ROM support out of the box
    Kcal control included ( use Color control included to tune RGB )
    Powered by SuperSU 2.78 SR1 by @Chainfire
    Full support for suhide out of the box, just flash latest suhide after rom flash, nothing more to do, this will survive next OTAs but the list is reseted each OTA, will see with chainfire a temp solution for this.
    Support out of the box to microG GmsCore ( http://forum.xda-developers.com/android/apps-games/app-microg-gmscore-floss-play-services-t3217616 )
    MicroG is still not working, it need new update to work on Nougat but the support its already present.


    What does not works:

    Settings/Status bar options its not working very good

    Change log:

    Project name: android_frameworks_base
    SystemUI: Enable three icon switching within QS DND tile
    SystemUI: statusbar: Fix status bar brightness control feature
    Revert "SystemUI: Add support for charging animation"
    SystemUI: statusbar: Fix QS quick pulldown feature
    SystemUI: tuner: Fix up button navigation in activity

    Project name: android_packages_apps_Stk
    Stk: New launcher icon

    Project name: android_packages_apps_CMParts
    CMParts: Notification light: Fix for app customization
    cmparts: Make CMParts searchable
    cmparts: Change how parts are launched
    CMParts: statusbar: Add double-tap to sleep switch
    CMParts: Navigate back only when up button is enabled

    Project name: android_packages_apps_Settings
    settings: Correctly index SwitchPreferences
    Settings: Fix possible NPE
    Settings: add package name to app info
    Revert "Settings: Display percentage power"
    Settings: remove double press power for camera from Display

    Project name: android_packages_apps_Eleven
    Eleven: Correctly set shake to play
    eleven: Add support for the MediaSession queue

    Project name: android
    Use clone-depth="1" for all pre-built projects.

    Project name: android_vendor_cm
    extract_utils: Do not change app SRC if there are arguments

    Project name: cm_platform_sdk
    cmsdk: Add search resources plumbing for CMParts
    cmsdk: Change how parts are launched



    Download link:

    MeoCloud: https://meocloud.pt/link/8da5b977-4221-416a-9737-52de3911fd5e/TugaPowerN091RC.zip/

    Gdrive: https://drive.google.com/file/d/0ByxlOYAKcbyTRm9Wc3p4bzRLRnc

    Mega: https://mega.nz/#!xUNn1JCD!PsBSeTaDfeb641uOPCwgnJoKcmX30Ss43q0Z0I8wFOA

    Android File Host: https://www.androidfilehost.com/?fid=457095661767100371

    MD5: 891d397b59b389439a121c6293ed741b

    Please dont mirror for now the roms zips, thanks


    Special thanks to @amardeep434 for initial work on making booting and also big thanks for @updateing
     

    reder77, Milan34119, jstepa and 2 others like this.
  2. csabreu
    Ice Cream Sandwich Oct 9, 2016

    csabreu , Oct 9, 2016 :
    You have to enable on-screen navigation bar. Multi-window won't work with hardware button I think.
     

  3. mickcost
    Honeycomb Oct 10, 2016

    mickcost , Oct 10, 2016 :
    Thanks
     

  4. se7enlyn
    Ice Cream Sandwich Oct 10, 2016

    se7enlyn , Oct 10, 2016 :
    you don't need to disable hardware buttons for it to work
     

  5. se7enlyn
    Ice Cream Sandwich Oct 10, 2016

    se7enlyn , Oct 10, 2016 :

    tap menu button
    recent apps will appear
    choose the app you want
    long press and drag the app to the top of the screen
    choose the second app and drag it to the bottom of the screen
     

    tye359, mickcost, Milan34119 and 2 others like this.
  6. csabreu
    Ice Cream Sandwich Oct 10, 2016

    csabreu , Oct 10, 2016 :
    Thanks for the info. Thus, it works a little different from the on-screen nav bar, where long pressing splits the window in two automatically.
     

    se7enlyn likes this.
  7. Xeph20
    Ice Cream Sandwich Oct 10, 2016


  8. ramcon12
    Gingerbread Oct 10, 2016

    ramcon12 , Oct 10, 2016 :
    No, you can use multi rom and have both
     

  9. Xeph20
    Ice Cream Sandwich Oct 10, 2016

    Xeph20 , Oct 10, 2016 :
    Yeah I have that now. Problem is i have a thumbnail issue on cm13 which can even freeze my opo and force reboot. So i want to change roms but want to keep all my apps and settings.

    Not enough storage on my opo for a full nandroid backup and otg mounting doesn't work in my TWRP...

    Jajajajaja
     

  10. ramcon12
    Gingerbread Oct 11, 2016

    ramcon12 , Oct 11, 2016 :
    mmmm thats bad. I wanted to do the same thing but decided to use Tuga with multirom and install everything again. Phone feels very smooth so yesterday I decided to swap Tuga for CM13 as my primary rom an leave CM13 as secondary just in case
     

  11. mickcost
    Honeycomb Oct 11, 2016

    mickcost , Oct 11, 2016 :
    Thanks: with your instructions, mutliwindows mode is OK!
     

    se7enlyn likes this.
  12. avibored
    Honeycomb Oct 12, 2016

    avibored , Oct 12, 2016 :
    Did anyone try getting Google assistant on this build by changing build.prop . . Does it work ?
     

  13. rajaspardeshi
    Ice Cream Sandwich Oct 12, 2016

    rajaspardeshi , Oct 12, 2016 :
    I'm having issues with tuga browser, any attempt to tap to search results in the app crashing. Any solutions?
     

  14. rajaspardeshi
    Ice Cream Sandwich Oct 12, 2016

    rajaspardeshi , Oct 12, 2016 :
    It works
     

  15. TheRealProcyon
    Jelly Bean Oct 12, 2016


  16. djmoderate
    Eclair Oct 12, 2016

    djmoderate , Oct 12, 2016 :
    How did you get it to work? Google FC's every time on me.
     

  17. rajaspardeshi
    Ice Cream Sandwich Oct 13, 2016

    rajaspardeshi , Oct 13, 2016 :
    Flashed the zips in order, and it works like it should in the first go. Only thing is, you cant use ok Google(yet).
     

    djmoderate and se7enlyn like this.
  18. ziepicwaffle
    Ice Cream Sandwich Oct 13, 2016

    ziepicwaffle , Oct 13, 2016 :
    You need to clear the cache (or data) of the Google app. I haven't tried it yet but I know that is one of the steps.
     

    se7enlyn likes this.
  19. ramcon12
    Gingerbread Oct 13, 2016


  20. djmoderate
    Eclair Oct 13, 2016

    djmoderate , Oct 13, 2016 :
    Oh ok. Yea I got it working. It kept asking to set it up every time I said, "Ok Google" and was a bit frustrated, but holding the nav home button will do just fine. Appreciate the help!
     

    rajaspardeshi likes this.