7
Rooted OxygenOS 11 on my OnePlus 7 Pro via OnePlus 7 Pro

  1. Dave1482
    Ice Cream Sandwich Mar 25, 2021

    Dave1482 , via OnePlus 7 Pro , Mar 25, 2021 :
    Welp, I managed to update my rooted OnePlus 7 Pro to OxygenOS 11! However, I cannot recommend anyone to update to it because you lose TWRP (currently no support on OOS 11), Magisk Modules don't work (all of them need to be disabled to boot), and Swift Installer (theming with root) does not work either. I will continue to use it, but I suggest anyone to just wait for Magisk and TWRP to get updated.

    UPDATE: It turns out the issues with Magisk were due to an old version of the Taichi module. TWRP 3.5.1_9-0 has been installed but won't boot.
     
    Last edited: Mar 27, 2021

    #1
  2. R.Peter
    Ice Cream Sandwich Mar 25, 2021

    R.Peter , Mar 25, 2021 :
    TWRP 3.5.1 support Android 11. You can find that for OP7pro here: dl.twrp.me/guacamole
    Magisk 21 should work on A11, they prepared for the release long ago. Head over here to download that.

    "Magisk v21.0
    ...
    ...
    It comes with full Android 11 support (tons of stuff had to be rewritten from scratch!), and a completely redesigned Magisk Manager. ..."
     

    #2
  3. UzziBoy
    Cupcake Mar 26, 2021

    UzziBoy , Mar 26, 2021 :
    TWRP 3.5.1 is not supported, phone stuck in fastboot mode, not booting into recovery.
     

    #3
    Sudhop likes this.
  4. Raven6681
    Froyo Mar 26, 2021

    Raven6681 , Mar 26, 2021 :
    Yes I encountered the same. I had to extract boot.img from the stable 11 rom and flash it via fastboot
     

    #4
    UzziBoy likes this.
  5. Raven6681
    Froyo Mar 26, 2021


    #5
    rsaloskar, sefsef_BJ and UzziBoy like this.
  6. sefsef_BJ
    Eclair Mar 27, 2021

    sefsef_BJ , Mar 27, 2021 :
    thanks a lot for your answer, it helped me !
    I wanted to ask you if your phone takes a long time booting and if your wifi works or not
    thanks
     

    #6
  7. sabbeman
    Eclair Mar 28, 2021

    sabbeman , Mar 28, 2021 :
    I agree! Got the same problem now!
     

    #7
  8. humood96
    Donut Mar 29, 2021

    humood96 , Mar 29, 2021 :


    Its working but there is alot of problems for example you can't reboot your phone , and the WIFI is not Working.

    Please inform us if you get a problem ?
     

    #8
  9. kawnoz
    Cupcake Mar 29, 2021


    #9
  10. Huntermonk
    Cupcake Mar 30, 2021

    Huntermonk , via OnePlus 7 Pro , Mar 30, 2021 :
    (desculpe digitar em português mas prefiro que você traduza pelo Google para não ter erros) vc usou o TWRP A/B Retention Script ?

    Em um update com root o máximo que pode acontecer é perder o root e twrp ou pode dar soft/hard brick ?
     

    #10
  11. JB Petersen
    Cupcake Mar 31, 2021

    JB Petersen , Mar 31, 2021 :

    Hi Raven. Did you have success on rooting your device? I bricked mine, and got the working phone back. But without root android 11 is not worth the "upgrade" : ] Adaway and magisk hide are essential to my phone environment...
     

    #11
  12. guilhermenbf
    Cupcake Mar 31, 2021


    #12
  13. mwdle
    Cupcake Apr 1, 2021

    mwdle , Apr 1, 2021 :
    So has anyone had any luck rooting by only patching the boot.img using magisk and installing (TWRP not involved whatsoever)? What I mean is has anyone successfully rooted on the Android 11 stable build for OP7Pro and not had issues with magisk and other root functions?
     

    #13
  14. Sudhop
    Cupcake Apr 1, 2021


    #14
  15. rsaloskar
    Cupcake Apr 2, 2021

    rsaloskar , Apr 2, 2021 :
    Followed the Guide and now rooted OOS 11 on 7PRO. TX.

    - I was rooted before and had modules installed. I Did get bricked before as i flashed TWRP on OOS11 later came to know that there are problems with OOS11 with normal root method. was stucked on booting. TWRP was not able to mount storage.
    - So later flashed stock ROM from oneplus site by sideloading with TWRP to get it working. Data completely wiped.
    - Could have restored if already had put it on PC.
    - Downloaded Latest OOS11 OTA from OxygenUpdater app. Took it to PC.
    - Extracted boot.img from it (Payload Dumper).
    - Booted with TWRP on stock ROM fastboot. Do not flash it only boot.
    - Flashed Latest OOS11 OTA update with TWRP. wiped dalvik.
    - Booted normally.
    - Installed Magisk v 22.0 app.
    - Copied extracted boot.img on the phone storage
    - Patched with Latest Magisk v 22.0
    - Copied it to PC
    - Flashed the patched boot.img in fastboot
    - Done.
    - Magisk hide works. safety net passed after a reboot.
    - wifi works, data works.
    - Banking apps worked, adaway rooted method worked.
    - You may me able to get it working normally if you already create the patched boot.img from OTA and flashed immediately after upgrade in fastboot. These are overview steps. refer links in the quoted msg for details.
     
    Last edited: Apr 2, 2021

    #15
  16. JB Petersen
    Cupcake Apr 2, 2021

    JB Petersen , Apr 2, 2021 :
    EDIT: I don't have android 11.For some reason it's version 10.0.11 and the support page now claims that is the latest version for my 7 pro...? Anyways, root, adaway, magisk hide and debloat is better than a bad android 11 😅

    I just did it too! Topjohnwu 's guide is correct, but it is easy to mess up:

    You should be able to extract the file you need from official firmware packages or your custom ROM zip (if using one). If you are still having trouble, go to XDA-Developers and look for resources, guides, discussions, or ask for help in your device’s forum.

    • Copy the boot/recovery image to your device
    • Press the Install button in the Magisk card
    • If you are patching a recovery image, make sure “Recovery Mode” is checked in options.
      In most cases it should already be automatically checked.
    • Choose “Select and Patch a File” in method, and select the stock boot/recovery image
    • The Magisk app will patch the image to [Internal Storage]/Download/magisk_patched_[random_strings].img.
    • Copy the patched image to your PC with ADB:
      adb pull /sdcard/Download/magisk_patched_[random_strings].img
    • Flash the patched boot/recovery image to your device.
      For most devices, reboot into fastboot mode and flash with command:
      fastboot flash boot /path/to/magisk_patched.img or

    • Reboot and voila!

    I pulled the boot from the latest update, using python ( https://nerdschalk.com/how-to-extract-payload-bin-from-ota-update-or-firmware/ ).

    I made a TOTALLY CLEAN install of the latest version (failed a few times rooting, so wiped anyways)

    I enabled USB debugging (tap build version 10 times -> developer settings -> usb debugging

    I transferred magisk apk and the boot.img to my phone manually

    Installed magisk

    Patched as in his guide

    MADE SURE TO USE ADB pull command to get the patched file

    rebooted to fastboot and used fastboot flash boot /path/to/magisk_patched.img (use the name that your patched file will get. It will say the name in magisk and the file will end up, where your working fastboot folder is)

    reboot - And IT finally worked!
     
    Last edited: Apr 2, 2021

    #16
  17. ChristianLotino
    Gingerbread Apr 2, 2021


    #17
  18. JB Petersen
    Cupcake Apr 2, 2021

    JB Petersen , Apr 2, 2021 :
    No. There are many things that actually can be more secure (like your privacy). There will always be warnings,but for nowyou should google if rooting is for you
     

    #18
    ChristianLotino likes this.
  19. Bolden
    Cupcake Apr 5, 2021

    Bolden , Apr 5, 2021 :
    So i decided to root my phone. And the guide that i followed worked perfectly fine, until i realized that twrp was not supported on the build that i am on.. Which left me in a brick state basically. And as I am totally new to this world, i did not know to get the stock boot.img file from my phone.

    So i had to download one of the stable builds online. Unfortunately that has left me with a crazy long boot and wifi not working on my phone anymore. So what i was wondering was, if anyone is running the same build as me and they extracted the boot.img, could i flash that and get it running again?

    If so, does anyone happen to have the boot.img that i need.

    I am running Oxygen OS 11 - Build 11.GM21BA
    Model GM1913
    Based in EU if that matters

    _________________________
    Edit: was able to download the full stable build on the phone and "upgrade" to it.
     
    Last edited: Apr 5, 2021

    #19
  20. Raven6681
    Froyo Apr 7, 2021

    Raven6681 , Apr 7, 2021 :
    No I don't have any issues, maybe clear cache?
     

    #20