6
OxygenOS Running apps (runkeeper, polar beat) closing since Nougat update

  1. Willie Hurx
    Froyo Jan 20, 2017

    Willie Hurx , Jan 20, 2017 :
    I use my phone to record my runs. Since the update to Nougat I'Ve a problem that the apps close automaticly after a while. When I was on MM there was never such a problem. On 31 dec I ran for about 2h and it worked great. Then on 4 january the app stopped during a run after about 20min. The next run I tried another app, but the same result, it stopped after a while.
    The options in battery managment are both off.
    Anyone having such a problem?
     

    #1
  2. iboj007
    Gingerbread Jan 26, 2017

    iboj007 , Jan 26, 2017 :
    Having this exact same issue on the latest Nougat update with Endomondo to track exercise with a bluetooth LE heart rate monitor (Polar H7).

    Often it will run for 30 mins often it will run for 5-10 mins and then automatically close out.
     

    #2
  3. Willie Hurx
    Froyo Jan 26, 2017

    Willie Hurx , Jan 26, 2017 :

    To bad that I'm injured at the moment so I can't try out because I've heard there is a solution.
    Open yor running app, go into the recent screen and then lock your app (close the lock at the sign) . That should to the thing. Maybe you can try it and let me know because I can"t run for a few weeks with my runners knee :(
     

    #3
    binki likes this.
  4. G_Dudu_Maroja_kOZh
    Eclair Jan 28, 2017


    #4
    iboj007 and Willie Hurx like this.
  5. Willie Hurx
    Froyo Jan 28, 2017


    #5
  6. G_Dudu_Maroja_kOZh
    Eclair Jan 28, 2017


    #6
  7. G_Dudu_Maroja_kOZh
    Eclair Jan 28, 2017


    #7
  8. anandbibek
    Gingerbread Jan 28, 2017

    anandbibek , Jan 28, 2017 :
    Go to settings -Battery - press right upper corner menu - Aggressive Doze and App Hibernation - DISSSAABLE THE SH*T
     

    #8
    airiartev likes this.
  9. Willie Hurx
    Froyo Jan 28, 2017

    Willie Hurx , Jan 28, 2017 :
    1485644096083.jpg

    1485644096181.jpg
    In right hand upper corner.. Open and closed... Plz tell me if it helped.. I'm injured at the moment so can't try it myself
     

    #9
  10. Willie Hurx
    Froyo Jan 28, 2017

    Willie Hurx , Jan 28, 2017 :

    Doze was already disabled... Both options.... But thnx anyway
     

    #10
  11. anandbibek
    Gingerbread Jan 29, 2017

    anandbibek , Jan 29, 2017 :
    Try another.

    Settings - Advanced - Recent apps clear mode - Normal clear.

    Also try

    Settings - Apps - Cogwheel in right top - Apps auto launch - Disable
     

    #11
  12. Willie Hurx
    Froyo Jan 29, 2017

    Willie Hurx , Jan 29, 2017 :
    Didn't change those settings and they are both as you said... That's the default setting I think.. But thnx for helping
     

    #12
  13. G_Dudu_Maroja_kOZh
    Eclair Jan 29, 2017

    G_Dudu_Maroja_kOZh , Jan 29, 2017 :
    the lock icon in the "recent apps screen" does not work, app closes anyway

    agressive doze is disabled.

    anyone tried on a custom ROM like cm?
     

    #13
  14. Willie Hurx
    Froyo Jan 29, 2017


    #14
  15. iboj007
    Gingerbread Jan 31, 2017


    #15
  16. iboj007
    Gingerbread Jan 31, 2017

    iboj007 , Jan 31, 2017 :
    Also want to note that I've tried clearing cache from recovery, deleting app data and cache, deleting device cache. All failed as well. Also, have tried uninstalling and re-installing the app in question and it also failed.
     

    #16
  17. Kristijan Puljek
    Gingerbread Jan 31, 2017

    Kristijan Puljek , Jan 31, 2017 :
    Does it stop when the phone is "idle" for 20 minutes or it doesn't matter? I currently can't run due to some health issues, but I took a couple of walks with Runkeeper and it worked fine. Walks being walks, I played with the phone occasionally, skipped songs and checked notifications, so that's why I'm asking if it makes a difference.

    I'm gonna be so pissed off if this starts happening when I'll be able to finally run again. Here's to updates!
     

    #17
    Willie Hurx likes this.
  18. Willie Hurx
    Froyo Jan 31, 2017

    Willie Hurx , Jan 31, 2017 :
    This is another sollution from someone on xda forum

    1485870328140.jpg
    I will try it tomorrow if it doesn't work I downgrade to the last 3.xx rom
     

    #18
  19. G_Kristof_Van_der_Haegen
    Eclair Jan 31, 2017

    G_Kristof_Van_der_Haegen , Jan 31, 2017 :
    Same problem here with my OnePlus3, official Nougat update OxygenOs 4.0.2.
    Using RunKeeper to track my half-hour run, no other apps actively running.
    When run is complete and I check my phone, in 1 out of 2 cases RunKeeper is not running anymore, even when battery is more than half full after the run. Very annoying !

    Extra info:
    - battery management is disabled
    - already tried a cache clearing from recovery menu
     

    #19
  20. Willie Hurx
    Froyo Jan 31, 2017

    Willie Hurx , Jan 31, 2017 :
    Tried one of the options mentioned here?
     

    #20