109

Sailfish OS for OnePlus One

?

Will you flash Sailfish OS?

  1. Yes

    885 vote(s)
    39.8%
  2. No

    459 vote(s)
    20.6%
  3. May be, when it is stable enough.

    879 vote(s)
    39.5%
  1. VeryMilan Honeycomb Sep 21, 2016

    VeryMilan, Sep 21, 2016 :
    So how can we sum up the current state?

    Everything is working, battery lifetime is neat.

    Not working yet / wip:

    * sensors
    * gps
    * some video codecs missing

    Is this correct so far?
     

  2. yacuken Eclair Sep 21, 2016

    yacuken, Sep 21, 2016 :
    I'm not multirom user. Can you create zip for multirom? Based on this?
     

  3. msri3here Ice Cream Sandwich Sep 22, 2016

    msri3here, Sep 22, 2016 :
    well, the zip you provided is perfect for this.
    but the problem is, once we flash Sailfish OS on multirom, we wont be able to flash any other zip files over it (unless there is a specific TWRP build that does it)
    So, I did a manual workaround
     

  4. msri3here Ice Cream Sandwich Sep 22, 2016

    msri3here, Sep 22, 2016 :
    from my usage, thats correct
     

  5. VeryMilan Honeycomb Sep 22, 2016

    VeryMilan, Sep 22, 2016 :
    Well, i was finally able to test this port \o/
    Your fix is working woohoo!

    Current experience:

    Phone works faster than the vgrade port and everything seems more ...neat.
    For video i only tested the recording by the stock app itself.
    I expected some freezes every view seconds in the recorded file, when viewed on computer.
    Also it is not very nice to view it on the device since it seems to work with less the 1fps. :S

    Update:

    * phone calls working properbly \o/ finally!!
    * unable to get xmpp to work installed the telepathy stuff just as in the past plus telepathy-gabble without success. Or i am to silly to find my jabber contacts.
    This is a serious problem, i really need jabber for communication!
    * found a syncthing client, working awesome!
    * found a music app (nothing preinstalled? nevermind) ...could be better, sound needs adjustments, not quite perfect from the loudspeakers
    * missing gestructures like double tab to wake

    Update:

    Some people might be interested in the ressource usuage in from this rom:

    [​IMG]

    This is not a clean, idle system: warehouse is open and FlowPlayer which sadly stucks at a white window.

    smaller update: turns out that one core stays active, now music is playing and it is stable at 45% (don't worry, multicore is working). I don't know if this is good or bad, since i have nothing to compare. Just notice this :3

    Update:

    Music is now playing a while:
    [​IMG]
     
    Last edited: Sep 22, 2016

  6. Antonio coviello Cupcake Sep 22, 2016

    Antonio coviello, Sep 22, 2016 :
    I have sailfish on my OPO now (with multirom), it's an amazing OS. If it'll be stable and we may install android app maybe I'll make it my first booting ROM.
     

  7. mailyaseen Honeycomb Sep 22, 2016

    mailyaseen, Sep 22, 2016 :
    Yes, you will be able to, once sfdroid starts working for OPO. There is development happening for sfdroid. And we can expect that sooner... :)
     

  8. VeryMilan Honeycomb Sep 22, 2016

    VeryMilan, Sep 22, 2016 :
    I would prefer native sailfish apps :/
    Still missing a real jabber solution. Anything else i need is there so far.
     

  9. wdehoog Gingerbread Sep 22, 2016

    wdehoog, Sep 22, 2016 :
    test_gps was already working but nothing showed up in harbour-messwerk. After installing geoclue-provider-hybris from OBS and 'pkcon install statefs-provider-inout-location' it still showed nothing but when I start test_gps harbour-messwerk now shows location and a lot of sattelites.

    harbour-modrana also works.
     
    Last edited: Sep 22, 2016

  10. VeryMilan Honeycomb Sep 23, 2016

    VeryMilan, Sep 23, 2016 :
    I was unable to locate geoclue-provider-hybris. Do i have to do something special for a "OBS" package?

    Btw, i lost around 20% battery over night :S


    BUT successful tested:

    * headphones
    * bluetooth loudspeaker
     
    Last edited: Sep 23, 2016

  11. wdehoog Gingerbread Sep 23, 2016


  12. baddea14 Gingerbread Sep 24, 2016

    baddea14, Sep 24, 2016 :
    usbstick work very good in oneplus one using thirdparty apps called 'USBStick utils' by kimmoli you can open data like document, playing video , music and install apps rpm package as example very nice @kimmoli .
     

  13. Marnux Donut Sep 24, 2016

    Marnux, Sep 24, 2016 :
    Today i took the time to try the sensor fix. As I, like a lot of others, run multirom, i used the manual install method for the fixed sensors file. After the initial reboot, none of the sensors seemed to come alive. After a second or third reboot for checking out multirom settings and possibilities, all sensors were working all of a sudden. The only thing that seems to give a problem still, is the gps signal. That will be an investigation for later.
    When i can find the necessary applications i need, this will definately become my daily driver.
     

  14. Marnux Donut Sep 25, 2016

    Marnux, Sep 25, 2016 :
    I haven't checked the existance of both packages before installing, but i didn't get any mention of the package managers that there was already a version installed. My assumption is therefore that they were not present, before i installed them.
    After the first reboot only the gps seemed to function and the rest of the sensors seemed to be inactive. So i rebooted a second time and then everything seemed to be working. The only thing that doesn't seem 100% is the compass.

    To get the geoclue-provider-hybris, you can add the OBS repository to your system, just like mentioned for the harbour-messewerk.
    Make yourself root in the terminal and issue:
    ssu ar bacon http://repo.merproject.org/obs/nemo:/devel:/hw:/oneplus:/bacon/sailfish_latest_armv7hl
    zypper in geoclue-provider-hybris

    I named the repo 'bacon' as it is device specific. You can name it whatever you want.
     

  15. VeryMilan Honeycomb Sep 27, 2016

    VeryMilan, Sep 27, 2016 :
    Well then, looks like i need to go back to Android for now because there is no "real" xmpp client and the basic implementation is not good anough for me.
    I'll keep watching here, thanks for this awesome port, i used it until now in production.
    The only thing beside the known video problem i experienced where not working sensors (not a problem for me) and sometimes an unclean reboot when i unplugged my powerbench.
    The mentioned bad sound ... i am not sure, i guess i conditioned myself ... never had a problem with it again.

    The battery usuage could be just a tiny bit better, would be awesome, i was unable to use my phone longer than a day.
    Maybe because so many application are using just one core?
    I found a battery saver tweak but i guess my phone just used more battery power with it than without. :D

    The wlan and general connection power felt a way better than with android, this was very neat to experience.

    In summary: It was possible to use the phone in production, just sometimes, some little things like a crash by powerbench unplug sometimes, thats all. It was a pretty cool experience and i hope there will be enhancements for the xmpp implementation / apps for it (i mean whatsapp, facebook, and more but no jabber? wth?).
    Sometime the OS feels a bit slow and unoptimized for bigger screens but there are alot of cool tweaks in the warehouse.
     

  16. sridiculous Gingerbread Sep 29, 2016

    sridiculous, Sep 29, 2016 :
    Flashed the 2.0.2.48 yesterday using Multi Rom and booted and everything was, as they say, "as smooth as silk". Phone, messaging, camera, wifi, cellular data, music, pictures and all work fully without any issues. Am extremely impressed with this OS. I have a couple of issues that I need to know how to.

    1. Video doesn't play. I was trying to just play the videos recorded on Android and they don't play. I did try the various tips provided in 3 different posts and still no luck and would greatly appreciate if someone can point out to the right steps. Youtube videos in the built in browser crashes the browser itself :-(

    2. Sensors are apparently working as per some very recent posts and I did go ahead and download that zip as well, but there is no option to flash that zip in Multi Rom (This is secondary ROM, Tertiary actually).

    3. I need to setup my company email (Exchange) and when I go to Settings -> Accounts, I don't see the option for "Microsoft Exchange" as revealed in my search for that feature. Since the Store access isn't working and there is no such app available in the Warehouse, I would need some help in getting the Exchange email setup.

    4. Lastly, I can live without WhatsApp, but would like to know if there is a way to get it working still, as some people prefer contacting me on WhatsApp, despite me asking them not to.

    I really want to use this as a daily driver, as my primary requirements would be met with the above and any help is greatly appreciated.

    Great Job and beautiful OS.
     

    siddug and Prinze Martin like this.
  17. Prinze Martin Ice Cream Sandwich Sep 29, 2016

    Prinze Martin, Sep 29, 2016 :
    The points you have posted are under development :) Guess you'll have to wait a bit longer(I am :D). Majority of the issues will be solved once it has android app support I guess :)
     

  18. Marnux Donut Sep 29, 2016

    Marnux, Sep 29, 2016 :
    You have to do it manually. We multirom users, can't use the zip install method, unless the sailfish rom is primary, i guess. I did the following:

    Make sure your phone is booted into sailfish.
    Make sure you have enabled the developer options and set a password for ssh and root access.

    Copy the file:
    - I unzipped the file on my pc locally.
    - I set up an sftp connection to the phone (username: nemo)
    - Copied the file to a location i could access

    Install the file:
    - I set up an ssh connection (username:nemo)
    - Elevated myself to root (devel-su)
    - Executed the command: mv <your-file-location>/sensors.qcom /system/bin
    - Executed the command: chmod 755 /system/bin/sensors.qcom

    After reboot, my sensors worked and they have been working ever since.

    I have been using Sailfish as my daily driver for four days now and i manage to use it for around two days before i need to recharge. This is probably light to medium use compared to others.
     

    CBpbxEcmecmBeH and AbhasJain like this.
  19. sridiculous Gingerbread Sep 30, 2016

    sridiculous, Sep 30, 2016 :
    I downloaded the zip, opened terminal, devel-su, unzip zipfilepath, cp -f sensors.qcom to /system/bin/, chmod 755 /system/bin/sensors.qcom and reboot and bamm, sensors working, need to check GPS still though...
     

  20. baddea14 Gingerbread Oct 3, 2016


    mailyaseen and msri3here like this.