Sailfish OS for OnePlus One


Will you flash Sailfish OS?

  1. Yes

    890 vote(s)
  2. No

    459 vote(s)
  3. May be, when it is stable enough.

    879 vote(s)
  1. xreactx
    Froyo Mar 7, 2017

  2. baddea14
    Gingerbread Mar 7, 2017

    baddea14 , Mar 7, 2017 :
    i face this problem with lineage cm14 multirom not compitable with recovery

  3. baddea14
    Gingerbread Mar 7, 2017

    baddea14 , Mar 7, 2017 :
    i try to using cm11 i success to install alien dalvik but the problem it very old os i getting many error other service that releated to missing library and os need updates.

    many users with nexus 5 devices said they success to getting alien dalvik with this version sfos using cm11 it work good with many apps like whatapp with voice as example , video player , gps etc.

    if someone can porting it (version sfos) to oneplus one than it will be good chance for apps to work good without problem we face like cm12.1 base

    we need than testing first installing alien dalvik and make sure setting android support work fine
    next , we need to improvement sfos and alien dalvik
    sfos services like sensor , camera, etc
    alien dalvik that releated to build.ro

    That i have to share.

    Good Luck everyone :)

  4. it-was-me
    Honeycomb Mar 7, 2017

  5. xreactx
    Froyo Mar 7, 2017

    xreactx , Mar 7, 2017 :
    Nexus 5 + CM12.1 + SFOS + AD = great results, 95+/- % success rate with android apps

  6. baddea14
    Gingerbread Mar 7, 2017

    baddea14 , Mar 7, 2017 :
    | SailfishOS (Fiskarsinjoki) (armv7hl)
    [[email protected] ~]$ devel-su
    i try install apk using command the result:
    method return time=1488919385.531420 sender=:1.122 -> destination=:1.172 serial=8 reply_serial=2
    boolean true


  7. xreactx
    Froyo Mar 8, 2017

    xreactx , Mar 8, 2017 :

    how are you installing AD?
    Last edited: Mar 8, 2017

  8. baddea14
    Gingerbread Mar 8, 2017

    baddea14 , Mar 8, 2017 :
    using instruction for users post:

    Install with pkcon is more effective

    pkcon refresh
    pkcon install-local aliendalvik-1.0.46-1.armv7hl.rpm

    Script and RPM

    1. Download files
    2. Navigate to Download folder
    3. Click on RPM and install (may take a minute or so)
    4. SSH into device
    5. "devel-su"
    6. Navigate to downloads folder in ssh and "mv platform_extraenvsetup.sh /opt/alien/system/script/"
    7. navigate to opt/alien/system/script/
    8. "chmod +x platform_extraenvsetup.sh"
    9. "systemctl start aliendalvik"
    10. reboot and test apk's...

    for platform_extraenvsetup.sh i using last one you modify it .

    as result in terminal :

    method return time=1488919385.531420 sender=:1.122 -> destination=:1.172 serial=8 reply_serial=2
    boolean true

    the alien dalvik start and return to stop from android support settings.

  9. xreactx
    Froyo Mar 8, 2017

    xreactx , Mar 8, 2017 :
    For the OPO its hit or miss. With the nexus 5 you should be golden. Try installing with “zypper in <packagename>.rpm”

  10. mailyaseen
    Gingerbread Mar 12, 2017

  11. suhasrocz
    Cupcake Mar 13, 2017

  12. xreactx
    Froyo Mar 13, 2017

    xreactx , Mar 13, 2017 :
    you should check out the patches in openrepos. things to fully customize your OPO.

    mailyaseen likes this.
  13. Alexi510
    Cupcake Mar 13, 2017

  14. mailyaseen
    Gingerbread Mar 13, 2017

    mailyaseen , Mar 13, 2017 :
    True... But just not able to use any android app(Maps and Whatsapp). I can able to install, but not being able to use. Waiting for that, those are needed thing for me..

  15. xreactx
    Froyo Mar 13, 2017

    xreactx , Mar 13, 2017 :
    I switched over to my Nexus 5 for SFOS as my daily driver. AD works much better with Gapps KK installed (google frameworks allow google maps to work)

    mailyaseen likes this.
  16. mailyaseen
    Gingerbread Mar 14, 2017

    mailyaseen , Mar 14, 2017 :
    Waiting for this on OPO... :)

  17. pigling
    Cupcake Mar 14, 2017

    pigling , Mar 14, 2017 :
    After spending several days to flash multirom to OPO and reading many valuable posts from this forum and xda forum, I decide to write down my story for some reasons: share my experience with others see if can be inspiring; make a record for future reference if I need to reflash the whole things from scratch.

    Some background: I played almost major mobile OS since WM6 era (exposing my age :->) including WM6.0/6.5, WebOS, Maemo/Meego, Win 7 Mobile, BBOS/BB10, iOS, Android. Didn't try Win 8 Mobile for the some reason: as a Nokia fan and developer I was frustrated with the fact that they gave up Meego without seeing the potential of N9 success. Additionally I had no idea what kind of stupid company would tell people that they will not support the newly released OS one year after the official release announcement and all apps on this OS can't seamless install on the next generation. So I was very upset for trying new OS during that period even I watched Tizen but afraid it would be another Meego. No try Firefox OS and Ubuntu Touch because they were not releasing globally. Now I am using iPhone6S, OPO, and HP Elite X3.

    Actually I was not continuously using OPO since day one until now. I played it for one year and switching to iPhone and later Samsung Note 4. This Jan Note 4 was bricked due to battery issue (I guess) and I decided to pick up OPO again. Previously I didn't flash OPO and was sticked to its original official rom. But it was really outdated and can't catch up with the latest Android benefits. I also noticed LineageOS (successor for CM) got very good porting for OPO so my journey starts from here.

    • Flash LineageOS to OPO

    Actually it was not difficult to do so. Their official website http://www.lineageosrom.com/2016/12/download-lineage-os-for-oneplus-one.html provides enough information including the ROM and Gapp download link. The only big challenge in this part is error code:
    Comparing TZ version TZ.BF.2.0-2.0.0123 to TZ.BF.2.0-2.0.0134
    assert failed: oppo.verify_trustzone("TZ.BF.2.0-2.0.0123") == "1"
    E:Installation aborted.
    After searching this forum and XDA I tried some fix and custom rom but it can't solve the problem well. Then I looked at the error code (yes of course the only effective way to debug SW is to read and check exception point ONE HUNDRED TIMES) and guess the reason may be the to-install rom can't match properly with the existing kernel/rom inside the device (we did version checking in head file in the similar way). So I dig the website to look for the full stock rom but NOT JUST INCREMENTAL ROM file. As CM closed their website, most posts before their closure pointed to the broken link which upset me very much. But eventually this post pulled me out of mud https://forum.xda-developers.com/oneplus-one/general/guide-return-opo-to-100-stock-t2826541. After flashing the whole file into the device through fastboot, you need to reflash TWRP as stock rom overwrote the recovery image with OnePlus recovery. Then on top of this flashing, Lineage OS can be done without "TrustZone" problem.
    • Flash MultiRom to OPO (LineageOS + Ubuntu Touch + Sailfish)
    After using LineageOS 14.1 I was very satisfied with the Android 7.1 on my OPO. Then my ambition expanded to have more OS on OPO and it reminded me the HTC HD2 with which people so crazily tried many OS on this WM6.5 device. Google points me to this post. That's great to see so many peers sharing their valuable stories and suggestion here. Actually my first desire is to have Ubuntu on OPO as it has deep relationship with Ubuntu the desktop Linux while Sailfish is successor of Meego which I already had some experience.

    1. LineageOS + Ubuntu Touch (failure experience)
    I rooted OPO with SuperSU https://www.androidfilehost.com/?fid=24686681827313714. I can't comment other SuperSU versions but so far this one works really well on my OPO. I downloaded TWRP+multrom for OPO https://www.androidfilehost.com/?fid=24421527759884191. Then I download the multirom from Google Play Store. !!! Please don't rush to install any updates when opening MultiRom app first time !!!
    WhatsApp Image 2017-03-14 at 12.13.49 PM.jpeg

    I didn't follow this rule, which resulted in the big trouble later. I wrongly installed all three updates including MultiRom, Recovery, and kernel patch (However, my host rom is Android 7.1 and there is no such correct patch in the list!). I chose patch for 6.0.x kernel to install. After it rebooted to recovery mode and finished the rest install processing, I rebooted to system and opened MultiRom to install "Ubuntu devel 307" which is the default choice. After it auto prompted to recovery mode to install rest part, I booted Ubuntu from MultiRom but it hang in the OPO white booting logo. I waited for 3 minutes and it was still there, which indicated my first try failed. I flashed everything out and reinstalled LineageOS from scratch. Then repeated above procedures but only installed MultiRom and recovery updates this time. However, the Ubuntu boot still hang in the logo stage. Meanwhile, I watched this on youtube .

    Success from others indicated I must did something wrong.

    2. CM12.1/CM13.0 + Ubuntu (another failure)

    I guessed I should also use old versions of CM just like the video and tried again. But it failed again. I was very very upset and considering to give up Ubuntu boot or even multi-boot on OPO.

    3. CM13.1.2 + Sailfish (first success LOL)

    Now I can't tell what inspired me in the previous failures. But at that time I thought why I just tried Sailfish on OPO to concept-prove the multi-boot idea. At least from this forum thread it seems many people successfully did it. Again I reflashed CM13.1.2 official stock rom and TWRP_multirom_bacon_20160221-01.img to the device, then rooted it by sideloading UPDATE-SuperSU-v2.76-20160630161323.zip. I also read the guide from https://sailfish-for-opo.tchncs.de/install and download necessary CM and Sailfish zip files and transferred to OPO. This time I decided to ignore any update in MultiRom app and opening it only for checking the successful root.

    I booted to recovery mode and installed the CM and Sailfish according to guide. Everything worked fine until now. Then rebooted the system to multi-boot page it prompted a warning for lack of kexec-hardboot patch. No choice but I went to MultiRom app in rooted Android to only installed kernel patch for 6.0.x. However, I was very nervous that this kernel patch may break everything. I then rebooted system to multi-boot page and chose to boot Sailfish. The device rebooted to logo stage and held there for about 15 seconds. I thought it also failed this time. However, the phone suddenly vibrated and the screen went to full dark while the front LED indicator came to white color. Thanks god, it eventually had different behaviour from previous Ubuntu hanging. But I was not clear what this dark screen would lead to. Another about 15 seconds passed and suddenly the whole screen got out of dark. It switched to a page listing welcome message in different language. That's it. I could assure that I successfully booted to Sailfish this time.

    3. CM13.1.2 + LineageOS 14.1 + Ubuntu + Sailfish (success)

    Sailfish is really a good mobile OS. The whole UI including gesture control gave a very different experience from Android and iOS. I played a while and saw some sign from Meego. Even the community-supported app warehouse reminded me the similar thing in N9. Then I thought this successful Sailfish experience indicated the multi-boot concept works in OPO. It encouraged me to turn back to Ubuntu boot.

    This time I went to MultiRom app in Android and chose to install the latest "stable" version from list. Auto rebooting to recovery mode to continue installing... I came to multi-boot page again and selected Ubuntu. The screen went to logo stage and maybe 30 seconds later I finally saw the familiar orange background and Ubuntu loading animation. I got it YEAH.

    After that I installed the latest Ubuntu "rc-proposed", "devel-stable", "devel_rc-proposed", "devel_proposed", and "devel" and tried to boot them respectively. It seemed that all "devel" related versions got problem to boot. Based on usability I only kept "rc-prosed" version at the end.

    Here is a tricky part. After getting CM, Ubuntu and Sailfish, I tried to upgrade MultiRom to the latest v33b and Recovery to the latest 2016-04-17. The upgrade succeeded but it didn't break multi-boot process.

    Actually other non-Android OS was my desire at that time. I flashed Ubuntu and Sailfish for fun. Of course I'd like to use them for daily work and life. However, shortage of app on these platforms stopped me from doing so. My frequent apps including IM like Whatsapp or WeChat, Grab or Uber, mobile banking, Google Map, etc. are not there.

    So I planed to add LineageOS to multi-boot list while still keeping a rooted Android at the same time. In that way LineageOS fulfils my daily requirement and the rooted Android holds the MultiRom app just in case any problem happens when multi-booting. However, this looking-easy task had been the most challenging one since I started the multi-boot flashing.

    My plan in mind looked like this (failure experience):
    1. Rooted CM13.1.2 (Android 6.0)
    2. Non-rooted LineageOS 14.1 (Android 7.1)
    3. Sailfish OS
    4. Ubuntu Touch
    The major concern was to keep the whole multi-boot connection among CM, Sailfish and Ubuntu untouched as much as possible because they worked very well at that time.

    I supposed it could be done after sideloading the LineageOS zip to MultiRom.
    1. Recovery Mode
    2. Enter to MultiRom from top right corner
    3. Add ROM
    4. Install Android from internal storage, Zip file or Sideload
    However, the installation crashed in the last step, no matter with zip file from the device or sideload from adb. The log prompted "Target ... A0001/6.0 ...". I guessed the adding the new rom function pushed LineageOS on top of existing host CM13.1 ROM. The version mismatch between them resulted in problem. I have no idea why two different ROMs should reside in different partition eventually go to the same partition. Really appreciate any advice for this part in MultiRom.

    Then my only idea was to "clean or remove the existing primary ROM so that the newly added ROM could move in without version conflict". Luckily I found this "Move primary ROM to secondaries" which will remove the current primary and then add it to secondary ROMS. So my final plan as following (success):
    1. Move primary CM13.1.2 ROM to secondary (to empty primary ROM partition for new ROM)
    2. Without rebooting, install LineageOS 14.1 to primary ROM (including Gapps). At this time, LineageOS is primary ROM while CM is the secondary.
    3. SWAP primary ROM and secondary ROM.  After this swap, CM is the primary ROM and LineageOS is secondary.
    4. Double check and make sure CM still be rooted.
    Finally all four OS can work together in one device.
    WhatsApp Image 2017-03-14 at 2.04.07 PM.jpeg
    Some sentences at the end:
    1. DON'T ENCRYPTED YOUR PHONE BEFORE FLASHING MULTI-ROOT!!! I spent six hours before seeing the warning from other forum post.
    2. My two-cent opinion after using Sailfish, Ubuntu, CM/LineageOS, and Windows 10 Mobile (I don't take iOS here because it really works well no matter you love it or hate it. But other OS supposes to have a lot work to do before catching up with iOS or even surpassing):
    • I can't see the potential of Ubuntu. I say this not because its lag performance and app shortage but also its basic architecture more like squeezing a desktop into a phone.
    • Sailfish is another Meego. This is not only its advantage but also shortage. It looks elegant and the UI especially lures me. However, I am always afraid it will disappear soon like Meego.
    • I knew CM long time ago but this is the first time I try it. Comparing with OPO original stock and Samsung Note 4 stock, CM/LineageOS help me enjoy beauty of Android which never makes me love and embrace Android before.
    • My feeling for Windows 10 mobile is a little complicated. It can meet my basic daily requirement. But I always think it should have been better than this. Microsoft didn't play well with such a good hand.
    • I know OS is a very tough business. The dead list is very long: Symbian, Maemo/Meego, WebOS, BBOS/BB10 and Firefox OS. Actually now there are only three kinds of OS business: iOS (fully controlled OS and HW), Windows 10 Mobile (close source OS and license to OEM) and open source Android. I can't imagine how Sailfish survives in this war. Google put so much effort to build the OS while it doesn't make money from OS licensing fee but other parts (Gapps). Then how Sailfish? I previously thought Nokia should work together with some giant service provider such as Yahoo and put Yahoo search, Yahoo mail, etc. service on top of Meego OS. This is the only way to fight with Android+Gapp. Very disappointed Venus plan between Nokia and Yahoo can't sustain.
    Please ignore spelling and grammar error if any. My last long English writing was ten years ago in postgraduate project. Again appreciate everyone in this forum and XDA for sharing valuable suggestion and experience. Also thanks OnePlus for bringing us this powerful OPO. Enjoy the fun.

    Pigling 2017-03-14

  18. baddea14
    Gingerbread Mar 14, 2017

    mailyaseen likes this.
  19. it-was-me
    Honeycomb Mar 14, 2017

    it-was-me , Mar 14, 2017 :
    Hey guys!
    I charged my opo in android today and it was faster full and the battery drained less
    is this a common problem?

  20. mailyaseen
    Gingerbread Mar 15, 2017

    mailyaseen , Mar 15, 2017 :
    hmm no go for WhatsApp?