Sailfish OS for OnePlus One


Will you flash Sailfish OS?

  1. Yes

    890 vote(s)
  2. No

    459 vote(s)
  3. May be, when it is stable enough.

    879 vote(s)
  1. it-was-me
    Honeycomb Jul 18, 2017

    it-was-me , Jul 18, 2017 :
    Which Sailfish version do you use and which base do you use?
    First, try this: https://github.com/wdehoog/sailfish-bacon-images/wiki
    Last edited: Jul 18, 2017

  2. it-was-me
    Honeycomb Jul 18, 2017

    Last edited: Jul 18, 2017

  3. robthebold
    Eclair Jul 18, 2017

    robthebold , Jul 18, 2017 :
    If you notice the phone heating up more than usual, you might run "top" from the terminal to see if any processes are hogging close to 100% CPU. Likely culprits include crond and statefs or the media indexer whose name escapes me right now. If it's a runaway process, this should help you find it.

    Video should be working: what SFOS version are you on?

  4. danPixl
    Cupcake Jul 19, 2017

    danPixl , Jul 19, 2017 :
    I fixed it - I completely wiped the phone from TWRP and sideloaded the .zips.

  5. it-was-me
    Honeycomb Jul 24, 2017

    azeez4901 and robthebold like this.
  6. it-was-me
    Honeycomb Jul 25, 2017

    it-was-me , Jul 25, 2017 :
    Hey, is a higher image resolution for sailfish available? 2 and 8 MP aren't so cool!

    Cupcake Jul 25, 2017

  8. it-was-me
    Honeycomb Jul 25, 2017

  9. siropchik
    Froyo Aug 3, 2017

  10. it-was-me
    Honeycomb Aug 4, 2017

    it-was-me , Aug 4, 2017 :
    Yeah, all is working! But the proximity sensor use a lot of the battery...

    siropchik likes this.
  11. hiltuspeke
    Cupcake Aug 8, 2017

    hiltuspeke , Aug 8, 2017 :
    I've been using the official Jolla phone from the launch until now, but eventhough I still like it very much, it begins to fall apart.
    I recently purchased second-hand OPO, my first Android phone in years. I purchased this specific phone with intention to install Sailfish OS on it.
    So I'm wondering what is the situation with Sfdroid or other Android support right now? I still need Whatsapp and maybe other Android apps from time to time. Is it possible to run single Android apps from Sailfish, or do I have to keep the full "Android in a window" running all the time? Is it possible to get push-notifications from Android apps? Is Whatsapp even functional in community-ported SFOS?

  12. it-was-me
    Honeycomb Aug 9, 2017

    it-was-me , Aug 9, 2017 :
    Unfortunatelly there is no Android support yet. Sfdroid is available but it isn't suitable for everyday use and I think the development for Sfdroid on OPO has been discontinued because the newer Sfdroid version requires a newer kernel.

  13. KanesAnix
    Cupcake Aug 12, 2017

    KanesAnix , Aug 12, 2017 :
    Please send me the Alien Dalvik files.The BACON Script and RPM.Thanks,that google drive can't open.Send my Gmail, *** email removed by @noquarter ***
    Last edited by a moderator: Aug 19, 2017

  14. hiltuspeke
    Cupcake Aug 13, 2017

    hiltuspeke , Aug 13, 2017 :
    I followed the beginners guide. Rooting was fine. However, the MultiROM app couldn't download anything for some reason. I flashed MultiROM from recovery and MultiROM Recovery from Fastboot. Then I flashed Furnace kernel because of the kexec-hardboot. Now, when booting, my phone is stuck to Cyanogen-splashscreen.

    Edit: Flashed AK kernel, if the problem was there. Same result. Can I fix this by flashing a kernel and if, what should I use?

    EDIT 2: I had luck with AK kernel: I managed to flash SFOS. But after flashing the primary CM12.1 my kexec-hardboot patch was gone, and thus I can't boot SFOS. How can I get kexec-hardboot support to my current primary rom without using the MultiROM App method described in the beginners guide? Do you use a special rom or flash the patch some other way?
    Last edited: Aug 14, 2017

  15. it-was-me
    Honeycomb Aug 19, 2017

    it-was-me , Aug 19, 2017 :
    I wouldn't recommend to flash Sailfish with Multirom. I think Multirom is dead. But you can try to use a Rom with kexec support (for example Resurrection Remix) and install Multirom in TWRP. The Sailfish base is this CM file.

  16. it-was-me
    Honeycomb Aug 19, 2017

    it-was-me , Aug 19, 2017 :
    AlienDalvik isn't working on OPO. It was only an experiment.
    Last edited by a moderator: Aug 19, 2017

  17. hiltuspeke
    Cupcake Aug 21, 2017

    hiltuspeke , Aug 21, 2017 :
    Sailfish is now working with Multirom, stock rom and boeffla kernel. Thanks for the help.

  18. xreactx
    Froyo Aug 24, 2017

    xreactx , Aug 24, 2017 :
    I was able to upgrade to through SSH ("ssu release" & "version --dup"). Has anyone been able to upgrade to or

  19. xreactx
    Froyo Aug 25, 2017

    xreactx , Aug 25, 2017 :
    After successfully upgrading to, I tried to go as far as with no luck. Now that I'm trying to install it from to the screen stays black (with Oneplus logo) after reboot. Did you have this problem as well?

    ***Update: I got it working
    Last edited: Aug 25, 2017

    it-was-me likes this.
  20. azeez4901
    Ice Cream Sandwich Aug 27, 2017