Sailfish OS for OnePlus One


Will you flash Sailfish OS?

  1. Yes

    890 vote(s)
  2. No

    459 vote(s)
  3. May be, when it is stable enough.

    879 vote(s)
  1. it-was-me
    Honeycomb Aug 27, 2017

    it-was-me , Aug 27, 2017 :
    I've tried to install SF on Multirom and it worked, thanks for that information.

  2. wdehoog
    Gingerbread Aug 27, 2017

    wdehoog , Aug 27, 2017 :

  3. azeez4901
    Ice Cream Sandwich Aug 28, 2017

    azeez4901 , Aug 28, 2017 :
    Hey did you use multirom version 'e' or another? I am on 'e'.. whats your base?

    My base is - cm-12.1-YOG7D-sf-20170218-bacon
    This is the recommended base as per the late pages here but it got me to error 7. So i modified the updater script to remove assertions and it flashed properly but didnt boot.
    and my flash file is sailfishos-bacon-release-


  4. azeez4901
    Ice Cream Sandwich Aug 28, 2017

    azeez4901 , Aug 28, 2017 :
    Now i swapping my primary rom (7.1.2 with modem c6 (old)) to an MM rom as primary. Will report after done. Attached logs if you'd like to have a look. Thank you for taking Sailfish a step further from its near-to-dead-state. #respect

  5. azeez4901
    Ice Cream Sandwich Aug 28, 2017

  6. azeez4901
    Ice Cream Sandwich Aug 28, 2017

  7. it-was-me
    Honeycomb Aug 28, 2017

    it-was-me , Aug 28, 2017 :
    I used: Main System: Official Cyanogen OS 12.1 with AK-Kernel
    newest Multirom and Multirom-TWRP
    Then I installed the same files like you as a secondary system and it worked.

    azeez4901 likes this.
  8. wdehoog
    Gingerbread Aug 28, 2017

    wdehoog , Aug 28, 2017 :
    What I meant was that your primary rom should be some CM12.1 rom. Not android 7.x nor 6.x but a 5.1 rom. Like it-was-me describes.

  9. azeez4901
    Ice Cream Sandwich Aug 29, 2017

    azeez4901 , Aug 29, 2017 :
    Ok. But i am worried that my 7x and 6x rom may not boot after doing that? do you have 7x rom in a secondary partition and does it boot? I installed a 6x rom on the primary and tried but didnt work. Thanks for the info

  10. wdehoog
    Gingerbread Aug 29, 2017

    wdehoog , Aug 29, 2017 :
    Indeed it will not. Same problem: firmware version. Maybe you can make a backup of the firmware partition and restore it when needed. I have never done this myself.

  11. azeez4901
    Ice Cream Sandwich Aug 29, 2017

    azeez4901 , Aug 29, 2017 :
    Heart Attack!

  12. tmichel
    Donut Aug 31, 2017

    tmichel , Aug 31, 2017 :
    I have Lineage OS running based on Android 7 as primary ROM and Sailfish as secondary ROM via MultiROM without problems.

    wdehoog likes this.
  13. wdehoog
    Gingerbread Aug 31, 2017

    wdehoog , Aug 31, 2017 :
    That is good to know. I thought that to be impossible. Can you post the exact roms+recovery you used for this setup?

  14. xreactx
    Froyo Sep 2, 2017

    xreactx , Sep 2, 2017 :
    anyone else having an issue with rotation in the camera app, when i rotate left or right the display appears upside down (inverted)...

  15. azeez4901
    Ice Cream Sandwich Sep 2, 2017

    azeez4901 , Sep 2, 2017 :
    yes please. my current primary is RR which is based on lineage so shouldnt be a problem.. but mine doest boot. Much appreciate if you can give details.

  16. tmichel
    Donut Sep 4, 2017

    tmichel , Sep 4, 2017 :
    Sorry for the late reply. I am using the official LineageOS for the OPO as primary ROM, Multirom v33b and TWRP Recovery 2.8.7. As Lineage has no kexec enable kernel I use Radiactive Nougat Kernel V1.5

    Installed Sailfish with the files quoted above, both Android and Sailfish boot and run fine. Only when you upgrade Lineage via OTA you have to reinstall the kexec Kernel, otherwise you won't be able to boot Sailfish.

    wdehoog likes this.
  17. Aditya.Me
    Donut Sep 6, 2017

    Aditya.Me , Sep 6, 2017 :
    Can someone please post an upgrade guide to 2.1.1.x releases from and any news of eta for a flashable ?

  18. Aditya.Me
    Donut Sep 6, 2017

    Aditya.Me , Sep 6, 2017 :
    Also is there any fix of this:
    Comparing TZ version TZ.BF.2.0-2.0.0123 to TZ.BF.2.0-2.0.0134
    assert failed: oppo.verify_trustzone("TZ.BF.2.0-2.0.0123") == 1
    Updater process ended with ERROR: 7

    I am currently on Resurrection Remix 7.1.2 is that a problem ? Recovery: twrp_multirom_bacon_20160221-01

    EDIT: Fixed, need to edit the updater script in cm12 to .0134 and it flashes fine
    Last edited: Sep 6, 2017

  19. wdehoog
    Gingerbread Oct 12, 2017

    wdehoog , Oct 12, 2017 :

    Here is the first beta release of Sailfish (Kiiminkijoki) for the Oneplus One:

    • Sailfish OS
    • use mer-hybris fork of android_device_oneplus_bacon instead of CM one
    • added delay to sensorfwd startup to get sensors working (for example rotation)

    I only tested installing the image and verified wifi, camera, video playing and tilt-sensor are still working. The rest is up to you. So be careful.

    CBpbxEcmecmBeH and luxuskamel like this.
  20. sridiculous
    Gingerbread Oct 13, 2017

    sridiculous , Oct 13, 2017 :
    Awesome. Just a quick question, can we upgrade existing Sailfish installation or requires a fresh install? Currenlty have Nougat (Tuga Power) and a AOSP base Oreo Beta running along with Sailfish Would be awesome if we could just update the Sailfish to the updated version instead of fresh install.