108
Sailfish OS for OnePlus One

?

Will you flash Sailfish OS?

  1. Yes

    883 vote(s)
    39.8%
  2. No

    458 vote(s)
    20.6%
  3. May be, when it is stable enough.

    879 vote(s)
    39.6%
  1. wdehoog Gingerbread Oct 13, 2017

    wdehoog, Oct 13, 2017 :
    Over the Air update will probably work (but I never test this).
     

  2. sridiculous Gingerbread Oct 13, 2017

    sridiculous, Oct 13, 2017 :
    Over the air doesn't seem to work. Check for updates reports that it is up to date. Twrp didn't let add a zip to sailfish is, it does for android though. Can't see any other way other than a clean install, which I don't want to. Guidance is greatly appreciated.
     

  3. wdehoog Gingerbread Oct 13, 2017

    wdehoog, Oct 13, 2017 :
    Which check for update do you mean? Some Jolla menu? That will not work. Adding zips with Twrp will also not work.

    Forum user @it-was-me came up with the following procedure https://github.com/wdehoog/sailfish-bacon-images/wiki/Over-the-Air-updates. Maybe it also works for you.
     

  4. sridiculous Gingerbread Oct 13, 2017

    sridiculous, Oct 13, 2017 :
    thanks for the pointer. i am trying that and am getting an error when performing 'zypper ref' and the error says

    File '/repodata/repomd.xml' not found on medium 'http://repo.merproject.org/obs/nemo:/devel:/hw:/oneplus:/bacon/sailfishos_2.1.2.3/
    ' with options to abort, retry or ignore. not sure how to proceed.
     

  5. sridiculous Gingerbread Oct 13, 2017

    sridiculous, Oct 13, 2017 :
    Found the issue. I had a typo to an invalid address for the community common repository. it should have been sailfishos_2.1.2.3 instead of sailfish_2.1.2.3. changed and proceeding, will post update soon once process completes.
     

  6. sridiculous Gingerbread Oct 13, 2017

    sridiculous, Oct 13, 2017 :
    Facing another issue now. The following is the log from when I get into the last step of the process and run "version --dup" command.

    Code:
    REFRESHING CACHE AND DOWNLOADING PACKAGES
    Refreshing: 90%
    Message: store: [|] Valid metadata not found at specified URL(s)
    
    Finished transaction (status=1, runtime=43047ms)
    UPGRADING SYSTEM
    Finished: 1%
    Error: Installation aborted by user
    
    Finished transaction (status=2, runtime=3958ms)
    UPGRADE NOT COMPLETE - Retry 1 of 9
    Waiting 1 seconds before retry.
    REFRESHING CACHE AND DOWNLOADING PACKAGES
    

    This goes on for 9 tries and fails and here is the final output after all 9 tries fail.

    Code:
    FINISHING
    
    The upgrade could NOT be finished. Make sure you have
    a working Internet Connection and SSU is propertly set up. In
    case the repos are changing rapidly (e.g. during development),
    just restarting the upgrade might fix the issue.
    
    REBOOT AT YOUR OWN RISK.
    
    Not sure what is wrong as all the steps are followed as detailed. Any clue how to get past this. Didn't want to risk rebooting yet.
     

  7. m4k3r1 Cupcake Oct 13, 2017

    m4k3r1, Oct 13, 2017 :
    Just flashed the latest version last night (2.1.2.3-b1) and I'm not finding the "Android Support" app within the Jolla Store. Any help or guidance would be appreciated. Other than that everything else seems to be working just fine! I did notice only one core is running but not sure if it's just an aggressive governor built in. Anyways, thank you for all the hard work, keep it up!
     

  8. sridiculous Gingerbread Oct 13, 2017

    sridiculous, Oct 13, 2017 :
    I decided to bite the bullet and proceed with sync and reboot. There were a couple of boot loops at first and my heart skipped a beat. It did come back up and looks like the upgrade is through, not sure what is missing yet though. Initial impressions are very impressive and looks very stable. Will post more updates on further usage.

    Phone call works only with Speaker Phone and not with the ear piece. The sensors don't seem to be working. I checked the gyro and proximity and both don't work. I went ahead and applied the sensors fix given a while back and still doesn't work. Camera (Pic and Video), Audio and all others seem to work just fine.

    Will check more and post updates.
     

    luxuskamel likes this.
  9. wdehoog Gingerbread Oct 14, 2017

    wdehoog, Oct 14, 2017 :
    Alien Dalvik (Android app support) not available on community ports.
     

    m4k3r1 likes this.
  10. wdehoog Gingerbread Oct 14, 2017

    wdehoog, Oct 14, 2017 :
    Does screen rotation work (also supported by the sensors modules)?

    I cannot promise anything of help but you might find some clues in the logs. Interesting logs are
    • logcat: /usr/libexec/droid-hybris/system/bin/logcat > lc.log 2>&1
    • journalctl: devel-su journalctl --no-pager > journal.log
    • dmesg: dmesg > dmesg.log
     

  11. wdehoog Gingerbread Oct 14, 2017

    wdehoog, Oct 14, 2017 :
    One other thing. Assuming it now points to the 2.1.2.3 version, could you try to refresh the adaptation-community repo (pkcon refresh adaptation-community) and then update (pkcon update).

    I seem to have forgotten to update the droid-hal-bacon package in the adaptation-community repo. Maybe the older version causes your problems and an update fixes them.
     

  12. sridiculous Gingerbread Oct 14, 2017

    sridiculous, Oct 14, 2017 :
    Did those steps and the issues are still there. Maybe i shoukd do a clean flash now, hate to do it really.

    the screen rotation doesnt work and neither does the proxomity sensor. gps seems to be the only sensor working.
     

  13. wdehoog Gingerbread Oct 14, 2017

    wdehoog, Oct 14, 2017 :
    Sorry to hear that. Maybe you can make a backup using the Settings utility. (I've never done that.) Unfortunately it needs an sd card or an external account and since there is no sdcard in the opo it looks like this will only work for Dropbox or OneDrive.
    Another option would be to copy the files from your current sailfish home dir to the new one (again I've never done that).
     

  14. m4k3r1 Cupcake Oct 14, 2017

    m4k3r1, Oct 14, 2017 :
    Ok thank you, I assumed it was something along those lines but wanted to confirm. At this point my disgust for Google surpasses my need for (some) android apps. Other than that, everything is running great. No sensor issues and stable enough as far as I can tell. Running SF as stand alone since I want to move away from Google.
     

  15. sridiculous Gingerbread Oct 15, 2017

    sridiculous, Oct 15, 2017 :
    Went ahead with a clean install and everything working just fine. Didn't venture into backup / restore and started with a clean slate. No issues found so far. Cameras, sensors, audio / video playback, calls, WiFi, cellular data, GPS etc etc everything working as expected. Great ROM and thanks for the efforts.
     

    CBpbxEcmecmBeH likes this.
  16. it-was-me Honeycomb Oct 15, 2017

    it-was-me, Oct 15, 2017 :
    At the next time you could try instead of using 'version --dup' 'zypper up'. That should work!
     
    Last edited: Oct 15, 2017

  17. hiltuspeke Cupcake Nov 16, 2017

    hiltuspeke, Nov 16, 2017 :
    Has anyone had any success using Whatsapp Web on OPO running Sailfish? I'd like to use SFOS on daily basis, but eventhough I've moved most of my chats to Telegram, I still have to check few Whatsapp groups occasionally.

    I have an android phone at home running as a Wifi hotspot and I could have my Whatsapp running there and read it from my OPO via Whatsapp Web, but Whatsapp Web doesn't load on any user agent I've tried on Webcat; the green loading bar stalls and the QR-code never loads.

    Any experience on this?
     

  18. wdehoog Gingerbread Nov 28, 2017


    it-was-me and Aukdrck like this.
  19. Aukdrck Froyo Nov 30, 2017

    Aukdrck, Nov 30, 2017 :
    Running the latest Beta (Thanks to @wdehoog ) and things look very promising.

    Do you guys have any App/ Patch recommendations for Netflix, Spotify, youtube, Google plus and a good web browser?

    FYI these are my current app list

    File Browser
    Sailbook - for Facebook
    Piepmatz - For Twitter
    Prostogram - For Instagram
    Sailimgur - Imgur Client
    Quickddit - Reddit Client
    YTPlayer - For Youtube
    SeriesFinale - Track TvShows
    CuteSpot - Spotify Client
    gPodder - Podcast
    Saildoro - Pomodoro App
    Worldclock
    TaskList - Keep Alternative
    Defender - Adaway Alternative
    SailfishReboot
    Screenshot app
    Warehouse

    Thank you in advance.
     
    Last edited: Dec 1, 2017

  20. it-was-me Honeycomb Dec 1, 2017

    it-was-me, Dec 1, 2017 :
    I don't have any recommendations. I don't know wether it is true but I have got these information:

    „Jolla is investigating and made the "real" browser based on gecko and which is now Sailfish-Browser. Currently they are developing a replacement for the QtWebkit based Webview based upon this work. (at least it looks like from the code changes in the browser and some hints in community meetings)”
     

    Aukdrck likes this.