108
Sailfish OS for OnePlus One

?

Will you flash Sailfish OS?

  1. Yes

    883 vote(s)
    39.8%
  2. No

    458 vote(s)
    20.6%
  3. May be, when it is stable enough.

    879 vote(s)
    39.6%
  1. Aukdrck Froyo Dec 2, 2017

    Aukdrck, Dec 2, 2017 :
    Thanks for the info mate. I will keep my eyes peeled.
     

  2. slipstream7 Cupcake Mar 25, 2018

    slipstream7, Mar 25, 2018 :
    hello,
    I have succesfully installed Sailfish OS 2.1.3.7 with CM 12.1, following the instructions at https://sailfish-for-opo.tchncs.de/ .

    I signed up for Jolla store, have Warehouse and Storeman installed. Camera works (video and pics) but Cameraplus just crashes when opening.

    Some options that Jeff Hoogland recommended don't work:

    1) zypper rr adaptation0 failed. Since its repo was disabled, I enabled it as well as the jolla store, don't know if that is ok. still failed after repo was enabled. What purpose is this command for?

    Disabled repositories (user):
    - home ... https://download.jollamobile.com/home:/honeybadger/latest_armv7hl/
    - adaptation0 ... https://releases.jolla.com/releases/2.1.3.7/nemo/adaptation-/armv7hl/
    - store ... https://store-repository.jolla.com/bacon/armv7hl/?version=2.1.3.7


    2) also I can't play certain video codecs such as .mkv and .webm and I fail to find any way to install extra codecs:

    gstreamer010-ffmpeg-extra cannot be installed due to missing dependancy: libgstaudio-0.10.so

    * I have found out that the videos can play in Kodi but I would like to just be able to play these formats using one of the Jolla players as well.

    3) I can't find any keyboard text predictor that works:

    pkcon install jolla-xt9 jolla-xt9-cp
    fails to install, no provider found.

    Wondering if anyone has solution to these.
     
    Last edited: Mar 25, 2018

  3. robthebold Eclair Mar 26, 2018

    robthebold, Mar 26, 2018 :
    The text prediction (and android compatibility) packages are third-party licensed and only available from Jolla for official Sailfishes, e.g. the original Jolla Phone, the Xperia X, etc. To get xt9 working on a community build, you need to get that package from another source. If you or a friend happens to have a phone with a licensed SFOS build, you could probably extract the package from there. Otherwise, take a look on the maemo.org forums using the power search feature to find where to get the missing package. I don't want to post a direct link and draw unwanted attention to something that's quasi-legal (depending on your local jurisdiction, of course).
     

  4. wdehoog Gingerbread Apr 9, 2018

    wdehoog, Apr 9, 2018 :
    Hi,

    Here is the first beta release of Sailfish 2.1.4.14 (Lapuanjoki) for the Oneplus One:
    https://github.com/wdehoog/sailfish-bacon-images/releases/tag/2.1.4.14-b1

    Changes
    Sailfish OS 2.1.4.14 (Lapuanjoki)
    switched vibrator from ffmemless to native
    release from 'testing' repositories (instead of 'devel')


    I only tested installing the image and verified wifi, camera, video playing and tilt-sensor are still working. The rest is up to you. So be careful.
     

    Mecca EL, CBpbxEcmecmBeH and baddea14 like this.
  5. baddea14 Gingerbread Apr 12, 2018


  6. it-was-me Honeycomb Apr 20, 2018

  7. it-was-me Honeycomb Apr 20, 2018


    CBpbxEcmecmBeH and Mecca EL like this.
  8. V1525213236787 Cupcake May 16, 2018

    V1525213236787, May 16, 2018 :
    [​IMG] [​IMG] [​IMG]

    Why? Using and default cm-12.1 (without camera) and cm-12.1 YOGD build (with camera). How i can install it stable, with working sensors and camera?
     

  9. wdehoog Gingerbread May 17, 2018

    wdehoog, May 17, 2018 :
    Sorry but I do not understand what you are asking. Did you use the required CM-12.1 build (cm-12.1-YOG7D-sf-20170218-bacon.zip) or another one?
     

  10. wdehoog Gingerbread Jun 25, 2018


  11. PRAZEWORKS Cupcake Jul 18, 2018

    PRAZEWORKS, Jul 18, 2018 :
    Just wanted to say thank you for your work! In the last few days I've installed SailfishOS to my OnePlus One and have been blown away at how well everything is works. It's instantly become my daily driver.
     

    luxuskamel and CBpbxEcmecmBeH like this.
  12. ankit90v Donut Sep 17, 2018

    ankit90v, Sep 17, 2018 :
    Should CM12 be installed alongside Sailfish 2.2.0.29 ?
     

  13. wdehoog Gingerbread Sep 17, 2018

    wdehoog, Sep 17, 2018 :
    Yes. First install the required CM12 then Sailfish. Sailfish uses some libraries and drivers from the CM12 image.
    Note: you will have to use the correct CM12 image. Otherwise video and sensors will not work.
     

  14. wdehoog Gingerbread Sep 20, 2018


    luxuskamel likes this.
  15. luxuskamel KitKat Sep 20, 2018


  16. luxuskamel KitKat Sep 27, 2018


  17. wdehoog Gingerbread Sep 27, 2018

    wdehoog, Sep 27, 2018 :
    Unfortunately not. There are anbox packages for sailfish and I did apply the required patches to the kernel but it still refused to start. Something with missing cgroup functionality and namespaces (I don't even know what these are). Since they got it working on UBPorts it should be possible though.
     

    Aukdrck likes this.
  18. Marzanna Cupcake Oct 25, 2018

    Marzanna, Oct 25, 2018 :
    Hello. I flashed cm-12.1-YOG7D-sf-20170218-bacon.zip and SFOS 2.2.1.18 beta 1. GPS and camera works but sensors don't :(
    There are some errors in systemd log but I can't understand why it doesn't work.
     

    Attached Files:


  19. wdehoog Gingerbread Oct 28, 2018

    wdehoog, Oct 28, 2018 :
    What does 'systemctl status sensorfwd' report? I have

    ● sensorfwd.service - Sensor daemon for sensor framework
    Loaded: loaded (/lib/systemd/system/sensorfwd.service; disabled; vendor preset: enabled)
    Active: active (running) since Mon 2018-10-22 10:44:02 CEST; 6 days ago
    Main PID: 1406 (sensorfwd)
    CGroup: /system.slice/sensorfwd.service
    └─1406 /usr/sbin/sensorfwd -c=/etc/sensorfw/primaryuse.conf --systemd --log-level=warning --no-magnetometer-bg-calibration


    and maybe try to restart it ('systemctl restart sensorfwd')?

    What does 'ps aux | grep sensor' report? I have:
    sensors 1077 0.1 0.0 61296 1860 ? Sl Oct22 12:25 /system/bin/sensors.qcom
    root 1078 0.0 0.0 20068 2004 ? Sl Oct22 0:00 /system/bin/sensorservice
    root 1406 0.0 0.2 103356 6904 ? Ssl Oct22 7:20 /usr/sbin/sensorfwd -c=/etc/sensorfw/primaryuse.conf --systemd --log-level=warning --no-magnetometer-bg-calibration
     

  20. Marzanna Cupcake Oct 28, 2018

    Marzanna, Oct 28, 2018 :
    Code:
    ● sensorfwd.service - Sensor daemon for sensor framework
      Loaded: loaded (/lib/systemd/system/sensorfwd.service; disabled; vendor preset: enabled)
      Active: active (running) since Sun 2018-10-28 21:23:22 MSK; 3min 48s ago
     Main PID: 1387 (sensorfwd)
      CGroup: /system.slice/sensorfwd.service
      └─1387 /usr/sbin/sensorfwd -c=/etc/sensorfw/primaryuse.conf --systemd --log-level=warning --no-magnetometer-bg-calibration
    
    Oct 28 21:23:22 Sailfish sensorfwd[1387]: Node ' "accelerometeradaptor" ' state changed to invalid
    Oct 28 21:23:22 Sailfish sensorfwd[1387]: SensorManagerError:  "adaptor 'accelerometeradaptor' can not be started"
    Oct 28 21:23:22 Sailfish sensorfwd[1387]: QObject::connect: Cannot connect (null)::propertyChanged(const QString&) to AccelerometerChain::propertyChanged(const QString&)
    Oct 28 21:23:22 Sailfish sensorfwd[1387]: QObject::connect: Cannot connect (null)::propertyChanged(const QString&) to AccelerometerChain::propertyChanged(const QString&)
    Oct 28 21:23:22 Sailfish sensorfwd[1387]: Node ' "orientationchain" ' state changed to invalid
    Oct 28 21:23:22 Sailfish sensorfwd[1387]: Node ' "orientationsensor" ' state changed to invalid
    Oct 28 21:23:22 Sailfish sensorfwd[1387]: "orientationsensor instantiation failed"
    Oct 28 21:23:22 Sailfish sensorfwd[1387]: SensorManagerError:  "sensor has not been instantiated"
    Oct 28 21:23:27 Sailfish sensorfwd[1387]: SensorManagerError:  "requested sensor id 'orientationsensor' not registered"
    Oct 28 21:23:27 Sailfish sensorfwd[1387]: SensorManagerError:  "requested sensor id 'orientationsensor' not registered"
    
    I restarted sensorfwd but it didn't help.
    Code:
    sensors  1042  0.0  0.0  35668  1836 ?  Sl  21:23  0:00 /system/bin/sensors.qcom
    root  1043  0.0  0.0  20068  2004 ?  Sl  21:23  0:00 /system/bin/sensorservice
    root  2477  0.2  0.2  89900  6580 ?  Ssl  21:28  0:00 /usr/sbin/sensorfwd -c=/etc/sensorfw/primaryuse.conf --systemd --log-level=warning --no-magnetometer-bg-calibration
    root  2530  1.0  0.0  4132  768 pts/0  S+  21:29  0:00 grep sensor
    
    Is there a problem with underlying CM? I can try to reflash everything but I would like to avoid it.