111
Sailfish OS for OnePlus One

?

Will you flash Sailfish OS?

  1. Yes

    888 vote(s)
    39.9%
  2. No

    459 vote(s)
    20.6%
  3. May be, when it is stable enough.

    879 vote(s)
    39.5%
  1. wdehoog
    Gingerbread Oct 28, 2018

    wdehoog , Oct 28, 2018 :
    I have no idea. I run it with multirom and my primary rom is a 5.1 blisspop.

    Do you have these files (I guess you have them):
    /etc/sensorfw/sensord.conf.d/60-sensor-selection-oeverrides.conf
    /etc/sensorfw/primaryuse.conf

    Maybe you can try to comment certain stuff (start with orientationadaptor in primaryuse.conf) and check if something changes. For me rotation always works. After a reboot or a sensorsfwd restart.

    Sorry but I cannot do much more. This sensors stuff is always causing a lot of complex problems.
     

  2. siropchik
    Froyo Nov 1, 2018


  3. J1541150345529
    Cupcake Nov 2, 2018


  4. Marzanna
    Cupcake Nov 3, 2018

    Marzanna , Nov 3, 2018 :
    I tried to reflash CM and SFOS but it didn't work. :(
    Maybe I'm doing something wrong?
    I completely wipe and format data on my phone before flashing.
    Checksums of CM and SFOS:
    Code:
    f84a728df2f77482b770007a529fb299  cm-12.1-YOG7D-sf-20170218-bacon.zip
    baaf5fd07948374e769e539aec36fab3  sailfishos-bacon-release-2.2.1.18-beta1-wdh.zip
    
    I tried to flash them separately and by adding another ZIP (in TWRP flashing menu).
     

  5. wdehoog
    Gingerbread Nov 3, 2018

    wdehoog , Nov 3, 2018 :
    What did not work? Did flashing fail? Did it not boot?
     

  6. wdehoog
    Gingerbread Nov 15, 2018


  7. G_Daniel_Kasak_Ycfj
    Cupcake Nov 23, 2018

    G_Daniel_Kasak_Ycfj , Nov 23, 2018 :
    I've just flashed Sailfish OS 3.0.0.8 and spent a couple of hours. This is my 1st experience with any version of Sailfish. I'm really impressed :) I've been trying to get an Android app installed, with no luck. It's not clear whether this version of Jolla I've just flashed will allow this or not. Some instructions ( eg https://jolla.zendesk.com/hc/en-us/articles/201440787#13 ) mention that you can download Android applications directly from the Jolla store ( and in fact have to do this for the 1st Android app installed ). But I don't see any Android apps in the store. I've downloaded aptoide.apk and tried to install from the apk, but instead of installing, I get returned to the browser, which downloads another instances of aptoide.apk. Confusing, but I'm determined :) So I downloaded KillDroid, entered my password, and tried restarting the Android service, and this failed. So anyway, I don't know what I'm doing, or whether any of these are expected to work with this version of Sailfish. Any clues? Thanks :)
     

  8. wdehoog
    Gingerbread Nov 23, 2018

    wdehoog , Nov 23, 2018 :
    Running Android apps under Sailfish OS currenlty only works with AlienDalvik which is closed source and only available for official devices and requires a bought license. The OPO is not an official device. Some people still managed to get it working though.

    Another solution could be Anbox but that currently does not run on the OPO. (requires a newer kernel and maybe more)
     

    G_Daniel_Kasak_Ycfj likes this.
  9. G_Daniel_Kasak_Ycfj
    Cupcake Nov 24, 2018

    G_Daniel_Kasak_Ycfj , Nov 24, 2018 :
    Got it. Thanks. I guess that's the end of this ROM for me then, at least for now. I'll look into the Anbox thing. I might be interested in helping get a later kernel working for OPO. Anyway, great effort on getting things so far!
     

  10. Marzanna
    Cupcake Dec 2, 2018

    Marzanna , Dec 2, 2018 :
    Sensors. They are not working.
    Are my checksums correct?
     

  11. wdehoog
    Gingerbread Feb 2, 2019

    wdehoog , Feb 2, 2019 :
    Hi,

    Here is the first beta release of Sailfish 3.0.1.11 (Sipoonkorpi) for the Oneplus One:
    https://github.com/wdehoog/sailfish-bacon-images/releases/tag/3.0.1.11-b1.

    Changes
    - Sailfish OS version 3.0.1.11 (Sipoonkorpi)
    - include harbour-messwerk (to test sensors)
    - include patched gst-plugins-base to fix buffer issues with internet streams


    I only tested installing the image and verified wifi, camera, video playing, gps, bluetooth and sensors are still working. The rest is up to you. So be careful.

    Important note: this version includes a firewall that resulted in kernel oops (reboot). Porter elros34 found what seem to be a fix but it is hard to test.
    If you experience reboots check kernel log with 'devel-su cat /proc/last_kmsg' if it indicates a problem with netfilter and ipv6 you can try to see if it helps to remove '/etc/connman/firewall.conf' and '/etc/connman/firewall.d'.
     

    luxuskamel likes this.
  12. Djurka
    Cupcake Feb 16, 2019

    Djurka , Feb 16, 2019 :
    thanx4ur effort,but how 'bout tethering (wifi)?is it working?if so,how?
     

  13. wdehoog
    Gingerbread Feb 17, 2019


    luxuskamel likes this.
  14. Djurka
    Cupcake Feb 18, 2019

    Djurka , Feb 18, 2019 :
    how come?didn't u test it urself?i'm asking,bc i'm facing the issue,that either connection via tethering does not get established,or immediately breaks after.could u,as lead developer clarify,if it is working on ur end,or a bug or...?
     

  15. wdehoog
    Gingerbread Feb 18, 2019

    wdehoog , Feb 18, 2019 :
    I never tested this and I am not going to. I have no data plan and have no use for this feature. But I guess if it works on other sailfish phones it should work on the opo as well. If you find something needs to change in the sailfish configuration or installed packages please let me know and I will try to fix it.
     

    luxuskamel likes this.
  16. Djurka
    Cupcake Feb 19, 2019

    Djurka , Feb 19, 2019 :
    should any1 encounter the same issue of mobile data connection interrupting,while being in tethering mode,i managed2fix it by diasbling dev mode prior2establishing a connection,which was causing the issue.now,if dev mode is disabled prior2establishing a tethering connection,as described,data connection keeps staying up,while tethering,as it should,without any interruptions anymore.sail on!
     

    wdehoog likes this.
  17. wdehoog
    Gingerbread Apr 11, 2019


  18. J1541150345529
    Cupcake Apr 12, 2019

    J1541150345529 , Apr 12, 2019 :
    Thanks as always wdehoog, if you don't need alien dalvik layer this is an awesome port device of sailfishos :)
     

  19. PRAZEWORKS
    Cupcake May 15, 2019

    PRAZEWORKS , May 15, 2019 :
    Hi and thanks for continuing to release these images, great work!

    I do have one issue with my fresh install and that is the camera is not working? Would anyone know how how to fix? I've re-flashed several times to see if that would solve it, but to no avail.
     

  20. J1541150345529
    Cupcake May 15, 2019

    J1541150345529 , May 15, 2019 :

    i'm currently using release 3.0.1.11 and camera works fine, but on my jolla c camera is broken and app doesn't appear between apps, anyway have you tried to launch csd (to test hw) from terminal? (just to understand if camera is detected)