111
Sailfish OS for OnePlus One

?

Will you flash Sailfish OS?

  1. Yes

    887 vote(s)
    39.9%
  2. No

    459 vote(s)
    20.6%
  3. May be, when it is stable enough.

    879 vote(s)
    39.5%
  1. wdehoog
    Gingerbread May 16, 2019

    wdehoog , May 16, 2019 :
    Hi,

    Here is the first beta release of Sailfish 3.0.3.9 (Hossa) for the Oneplus One:
    https://github.com/wdehoog/sailfish-bacon-images/releases/tag/3.0.3.9-b1.

    Changes
    * Sailfish OS version 3.0.3.9 (Hossa)
    * Fixed battery full detection
    * Fixed charging animation

    I only tested installing the image and verified wifi, camera, video playing, gps, bluetooth and sensors are still working. The rest is up to you. So be careful.

    Notes:
    * This version has few visible changes but a lot has changed under the hood. Most notably SailfishOS has moved from eglibc 2.19 to glibc 2.25. Weird things might happen.
    * Currently SailfishOS is shipped with libhybris version 0.0.5.30 but that is not working on ports using older bases (bacon uses hybris-12.1). The older libhybris version 0.0.5.25 seems to still work so this one is used.
     

    mjthos and luxuskamel like this.
  2. wdehoog
    Gingerbread May 16, 2019

    wdehoog , May 16, 2019 :
    What is not working? Does it not start, no view finder, no video, no pictures can be taken?

    Is there any related info in the logs (journalctl)?

    Did you use the specific CM12.1 image (see https://github.com/wdehoog/sailfish-bacon-images/wiki/Custom-CM-12.1-image)?
     

    luxuskamel likes this.
  3. PRAZEWORKS
    Cupcake May 16, 2019


    luxuskamel likes this.
  4. PRAZEWORKS
    Cupcake May 16, 2019

    PRAZEWORKS , May 16, 2019 :
    Is there a way to upgrade to this version without having to wipe my install and set everything up again??
     

    luxuskamel likes this.
  5. wdehoog
    Gingerbread May 16, 2019

    wdehoog , May 16, 2019 :
    You could try Over The Air update. See https://github.com/wdehoog/sailfish-bacon-images/wiki.
    I never tried this so I can't say if it works but the information comes from a forum user that did it multiple times.
     

    opoloco and luxuskamel like this.
  6. Djurka
    Cupcake May 16, 2019

    Djurka , May 16, 2019 :
    i'm facing the issue,that after a fresh install,time&date can only be set thru CLI - but not thru GUI.has no 1 else ran into this?
     

  7. wdehoog
    Gingerbread May 16, 2019

    wdehoog , May 16, 2019 :
    Never tried this before but indeed it does not work. The log (journalctl -af) says:
    Code:
    May 16 19:20:29 Sailfish timed-qt5[2436]: CRITICAL: can't set system time: Operation not permitted
    For you as well? No idea if this is a general SailfishOS thingy. Maybe you can ask at together.jolla.com.
     

    opoloco and luxuskamel like this.
  8. wdehoog
    Gingerbread May 18, 2019

    wdehoog , May 18, 2019 :
    Sorry but I made a mistake. The patched mce (fixing battery full detection) was not included in the 'testing' repository. Now it is.

    You can get this updated version by:
    Code:
    devel-su zypper ref adaptation-community
    devel-su zypper in mce
    
    I am not going to build and test a new image for this change only.
     

    opoloco, mjthos and luxuskamel like this.
  9. Djurka
    Cupcake May 23, 2019

    Djurka , May 23, 2019 :
    since we got battery detection&charging animation now,can we get a proper,matching boot logo,aswell to copliment the charging animation,we finally got,for a native sailfish touch&feel?tia
     

  10. wdehoog
    Gingerbread May 24, 2019

    wdehoog , May 24, 2019 :
    Sorry I don't have one. Looks like you can add you image using this tool: https://forum.xda-developers.com/on...od-cm12-logo-bin-image-injector-v1-0-t3161139 and once you have made one using fastboot you can flash it.

    -edit-

    I took the one from my phone and copy pasted from https://forum.fairphone.com/t/fp2-change-splash-image-splash-img/29758. See https://pasteboard.co/IgdEU8q.png.
     
    Last edited: May 24, 2019

    opoloco, mjthos and luxuskamel like this.
  11. Djurka
    Cupcake May 24, 2019

    Djurka , May 24, 2019 :
    thank you for the logo provided!i been stumbling across such tools,prior to posting here,but unfortunately all these tools, i stumbled upon,are windows-only.flashing the logo would not be an issue at all,since i know how to perform it via fastboot.the only thing,that is required,would be the conversion of .png to .bin.have you got a workaround for the conversion of .png into a flashable .bin or a tool,that worx for linux?other than that,thank you for your effort and thank you for the .png provided.now,the only thing required,is a proper working conversion to a flashable .bin.
     

  12. wdehoog
    Gingerbread May 24, 2019

    wdehoog , May 24, 2019 :
    The zip file contains the sources. Google for logoinjector + linux or build or sources and you will find some howtos.
     

    opoloco and luxuskamel like this.
  13. Djurka
    Cupcake May 25, 2019

    Djurka , May 25, 2019 :
    thanx for your hints!i've been trying the following,which seemed a promising way to go:
    https://github.com/WeAreFairphone/splash-imgs
    but always get that error-msg:
    python2: can't open file 'logo_gen.py': [Errno 2] No such file or directory
    after performing the command:
    python2 logo_gen.py <raster image file>
    (as described in the link,provided above)

    why is it so damn hard to simply convert a .png file into a flashable .bin for opo?
    i am struggling with it since days - with no success at all.
     

  14. wdehoog
    Gingerbread May 25, 2019

    wdehoog , May 25, 2019 :
    I would not use tools that are made for other phones unless you know what is going on.

    This seems like a good howto: https://blog.phils3r.de/linux/2018/05/12/Boot-Logo-OnePlus-aendern.html
    use the sources from the LogoInjector_v1.2 zip file.

    Buiding can be done with something like:
    Code:
    gcc lodepng.c LogoInjector.v1.2.c -o LogoInjector.v1.2
    
     

    opoloco and luxuskamel like this.
  15. goodvin
    Cupcake Jun 13, 2019


  16. wdehoog
    Gingerbread Jun 14, 2019

    wdehoog , Jun 14, 2019 :
    This sometimes happens to me when the first time wizard does not complete it's job. I only experience this once in a while during development. No idea why it failed for you and, sorry, no idea how to fix it.

    Maybe you can try to reinstall or first flash the factory image (see https://github.com/wdehoog/sailfish-bacon-images/wiki/Troubleshooting).
     

    opoloco, mjthos and luxuskamel like this.
  17. mjthos
    Cupcake Jun 18, 2019

    mjthos , Jun 18, 2019 :
    Hi all. I'm new to OnePlus and also to this forum. I successfully completed SFOS3 on my opo 2 days ago. Special thanks to Prazeworks for his youtube video and wdehoog who did all the heavy lifting for us and other members' contributions. I'm enjoying the move so far but I seemed to have missed the train that allowed android apps support. Not sure how useful the os will be without productivity apps but I will give it a decent run.
     

  18. opoloco
    Cupcake Jun 30, 2019

    opoloco , Jun 30, 2019 :
    Thanks for the brilliant work, wdehoog! I flashed a week ago and totally love SFOS on the OnePlus One. :hearteyes:

    Two quick things:

    1. I posted an "issue" on Github about the compass. It seems to be 90° off?! No idea, whether this has any implications. At least, PureMaps worked great on a longer distance yesterday despite of this.

    2. As for the bootlogo, I felt tempted to give it a go. However, after running LogoInjector.v1.2 I got a .bin file that was substantially smaller than the original one. Therefore, I didn't want to risk uploading it to the phone. Can anyone please verify, if this discrepancy is normal?
     

  19. wdehoog
    Gingerbread Jul 1, 2019

    wdehoog , Jul 1, 2019 :
    When I create a new bin it is 16,777,216 bytes. The exact same size as the original one. (Note that I did not try to flash it.)
     

  20. mjthos
    Cupcake Jul 27, 2019