110

Sailfish OS for OnePlus One

?

Will you flash Sailfish OS?

  1. Yes

    885 vote(s)
    39.8%
  2. No

    459 vote(s)
    20.6%
  3. May be, when it is stable enough.

    879 vote(s)
    39.5%
  1. nh1402 Donut Feb 9, 2016

    nh1402, Feb 9, 2016 :
    krnlyng and I don't have have a CM12.1 based phone, so you would have to port his changes to CM12.1 in order to get sfdroid working on the OPO, I'm currently working on integration which isn't platform specific, so things like showing Android Notifications, overriding the Android keyboard with the Sailfish one, importing contacts (for those who don't have a Google Account) from Sailfish into the CM base and that kind of thing, so if you have ideas of what to integrate then let me know.
     

    NotDead13 and CBpbxEcmecmBeH like this.
  2. AbhasJain Donut Feb 10, 2016

    AbhasJain, Feb 10, 2016 :
    I could find only 16 apps on the Jolla store, and I did install a few out of those available; am attaching a few snapshots here.
     

    Attached Files:


    aironeous, biltoad and vgrade like this.
  3. scandy Cupcake Feb 10, 2016

    scandy, Feb 10, 2016 :
    I can confirm that I get the same as AbhasJain, even with my Jolla account I createda while back, before flashing Sailfish on my OPO.

    What is involved in getting the backend servers accepting the OPO? An IMEI white list? Or is there some sort of Useragent string getting sent to the servers?

    Just out of curiosity, are there any stats on how many apps are in the Jolla Store atm?
    Are there different apps in the Jolla store compared to Warehouse?

    As far as I am aware, Warehouse dosnt have much of an appreview before they can go in.
    I assume the Jolla Store has some process for this?
     

  4. vgrade Honeycomb Feb 10, 2016

    vgrade, Feb 10, 2016 :
    Thanks for the feedback.

    I'm not sure what's involved in allowing access sorry. We have managed 70 up votes on https://together.jolla.com/question/127744/access-to-jolla-store-for-oneplus-one/ so the devs will be watching.

    I'm not aware of any status on app numbers, ask on together.

    Yes there is the Harbour process which vets apps before they can appear instore.

    vgrade
     

    AbhasJain and topfreitas like this.
  5. topfreitas Froyo Feb 10, 2016

    topfreitas, Feb 10, 2016 :
    @vgrade all my love to you! hahaha.

    I'll make a T-shirt with "Kudos to lord Vgrade". Man if you need any help, just let me know!
     

  6. inDAcore Eclair Feb 10, 2016

    inDAcore, Feb 10, 2016 :
    I tried to make new Jolla account as well. It just "seems" to work.
    Store then seems to show only those applications which I have installed from Warehouse.
    So backend-store is not actually open for us yet.

    In general there is much more applications than which you can find from Warehouse/openrepos.net so it would be nice to have it open!
    Can not say how many exactly but 100-150 native apps is my estimate.
     

    CBpbxEcmecmBeH likes this.
  7. mvmsaikrishna Ice Cream Sandwich Feb 10, 2016


    vgrade likes this.
  8. Aditya Wasan Gingerbread Feb 11, 2016

    Aditya Wasan, Feb 11, 2016 :
    Hey guys

    We'll I'm new to multirom and SFOS so what I did was
    Broken OS 6.0.1 Primary And Installed SFOS on multirom with cm 12 as base but it is stuck at 1+ logo for more than 10 mins some help please
     

  9. mvmsaikrishna Ice Cream Sandwich Feb 11, 2016

    mvmsaikrishna, Feb 11, 2016 :
    I had cm12.1 as primary and sfos and cm13 as primary. You can try to switch cm13 to secondary..
     

  10. paultruland Gingerbread Feb 12, 2016

    paultruland, Feb 12, 2016 :
    I'm new to this whole multi-rom game myself...and I tried to search this thread first so forgive me if this has been answered. I've got everything working/booting (CM13 nightlies w/ lightning kernel for primary, Sailfish OS with CM 12.1 secondary), however I have to run the terminal command to unhide masked settings and fix my APN settings each boot; the changes never save. Is that the expected behavior at this point or is there something I can do?
     

  11. vgrade Honeycomb Feb 12, 2016

    vgrade, Feb 12, 2016 :
    Thanks for the report, manual setting of the APN are not saved as there is a permissions issue.

    chown -R radio:radio /var/lib/ofono

    BR

    vgrade
     

    msri3here likes this.
  12. paultruland Gingerbread Feb 12, 2016

    paultruland, Feb 12, 2016 :
    Thanks for the tip...and thanks for all your work on the ROM; this is very cool!
     

    vgrade likes this.
  13. ruedigergad Donut Feb 12, 2016

    ruedigergad, Feb 12, 2016 :
    Hi,

    first of all huge thanks to vgrade and contributors.
    I specifically bought a used OnePlus One because of the apparently promising work and so far things seem to work pretty nicely.

    Second, I can confirm that I have at least Ogg Video playback working in the browser.
    I will try to provide more information soon.
    In a nutshell, I installed everything gstreamer-foo related that I could find so far and this seems to have improved things.

    Please note that I did not use the warehouse openrepos client but downloaded those packages including dependencies that I installed from openrepos manually.
    The reason is that when I tried to install ytplayer from openrepos via warehouse, the search in ytplayer did not work, apparently due to issues sending or receiving the search requests.
    After doing a complete reflash and installing ytplayer manually, the search functionality of ytplayer works as expected.

    Thanks a lot again and cheers,

    Ruediger
     

    inDAcore likes this.
  14. ruedigergad Donut Feb 12, 2016

    ruedigergad, Feb 12, 2016 :
    Here is a bit more information:
    For comparison, I uploaded the outputs of "gst-inspect-0.10", "gst-inspect-1.0", "pkcon search name gst", "GST_DEBUG=3 harbour-ytplayer", and "GST_DEBUG=4 harbour-ytplayer", from my Jolla Phone and the OnePlus One to pastebin:

    Jolla Phone
    gst-inspect-0.10: http://pastebin.com/qpDPe03P
    gst-inspect-1.0: http://pastebin.com/2pwxjk9q
    pkcon search name gst: http://pastebin.com/aHjhsjku
    GST_DEBUG=3 harbour-ytplayer: http://pastebin.com/a00KdCgp
    "GST_DEBUG=4 harbour-ytplayer": http://pastebin.com/e37da6U7

    OnePlus One
    gst-inspect-0.10: http://pastebin.com/sVh5FbqJ
    gst-inspect-1.0: http://pastebin.com/kHe5Fcw5
    pkcon search name gst: http://pastebin.com/QsuTvPJT
    GST_DEBUG=3 harbour-ytplayer: http://pastebin.com/3SHRkvpW
    "GST_DEBUG=4 harbour-ytplayer": http://pastebin.com/tdV3VJVW

    ytplayer seems to use gstreamer-1.0.
    With respect to "GST_DEBUG=4 harbour-ytplayer", one interesting difference becomes visible around:
    Line 619 (OnePlus One) http://pastebin.com/tdV3VJVW
    vs.
    Line 534 (Jolla Phone) http://pastebin.com/e37da6U7

    While on the jollaphone, the droidcodec gets created:
    0:00:00.842728522 5645 0x4543d520 INFO droidcodec gstdroidcodec.c:210:gst_droid_codec_get_all_caps: caps video/mpeg, mpegversion=(int)4; video/x-h264, stream-format=(string)avc, alignment=(string)au; video/x-h263

    On the OnePlus One, the codec cannot be resolved:
    0:00:00.523734583 25566 0xb3445230 WARN uridecodebin gsturidecodebin.c:939:unknown_type_cb:<uridecodebin0> warning: No decoder available for type 'video/x-h264, stream-format=(string)avc, alignment=(string)au, level=(string)3.1, profile=(string)high, codec_data=(buffer)0164001fffe100186764001facb4028023fc4420000003002000000601e3065401000468ee3cb0, width=(int)1280, height=(int)546, framerate=(fraction)24/1, pixel-aspect-ratio=(fraction)1/1, parsed=(boolean)true'.

    Edit:
    Searching further reveals that the Jolla Phone has the following gstreamer plugins installed:
    Installed gstreamer0.10-droidcamsrc-0.1.1-10.11.3.jolla.armv7hl GStreamer source for Android camera hal
    Installed gstreamer0.10-droideglsink-0.1.0-10.7.5.jolla.armv7hl droideglsink HW accelerated sink
    Installed gstreamer1.0-droid-0.20150819.0-10.6.1.jolla.armv7hl GStreamer droid plug-in contains elements using the Android HAL
    That are not available on the OnePlus One
     
    Last edited: Feb 13, 2016

  15. nishant.roy24 Cupcake Feb 13, 2016


  16. ruedigergad Donut Feb 13, 2016

    ruedigergad, Feb 13, 2016 :
    Some more feedback and thoughts on the current video playback status:

    Ogv also works from within the gallery.

    One of the more commonly used codecs in the wild seems to be video/x-h264.
    While there seems to be support for video/x-h264 in gstreamer-0.10 on the OnePlus One in form of gstreamer-plugins-ffmpeg-extra, unfortunately, there seems to be no support for this codec in gstreamer-1.0 on the OnePlus One yet.
    However, gstreamer-1.0 seems to be the standard that is used, e.g., in qt5-qtmultimedia, which in turn is what most applications seem to use.

    So, just to brainstorm a bit on ways for watching videos:
    - Find a video/x-h264 codec for gstreamer-1.0, e.g.,
    - gstreamer-plugins-libav (libav is "the new ffmpeg")
    - gstreamer-plugins-droid (requires support from the hardware adaptation)
    - Recode videos to ogv (which would be fine for my use cases at the moment)
    - Find a video player that still uses gstreamer-0.10.

    There is already a gstreamer libav plugin available, however, for this build, support for h264 was disabled.
    Looking at the build, it seems that this gstreamer libav only supports some audio codecs like mp3 and aac.

    I am a bit in a hurry so I cannot elaborate more on this, right now.
     
    Last edited: Feb 13, 2016

    aironeous and CBpbxEcmecmBeH like this.
  17. VeryMilan Honeycomb Feb 13, 2016


  18. fajdo Cupcake Feb 13, 2016

    fajdo, Feb 13, 2016 :
    Vgrade, on CM I had a problem with in call volume, people can't hear me, I solved that whit build. promp. When I installed sailfish is problem again there. Is there any way to fix that. By the way I love sailfish. I miss the most Android games, hope this will resolve soon.
     

  19. ruedigergad Donut Feb 14, 2016

    ruedigergad, Feb 14, 2016 :
    Another brief update:
    I built gstreamer10-libav with h264 decoder support.
    With this version, I can play mp4 videos, e.g., in the gallery and with ytplayer.

    I quickly created a packaged version that is available here:
    https://openrepos.net/content/ruedigergad/gstreamer10-libav

    Please note that it is literally years since I built the last rpm for SailfishOS and that I did not have so much time, right now.
    So, I only tested it very briefly on my OPO and it seems to work.

    All feedback is highly appreciated.


    Furthermore, some more notes on other codecs I have installed:
    As gstreamer0.10 seems not to be used anymore, I removed the gstreamer0.10 related plugins that I had installed from OpenRepos including their dependencies.
    So, the remaining plugins from OpenRepos that I have currently installed are:
    gst-plugins-bad-extra-1.4.5-1.armv7hl.rpm
    gst-plugins-ugly-1.4.5-1.armv7hl.rpm
     

  20. mvmsaikrishna Ice Cream Sandwich Feb 14, 2016

    mvmsaikrishna, Feb 14, 2016 :
    Great! Thanks for your contribution.