0
Samsung Health not auto recording steps etc.

  1. X1517396854503 Ice Cream Sandwich Mar 20, 2018

    X1517396854503, Mar 20, 2018 :
    Hi,

    I am using Samsung Health app in all my phones. In my 5t it is not automatically recording steps. I have to open the app once to start the counter. All the permissions are already granted. What should I do?

    Thanks
     

    #1
  2. G_Angelos_Theo_(angelos) Honeycomb Mar 20, 2018


    #2
    X1517396854503 likes this.
  3. NikhilJagtap Ice Cream Sandwich Mar 20, 2018


    #3
    X1517396854503 likes this.
  4. X1517396854503 Ice Cream Sandwich Mar 20, 2018

    X1517396854503, Mar 20, 2018 :
    Thanks. Let me check and get back to you.
     

    #4
  5. X1517396854503 Ice Cream Sandwich Mar 27, 2018


    #5
  6. redlinecoatings Ice Cream Sandwich Mar 27, 2018

    redlinecoatings, Mar 27, 2018 :
    I was having the same issues with Samsung health not counting my steps and I tried everything to keep it running. I gave up and installed Google Fit and so far so good. The widget sometimes isn't quick to update but if you open the app the steps are all there.
     

    #6
    MentalDraco and X1517396854503 like this.
  7. X1517396854503 Ice Cream Sandwich Mar 27, 2018

    X1517396854503, Mar 27, 2018 :
    All my other devices are using Samsung Health and I have synced them. Moreover it has more options than Google Fit. It works fine even in an old Moto, idk what's the issue with the 5t.
     

    #7
  8. nileshkmakwana Froyo Mar 27, 2018

    nileshkmakwana, Mar 27, 2018 :
    I am having same trouble mate. I was use to have samsung S5. I was so impressed with Samsung health app. Unfortunately it does not work on my 3T either. So I just gave up. Buy any cheap health tracker for that purpose...thats it.
     

    #8
    TheUwaisPatel and X1517396854503 like this.
  9. redlinecoatings Ice Cream Sandwich Mar 27, 2018

    redlinecoatings, Mar 27, 2018 :
    Ya I'm not sure either. It is a nice app that syncs all of your data but I gave up on it. Have you tried leaving feedback or contacting them through the playstore to see if there's anything that can be done?

    Also one other thing to try if you haven't is go into the settings and turn on the notification panel step counter. That might keep it active in the background.
     

    #9
    X1517396854503 likes this.
  10. X1517396854503 Ice Cream Sandwich Mar 27, 2018

    X1517396854503, Mar 27, 2018 :
    As per Samsung support it should work on all Android devices, if its not working then we need to contact the oem.

    Tried but same result.
     

    #10
  11. X1517396854503 Ice Cream Sandwich Mar 31, 2018

    X1517396854503, Mar 31, 2018 :
    It is working in almost every Android device that I tested, except oppo and vivo. One more issue that I found with the 5t is that when the wifi hotspot is on and you answer a call, the hotspot remains on/activated but the internet cannot be accessed. I regret buying 5t now, awesome processor and everything but it ain't covering these tiny things. No offense to anyone though.
     

    #11
  12. Fredman Honeycomb May 26, 2018


    #12
  13. X1517396854503 Ice Cream Sandwich May 26, 2018


    #13
  14. Tamalone Cupcake Jun 20, 2018

    Tamalone, Jun 20, 2018 :
    Just curious if you've found a solution yet. I have the same problems on my OP6.
     

    #14
  15. X1517396854503 Ice Cream Sandwich Jun 20, 2018

    X1517396854503, Jun 20, 2018 :
    Won't work in op. Many users at xda can also confirm the same.
     

    #15
  16. Tamalone Cupcake Jun 20, 2018

    Tamalone, Jun 20, 2018 :
    Too bad. Thanks for your quick reply.

    Can you recommend a similar app? Or is Samsung Health just that good?
     

    #16
  17. X1517396854503 Ice Cream Sandwich Jun 20, 2018

    X1517396854503, Jun 20, 2018 :
    Your welcome. No other app can beat Samsung Health trust me I have tried them all. I don't use any health app in the 5t. This experience has changed my motto to Never a op Again.
     

    #17
  18. C1539554626990 Cupcake Oct 15, 2018

    C1539554626990, Oct 15, 2018 :
    I had the same issue with the 5t and fixed it.
    I went into settings, battery, batter optimisarion, and disabled it for Samsung Health.
    Hope this helps :)
     

    #18
  19. X1517396854503 Ice Cream Sandwich Oct 15, 2018

    X1517396854503, Oct 15, 2018 :
    Unfortunately it didn't work in my and my friend's 5t.
     

    #19
  20. Mayur Shingate Cupcake Dec 5, 2018

    Mayur Shingate, Dec 5, 2018 :
    It was not working for me too. I changed the Battery Optimization of Samsung Health to 'Don't optimize' in Settings and restarted my phone. Now, It's working for my OP6. Try once.
     

    #20