0
Screen Auto rotate turns off automatically (OP 5T)

  1. jaydesai749
    Eclair Dec 8, 2017

    jaydesai749 , Dec 8, 2017 :
    Using the new OP5T, the screen Auto rotate feature switches off suddenly when in use, eg. when watching a YouTube video or any other video, the screen auto rotate suddenly turns off and turns into portrait mode. This occurs after a couple of hours after I specifically turn it on from the display settings.
    Also it disappears from the notification shortcuts, so I have to go again to the display settings and turn it on. If anyone knows how to keep it permanently on the notification shortcuts, please help.
    Does anyone else face this too? Coz this never happened in my earlier smartphones untill when the phone is restarted.

    Thanks for your time.
     

    #1
  2. goden1357
    Cupcake Dec 8, 2017

    goden1357 , Dec 8, 2017 :
    Especially when I take pictures after to review and holding the phone horizontally or vertically and the pictures also will automatically rotate.

    I don't know if this is a bug?
     
    Last edited: Dec 8, 2017

    #2
  3. pgrey
    Ice Cream Sandwich Dec 25, 2017

    pgrey , Dec 25, 2017 :
    It's a bug, no question, I'm trying to figure out if there's a "bug filing" mechanism here, perhaps an Admin will comment?

    My 5T constantly switches itself back to portrait, from "auto rotate".
    I was thinking it was happening maybe once/day (4.7.4 build), but now I've seen it twice today, already, now that I'm tracking it more.
    It's insanely irritating, trying to view/show people pictures, and it just stops rotating because the mode is changed.

    Maybe there's a way to lock it, someone may know a "one off" setting somewhere too...
     

    #3
  4. dcbStudios
    Cupcake Dec 19, 2018

    dcbStudios , Dec 19, 2018 :
    As a work around for now, I've gone through and installed an app called Locale and an app called Rotation Locker which has an add-on for Locale to set auto-rotation. I set the auto-rotation instance in the default so that this will check if the setting ever turns off. If it does...thanks to the persistent background setting that the Dev put into the add-on...it will kick it right back on (in theory... no problems so far in my end). I know this is for the OP 6...but I'm also having this same issue in my OP 6T, so I needed my own work around. Hope this helps. - Dan B.
     

    #4
  5. ouyamaster
    Honeycomb Feb 3, 2019

    ouyamaster , Feb 3, 2019 :
     

    #5
  6. ouyamaster
    Honeycomb Feb 3, 2019


    #6
    dcbStudios likes this.
  7. dcbStudios
    Cupcake Feb 3, 2019

    dcbStudios , Feb 3, 2019 :
    Cool beans... Glad I could help. Hopefully we get an official fix so we don't have to have extra background stuff running.
     

    #7
  8. ouyamaster
    Honeycomb Feb 3, 2019

    ouyamaster , Feb 3, 2019 :
    dcbStudios

    Cool beans... Glad I could help. Hopefully we get an official fix so we don't have to have extra background stuff running.



    Exactly and Although Locale is a great app it's ten bucks I could have saved.

    Word of warning though you still sometimes have to force Landscape when viewing pictures but at least On Auto everything else autorotates and no need to keep ticking hybernate 30 minutes Everytime you wake your phone.
     

    #8
  9. michelleboswell
    Cupcake Aug 2, 2019

    michelleboswell , Aug 2, 2019 :
    What's the update on this... where's One Plus fix... this has just started happening on my device in 2019 after an update. Please resolve!!!!
     

    #9
  10. G1510792206174
    Froyo Aug 10, 2020

    G1510792206174 , Aug 10, 2020 :
    alguma solução, isso é um problema de software?any solution, is this a software problem? got it on oneplus 7
     

    #10