4
Screen overlay detected CM 13

  1. rramanbbansal
    Cupcake Jun 9, 2016

    rramanbbansal , Jun 9, 2016 :
    I had same problem since yesterday night in One Plus 2 post I upgraded to Marshmallow. Had gone thru various blogs and communities, couldn't find any solution as I neither had any twilight or any other such app installed. But tried following and it worked ABSOLUTELY FINE for me. So, you can try too.
    Go to settings >> Apps >> App Settings (a gear icon on top right corner) >> Access permissions >> Give relevant access to apps in access permissions and Advanced permissions (I have given all types of access to my all apps)
    Afterwards, I have opened each and every app to see, whether it works and IT WORKED. All my apps are working fine and I am back to enjoying Marshmallow on One Plus 2.
     

    #21
  2. nehagupta.dun
    Cupcake Jun 9, 2016

    nehagupta.dun , Jun 9, 2016 :
    Hi! There is no sound for incoming calls on my phone. The notifications are on and I even rebooted the phone in safe mode but no use. It's still not working. Plz help!
     

    #22
  3. nehagupta.dun
    Cupcake Jun 9, 2016


    #23
  4. vahid183
    Gingerbread Jun 9, 2016

    vahid183 , Jun 9, 2016 :
    Thats the second thing i tried yesterday. When i go to settings >> Apps >> App Settings (a gear icon on top right corner) >> Access permissions >>storage permissions and i try to change it(this goes for all the apps listed here not only whatsapp as i origanly thought) I still get the overlay detected popup
     

    #24
  5. Arian hysi
    Cupcake Jun 9, 2016

    Arian hysi , Jun 9, 2016 :
    Thank very much
     

    #25
  6. sri75_2000
    Cupcake Jun 9, 2016

    sri75_2000 , Jun 9, 2016 :
    Thanks for your prompt and effective post, it really worked. the clean master,CM security, battery doctor apps such try to create issues during installation and deny permissions.Now my problem is resolved , thanks.
     

    #26
  7. sri75_2000
    Cupcake Jun 9, 2016


    #27
  8. kedarvtaskar
    Cupcake Jun 9, 2016

    kedarvtaskar , Jun 9, 2016 :
    Perfect! I had cleanmaster installed. I uninstalled it and it works! Fantastic. Thankyou all for your great suggestion :)
     

    #28
  9. AnitaZoet
    Cupcake Jun 9, 2016

    AnitaZoet , Jun 9, 2016 :
    I was getting so frustrated!! But deleting Clean Masters worked for me! Thank you so much!
     

    #29
  10. MiladDaliri
    Cupcake Jun 9, 2016

    MiladDaliri , Jun 9, 2016 :
    Hi,

    I dont understand, how did you solve the problem did you say? I have exact the same problem with all my apps including whatsap. i cannot even look in my contacts, it does not allow me to give permission; i get screenoverlay error.
     

    #30
  11. vahid183
    Gingerbread Jun 9, 2016

    vahid183 , Jun 9, 2016 :
    I didnt solve it. still have the problem. At first google hangouts worked fine one time only than it to started poping up the overlay screen warning

    Was forced to to switched to my backup phone till this is solved :(:(
     

    #31
  12. p_gandhi
    Cupcake Jun 9, 2016

    p_gandhi , Jun 9, 2016 :
    Disable AVG before installing.............................
     

    #32
  13. p_gandhi
    Cupcake Jun 9, 2016

    p_gandhi , Jun 9, 2016 :
    Try to change permission in SAFE MODE......it worked for me.
     

    #33
  14. vahid183
    Gingerbread Jun 9, 2016

    vahid183 , Jun 9, 2016 :
    Tried that yesterday no effect.


    Just finished a factory data reset (settings>>backup&reset>>factory data reset) and installed whatsapp and it seems to be working. So fingers crossed!!!


    When i tried to do a hard reset(holding power button and volume down button ect) the menu I end up in was in Chinese and i had no idea what to chose lol
    anyone know how to change to English??
     

    #34
  15. MobileGreg
    Cupcake Jun 9, 2016

    MobileGreg , Jun 9, 2016 :
    For what it's worth, I had the same issue where an app asking for access to files then told me it couldn't move forward b/c of the Screen Overlay issue. I had 15+ apps with "Overlay" permissions, so i couldn't reasonably disable all of them each time I wanted to use an app, but I DID have one specific app I suspected was the culprit called "Berry Search" which is a tiny app that adds a little magnifying glass to the edge of the screen to use for quick search / launch of apps. When I closed that app and retried to give the app permission, I didn't have any issues.

    All in all, it seems that it's more of a matter of whether the Overlayed app is actually running at the time you're trying to give the other app permission. If it IS running, restart the phone and try to give the new app permission before the overlay app opens up. If it opens automatically, try force closing it and giving permission to the new app again with the "Overlay" app closed completely.
     

    #35
  16. shruti.owalekar
    Cupcake Jun 9, 2016

    shruti.owalekar , Jun 9, 2016 :
    Working for me too!! Thanks!!!
     

    #36
  17. AakashVerma4
    Cupcake Jun 9, 2016

    AakashVerma4 , Jun 9, 2016 :
    Guys try this. Setting>Apps>Configure apps(that symbol on top right) >Draw over other apps.
    U will see a list of apps. One of these apps should be causing the problem. So just click and disable 'Permit drawing over other apps'. Try with apps that you suspect might be causing. For me it was a file manager app that I installed to manage my office files.

    Might be a different file for you guys. WORKED FOR ME!
    Let me know.
     

    #37
    gioninardo likes this.
  18. MeiMei246
    Cupcake Jun 9, 2016

    MeiMei246 , Jun 9, 2016 :
    This worked perfectly! I was getting dizzy with the looped messages! Thank you :)
    How about reinstalling a battery saving app now; will it reoccur?
     

    #38
  19. Audrius
    Cupcake Jun 9, 2016

    Audrius , Jun 9, 2016 :
    Thanks a lot, it works!
     

    #39
  20. malidan
    Marshmallow Jun 9, 2016

    malidan , Jun 9, 2016 :
    I've been running MM on my Nexus 6 since last year and I have never had this issue, I now have N and I still have never seen this issue.
    A MM thing? I don't think so;)
     

    #40