78
SD card problem in ONE X

  1. KSomi
    Gingerbread Nov 11, 2015

    KSomi , Nov 11, 2015 :
    there you have it, straight from OnePlus. Helen tries to put it nicely..but hey, at least they are honest enough and have promised to solve some of it in one or two weeks. ;)
    By the way, those having issues with supported file systems...so the tussle with FAT32, NTFS..gotta wait..! :rolleyes:
     

  2. MrEntropic
    Donut Nov 11, 2015

    MrEntropic , Nov 11, 2015 :
    I've read through this thread and others, and have come to the following conclusions:
    - most problems occur with higher capacity SD cards (64 GBs and above), while fewer are found with 32 or 16 GBs
    - Some users experienced problems only AFTER the OTA update
    - Some users were able to fix their problem by formatting cards to NTFS
    - All of the above mentioned statements are intermingled among posts.

    There is no clearly defined problem with the SD card, which makes it all the more tedious.
    All we can do is try a few of the proposed methods in the threads, and/or wait for an OTA update that alleviates these problems.
    It's a matter of patience, but fortunately, a solution will most likely be available in the future.
     

  3. incidence29
    Donut Nov 11, 2015

    incidence29 , Nov 11, 2015 :
    Hi everyone!

    I got yesterday my OPX (first OP, coming from Galaxy S3). I like the phone a lot BUT I also encountered the SD Card issue. I've been playing around in order to shed some light "empirically". Hope this helps the dev team as well as other users until the promised fix reaches us (apparently 1-2 weeks according to @Helen --> thanks by the way!)

    I have two cards: MicroSDXC 64 GB Class 10 by Samsung and a very old MicroSD 2 GB by Kingston.

    I tried formatting both of them with different file systems, here are the results:

    - 2GB SD (with OxygenOS 2.1.2 build 14_151103):
    • exFAT: not detected at all, no error messages
    • FAT32: detected, works! (meaning normally seen in stock and third party file managers, and apps in general: Google photos, music, Here maps...)
    • FAT: detected, works!
    • NTFS: detected, works!
    - 64 GB SDXC (with OxygenOS 2.1.2 build 14_151103)
    • exFAT: not detected at all, no error messages (same with OxygenOS 2.1.0!!! Does not depend on last OTA update...)
    • FAT32: not detected at all, no error messages
    • NTFS: detected, works (but I would prefer using exFAT)
    The USB OTG (tested with both with a 2GB usb stick and with the microSD cards above, inserted in a USB reader) shows similar issues with file systems:
    • exFAT: detected but not working, stuck on error checking (all three storages)
    • FAT32: works on the 2 GB usb stick and the 2GB SD card (64 GB not tested)
    • NTFS: works on the 2 GB usb stick (others not tested)

    The failed detection of some file systems and sizes is a bug, and a big one, it should have been tested properly before releasing the software/phone. Anyway I'm sure they are working very hard on it.

    Detection bug apart, another big issue is the poor microSD UX, as already written extensively on the forum:
    • Storage is not appearing in the settings > storage menu: here the used and free space should be listed, as well as the FORMAT and UNMOUNT commands (if you remove the SD the phone complains you didn't unmount correctly!). I guess unmount should also be available for a USB OTG drive.
    • A fundamental option to save photos and videos directly SD card in the camera app.
    • Many complain about not being able to move apps to the SD card: I personally don't consider it a big problem. It's not reliable nor fast to do so (and not suggested by Google either). I prefer to keep apps on the internal memory.
    By the way, i don't want to go off topic but the Camera app (v 1.1.0) is a disappointment for me. No manual controls at all, except the exposure compensation, which I like! :) The user should be able to shoot in full auto but also have the possibility to change some parameters if he wishes to. For example: metering mode, ISO, shutter speed, white balance. I guess these are more complicated and hence require more time developing. But hopefully the camera team is already working on them.

    For the moment focus on the SD related detection bug and UX features! Good work!
    Hope it helps!
     
    Last edited: Nov 12, 2015

  4. MrEntropic
    Donut Nov 11, 2015

    MrEntropic , Nov 11, 2015 :
    By the way:

    Received my Oneplus X yesterday, amazing phone, stunning for this price!
    As with most, SD card did not work (checking for errors perpetually) (64 GBs).
    Did the OTA update, still did not work (checking for errors).
    I then proceeded to format the card. It was in exfat by itself. Formatted it to NTFS.
    It is now working!
    It is not recognized by the storage tab in settings, but Files app and ES file explorer detect it, so i guess it might be functional.
     

    jwkreule and KSomi like this.
  5. tatasse
    Froyo Nov 11, 2015


  6. tatasse
    Froyo Nov 11, 2015


  7. vinodk.me
    Cupcake Nov 11, 2015


  8. rohanh
    Eclair Nov 11, 2015

    rohanh , Nov 11, 2015 :
    Didnt show in "Storage" but Solution is Use any file explorer , like ES File It will detect your SD Card.
     

  9. simranbindra0017
    Cupcake Nov 11, 2015


  10. SapilautX
    Ice Cream Sandwich Nov 11, 2015

    SapilautX , Nov 11, 2015 :
    Just a quick info.. OPX users can now a bit smile :)

     
    Last edited: Nov 11, 2015

    Ceasedd likes this.
  11. drjeevak
    Cupcake Nov 11, 2015

    drjeevak , Nov 11, 2015 :
    Does anyone have a work around for getting the camera to save images on the SD card?

    Also, why does whatsapp save images to the memory despite instructing it not to?
     

  12. ivsivris
    Gingerbread Nov 11, 2015

    ivsivris , Nov 11, 2015 :
    The SD I'm currently using in my Oneplus X:
    • Samsung 32GB micro SD Pro Class 10 70MB/s (#SAM-MGBGB/32GB)
    Took it out of my bike navigation, so therefore I cannot see how it's formatted. What does work is quite simple. File Manager sees the SD, Google Play Music sees the SD and it's music on there.

    What doesn't work is 'moving' the possible apps to the SD. Stated by 'not enough space'. I am currently trying to download some offline maps for Nokia's Here Maps. It does not see the SD card so far, but I'm going to try download and relocate to SD..

    // EDIT

    Here Maps has the option to select a different storage option. SD is recognised and now I am downloading offline maps to the SD! Looks like I don't have much of trouble after all.
     
    Last edited: Nov 11, 2015

  13. taaeem
    Eclair Nov 11, 2015

    taaeem , Nov 11, 2015 :
    So I have 16GB SDHX Card which I used in my prior phone and I reformatted it to NTFS and it isn't recogniced in settings but visible in file managers. But I can't write to the card in any way...
     

  14. Jerry000
    Gingerbread Nov 11, 2015

  15. DashWatson
    Donut Nov 12, 2015

    DashWatson , Nov 12, 2015 :
    Hey bro. I have the same card. Use the card reader/adapter, put the card in the computer, format it in NTFS. Then pop it back in the phone. It works without problems. The problem lies only in the exFAT formatting. Wait for OnePlus to fix the exFAT support in the next update. Till then, use NTFS formatting...
     

    adarshbhat.88 likes this.
  16. DashWatson
    Donut Nov 12, 2015

    DashWatson , Nov 12, 2015 :
    To everyone who is using a 64 GB and above card, pop it in your computer, format it in NTFS and then put it in your phone again. It's still not visible in the storage settings, but file managers like OnePlus's Files and ES File Explorer are able to recognize, read and write on it. Wait for OnePlus to fix the exFAT support and the storage settings bug...
     

  17. DashWatson
    Donut Nov 12, 2015

    DashWatson , Nov 12, 2015 :
    Accurately put. Everyone seems to be so focused on micro SD cards that they've completely forgotten about USB-OTG.

    Apart from the SD card not showing up in storage settings and the exFAT problems, there is also no way to unmount them safely. So if you just pull it out, it shows "unexpectedly removed". Same us the case with USB-OTG. It works. But it doesn't show up in the storage settings and there's no way to safely unmount it. OnePlus, take note. Please fix the USB-OTG problem in the same update too...
     

  18. sandych6687
    Donut Nov 12, 2015

    sandych6687 , Nov 12, 2015 :
    Cant still create a thread and that's why putting this up here..Does any one plus x user face issues with double tap.Mine worked fine for two days but now after being in sleep state for sometime the phone doesn't register the double tap,instead I need to use the button.Is this normal or some kind of an issue.Lately I see that even a 10 mins of sleep too makes it difficult for one plus x to register D2W
     

  19. sandych6687
    Donut Nov 12, 2015

    sandych6687 , Nov 12, 2015 :
    OPX is good.I didn't update and hence the problem is not there
     

  20. piqson
    Cupcake Nov 12, 2015

    piqson , Nov 12, 2015 :
    Yes I am also facing the same problem regarding SD card detection in my OPX. I have a 32GB sd card, it shows in the files but does to allow me to move the larger applications onto the sd card. Nor is it showing up in storage (settings) or any other application.