0
Sd card unexpectedly removed

  1. NiKflames
    Gingerbread Jun 23, 2017

    NiKflames , Jun 23, 2017 :
    I got a new class 10 u1 micro sd card a few weeks ago and I've been unable to get proper use out of it. I keep getting "sd card was unexpectedly removed" after a few hours of usage. Most times it mounts back or i have to reboot my OPX before it can detect the card again. The memory card doesn't seem to be the issue as it works well on another device. I've done a lot of research on the issue but no luck solving it. Please can i get suggestions that doesn't involve me getting a new micro sd card or factory resetting my phone
     

    #1
  2. G_Pavan_Teja_VWnb
    Cupcake Jun 28, 2017


    #2
  3. MdAH24633
    Cupcake Jun 29, 2017


    #3
  4. NiKflames
    Gingerbread Jul 2, 2017

    NiKflames , Jul 2, 2017 :
    UPDATE: I finally decided to factory reset my phone only to go from frying pan to fire, I'm no longer able to format any micro sd card through my phone and i still get the unmounts. I've tried these cards on laptops and other phones without any errors where as formatting with my phone now brings the error in the screenshot. It's really annoying given that i could format any card prior to factory resetting. How factory resetting brings about a problem is beyond me! I began thinking it was hardware related but refused to fall to such swift conclusion so i downgraded to OOS 2.2.2 (lollipop) for testing and just as i suspected, i was able to format again. The "sd card was removed unexpectedly" error still persisted though so there was no point remaining on lollipop with all its disadvantages and performance problems. I'm back on OOS 3.1.4, still can't format any micro sd card (i don't get this at all!) and still get the unmounts problem too so I'm back at square one with an extra burden. I've reset my phone more than five times I believe in the past week. I'm so fed up, I think I'll just stick to my old 8GB class 6 or 4 (not sure) micro sd. It seems OOS has compatibility issues with certain micro sd cards (I'm not willing to buy another card only to face the same problem) or maybe the card is on the thin side. The card dimensions are as follows:
    Size (L x W x H mm)
    11×15×1
    .
    PS: is there a way to fix the format issue I'm currently facing? Like i said, i was able to format before factory resetting. Any assistance will be well received.
     

    Attached Files:

    Last edited: Jul 2, 2017

    #4
  5. NiKflames
    Gingerbread Jul 28, 2017

    NiKflames , Jul 28, 2017 :
    I finally got another one, a u3 micro SD card this time. I've had no issues so far (almost 3 days)
     

    #5