22
[Solution] - Protected apps disappear!

?

Was this helpful?

  1. Yes

    64.7%
  2. No

    11.8%
  3. Already knew it!

    13.7%
  4. Good to know!

    17.6%
Multiple votes are allowed.
  1. hasith777
    Gingerbread Oct 3, 2014

    hasith777 , Oct 3, 2014 :
    I saw people complaining about protected apps disappearing sometimes when you use protected app feature...this is one of the things that you could do to get it back!

    1. press the button which brings out the wallpaper/widgets/themes on your home screen (the button left to your home button, don't know what to call it sorry :) and this could be a different button if you customized it) - refer screenshot so you will know what button to press

    2. press the 3 dots top of the menu (refer screenshot)

    3. Go right to the bottom and you will find an option for "Protected apps" select that and there will be a list of apps which you could make appear or disappear..

    4. If you see the apps which were disappeared and the check boxes are not checked, check the boxes exit the menu come back and uncheck them..after unchecking, for me the apps reappeared and I could access them..

    hope this helps..
     

    Attached Files:


    #1
  2. COPIOUS
    Honeycomb Oct 3, 2014


    #2
    hasith777 likes this.
  3. Stephen Gunnoe
    Ice Cream Sandwich Oct 3, 2014


    #3
  4. carbine30
    Marshmallow Oct 3, 2014

    carbine30 , Oct 3, 2014 :
    i heard about it, didn't use it and now it promotes a pattern to be drawn... whats the point ?
     

    #4
  5. hasith777
    Gingerbread Oct 3, 2014

    hasith777 , Oct 3, 2014 :
    it's a cool feature..you should put the apps in to a folder and basically lock it using a pattern :)
     

    #5
    PVS Kharoud and tastesawesome like this.
  6. mjialinl
    Cupcake Oct 17, 2014

    mjialinl , Oct 17, 2014 :
    Okay. I need some serious help here. I did all that. And my apps still won't come back. Even worse, the settings menu is gone (I was playing around with the protected app feature and locked my settings)... So I can't go to settings at all... I reported the bug already through my phone. Any quick solutions?
     

    #6
  7. oneplusonedollarbillyall
    KitKat Oct 17, 2014

    oneplusonedollarbillyall , Oct 17, 2014 :
    from the home screen {if you are using the oneplus buttons, (not the google stock software ones) tap the menu button}.
    you will see wallpapers, widgets, themes.
    SWIPE UP FROM THE BOTTOM OF THE SCREEN.
    look all the way at the bottom. see "Protected Apps"
    tap protected apps.
    do your swipe pattern unlock.
    uncheck all apps that are checked.
    once you do that just go back out. you might have to reboot your phone. either way all those apps will be available again. the bad thing is the shortcuts on the screens will not come back. you will have to drag the shortcuts from the main app drawer again.

    this should solve your problem. I DID THE SAME EXACT THING TODAY. thats how i know
     

    #7
    prateek.batla and mjialinl like this.
  8. oneplusonedollarbillyall
    KitKat Oct 17, 2014

    oneplusonedollarbillyall , Oct 17, 2014 :
    I agree. i think the protected apps thing is useless. i did it thinking that it was an extra measure in case i didn't want someone who got a hold of my phone. while swiping patterns aren't going to keep someone out forever, it might detract someone from entering but because of the apps being blackedout, i saw no point.
     

    #8
    carbine30 likes this.
  9. oneplusonedollarbillyall
    KitKat Oct 17, 2014

    oneplusonedollarbillyall , Oct 17, 2014 :
    sorry brother, i didn't realize you had already put these instructions on here
     

    #9
    hasith777 likes this.
  10. carbine30
    Marshmallow Oct 17, 2014

    carbine30 , Oct 17, 2014 :
    it makes sense :)
     

    #10
  11. mjialinl
    Cupcake Oct 17, 2014

    mjialinl , Oct 17, 2014 :
    Thanks!!!! Life saver!
     

    #11
  12. Johnny_Bravo
    Cupcake Dec 22, 2014

    Johnny_Bravo , Dec 22, 2014 :
    lol. Your post helped me too. The restart part was missing in the OP. When I did what OP suggested only some of the apps appeared
     

    #12
  13. MShoukry
    Cupcake Dec 30, 2014

    MShoukry , Dec 30, 2014 :
    1. Settings > "Apps" (under "DEVICE")
    2. Press Menu button (3 dots on top right)
    3. Click "Protected apps"
    4. Draw Pattern, then Un-Check the apps that had their icons disappear

    IF THIS WASN'T ENOUGH...

    5. REPEAT STEPS 1&2 [Back to the same place (Settings > "Apps") and Press Menu button again]
    6. this time Click "Reset app preferences"
    7. Click "Reset apps"

    YOU'RE GOOD TO GO ;)
     

    #13
  14. mkartono
    Cupcake Jan 12, 2015

    mkartono , Jan 12, 2015 :
    I have a question related to this.
    I've noticed with another cyanogen phone that when protected app is done for an app (in this case whatsapp) the pop up notification tells you its a protected app notification.
    However with my oneplus it comes up normally like a whatsapp notification and when I click on it, it doesnt ask for the pattern.
    Is there a setting I'm missing or is this a bug?
     

    #14
    ramsan10 likes this.
  15. AlbertTY
    Honeycomb Jan 12, 2015

    AlbertTY , Jan 12, 2015 :
    I've tried to tick & untick to get my app to re-appear, but it still disappears for some reason, ... I've already tried pressing both of the reset options on the top right once I've accessed it through my lock pin. The app can't be found anywhere on the app drawer, however, it can still be found under Options > Device > Apps. Am I the only one who has this bug?
     

    #15
  16. mkartono
    Cupcake Jan 12, 2015

    mkartono , Jan 12, 2015 :
    so your saying when you go to >Settings> Apps> Protected apps (from the drop down on right top)>enter pattern and uncheck the boxes that your apps still dont appear?
     

    #16
    AlbertTY likes this.
  17. marnix11
    Froyo Jan 12, 2015


    #17
  18. vincerevic
    Honeycomb Jan 12, 2015

    vincerevic , Jan 12, 2015 :
    OR
    Drag and drop from "view all apps" to the protected app widget. KISS, done!
     

    #18
    HOQ321 likes this.
  19. vincerevic
    Honeycomb Jan 12, 2015


    #19
  20. maydhere1
    Cupcake Jan 19, 2015

    maydhere1 , Jan 19, 2015 :
     

    #20