Solution: Recover From Hard Bricked OnePlus One

  1. sukanta.hazra
    Ice Cream Sandwich Sep 3, 2014

    sukanta.hazra , Sep 3, 2014 :
    Hello Friends,

    If you somehow hard bricked your oneplus one, that means you can not start phone even into fastboot mode. Most probably you messed up or erased some important partitions accidentally, this guide might help you to recover. Final Credit goes to XDA member netbuzz

    @netbuzz Buddy I am soo so happy for you all
    Many congratulations to you to discover this process....
    My Device is not bricked, but I was looking for this kind of solution.

    Actually this solution came up in 5 steps, I guess
    Step 1 : The Main Problem 1st Post in This thread and partition details post using "gdisk -l /dev/sdc" & jtag solution by @DSwissK and @timmaaa

    Step 2 : @os_man said that he can fix it, if he got the 3 files :

    Step 3 : My Post ( @Mnt-XDA ) of the Color Os Official Zip, Partition files & XML and the EXE : Msm8974DownloadTool.exe ( The main Tool, that helped us all)
    But was not sure about the Chinese language, and the DRIVER.ISO point

    Step 4:
    Solution by @rezor92 (trial & error mainly) with no actual logical steps and driver installation guide

    Step 5:

    The Final Solution by By You @netbuzz with proper steps
    @netbuzz You finally made it.... Great Job.


    I am posting this solution ( copy paste ) from XDA Thread
    [Q] Wrong kernel : black screen, no fastboot, no adb, no factory reset



    Originally Posted by netbuzz [​IMG]
    OK, as promised I wanted to write up more detailed steps on how I unbricked my OPO. First, thanks to all who contributed, found the needed files and solution.

    The solution is in fact to download Color.zip from https://mega.co.nz/#!BkpwyYSB!rkYSkF...p1-MX1cLLtaiRo.
    After downloading, unzip the archive.

    Next, Windows drivers. If you're like me you've already tried different drivers, including Qualcomm USB drivers for 9006 and 9008. My best advice is to uninstall the drivers you tried. Go to Device Manager, right click on the bricked USB device (QHSUSB_BULK or Qualcomm HS-USB QDLoader 9008) and go to Properties, click on Driver, then select Uninstall. Check the box to remove driver files, if prompted. Then, go to the extracted Color.zip folder and find Driver.iso. Extract Driver.iso. Inside the extracted folder find Setup.exe. Run Setup.exe to install the drivers. The installer is Chinese, but all you need to do is click through.

    Second note about drivers if that I had the worst time trying to get things to work on my Windows 7 computers. Both Windows 7 and 8 block unsigned driver installations. I've tried overwriting these settings and spent half a day messing with it, and I never go the next steps to work properly. I ended up trying installing the drivers from Setup.exe and the following steps on my Windows 2003 server and things worked properly first time. I am not saying that you won't get this to work on Window 7 or 8, but if you're having troubles try Windows XP, that might make a difference.

    Anyway, once you have the drivers straightened out, connect your phone to the computer, start it up by holding VolUp + Power to about 10 seconds, and let the computer do its thing. Don't install drivers if they are not installed by itself. Instead launch Msm8974DownloadTool.exe. It will scan all the COM ports and find the phone. That's the one line that looks different in the list. The list is just a list of your com devices. If you unplug the phone and move it to another port, or computer, it will show your bricked phone on a different line. There is no reason to click in or select at lines, the program knows where the phone is.

    Clicking on "Enum" just rescans the busses. Clicking the big square button in upper right corner scans the phone and reports what's good and what's not. It takes a minute for the scan to finish.

    If you don't see your devices, try unplugging/plugging in your phone a couple times, and rebooting it with VolUP + Power (hold 10 seconds). You will see it in Device Manager as well.

    Anyway, once you see the phone in the list, click Start. You should see the programs starts writing different files to the phone. Each time it writes a file you'll see a progress bar. Once this is going you know you will be good to go... After all files are written, the line with your device will turn green. You're good, unplug and reboot your phone to ColorOS.

    If there is a problems flashing the device, the line will turn Red. That's what I was getting on my Windows 7 after like 3 seconds after clicking Start. After moving to Windows 2003, everything worked like a charm.

    Once you're on ColorOS and want to go to Cyanogenmod 11S, you have a few options. The easiest way if to use a toolkit from http://forum.xda-developers.com/onep...9-gui-t2807418, or you can download an image manually from: http://forum.xda-developers.com/onep...stock-t2826541 and run the following commands in fastboot mode:
    fastboot flash boot boot.img
    fastboot flash userdata userdata.img
    fastboot flash system system.img
    fastboot flash recovery recovery.img
    fastboot flash cache cache.img
    fastboot flash modem NON-HLOS.bin
    fastboot flash sbl1 sbl1.mbn
    fastboot flash dbi sdi.mbn
    fastboot flash aboot emmc_appsboot.mbn
    fastboot flash rpm rpm.mbn
    fastboot flash tz tz.mbn
    fastboot flash LOGO logo.bin

    Make sure you have the proper image. I accidentally installed the 16GB version on my 64GB OPO first time and obviously didn't get 64GB of space.

    That's about it. I think if people are still having problems then it's likely due to drivers, or Windows 7/8 issue. If you're still getting stuck, let me know, I'll see if I can help.

    Enjoy Guys...
    Last edited: Sep 3, 2014

  2. Reflect Stratos
    KitKat Sep 3, 2014

  3. XmXmaks
    KitKat Sep 3, 2014

    XmXmaks , Sep 3, 2014 :
    Brilliant, thank you good sir.

    B-Rad, Ceasedd and Oneyedmonkey like this.
  4. risky1301
    Lollipop Sep 3, 2014

    shadilol and bestlands like this.
  5. JoniS
    Gingerbread Sep 3, 2014

    JoniS , Sep 3, 2014 :
    Its always good to know there is solution in case something goes wrong.

  6. Turtletms
    Gingerbread Sep 3, 2014

    Turtletms , Sep 3, 2014 :
    May need this someday, posting so I can find it again when I finally get an android.

    brese likes this.
  7. Deactivated User
    Sep 3, 2014

    Ceasedd and MrBoostinduced like this.
  8. aspherical
    Jelly Bean Sep 3, 2014

    aspherical , Sep 3, 2014 :
    So, it's not really a hard brick if there's a way to recover it, is it?

    You'd have to do more than just root to get to where you'd need these instructions.

  9. sukanta.hazra
    Ice Cream Sandwich Sep 3, 2014

  10. askpcguy
    Jelly Bean Sep 3, 2014

    askpcguy , Sep 3, 2014 :
    Rooting only allows the user access to super user permissions. It has nothing to do with touching the device's partitions. Sure you could use an app or even shell commands to mess with partitions but the wise person would do LOTS of reading before trying that. :)

    jparedesj, nukejello and whytefyre like this.
  11. JuJuDawg
    Froyo Sep 3, 2014

    JuJuDawg , Sep 3, 2014 :
    This would mean there's always an out and that the OPO will forever be only soft-bricked and never hard-bricked, ever, right? ;)

    Very useful info to keep in the back pocket. Good job.

    Aaahh likes this.
  12. rezor92
    Froyo Sep 4, 2014

    nmcunix, lostLambda and Karma1plus1 like this.
  13. sukanta.hazra
    Ice Cream Sandwich Sep 5, 2014

  14. relaksua
    Eclair Sep 5, 2014

    relaksua , Sep 5, 2014 :
    I have a similar issue....my phone keeps rebooting into cm recovery..i tried factory reset and reboot but it still keep rebooting into cm recovery...how can i solve this?

  15. wgen
    Gingerbread Sep 12, 2014

    wgen , Sep 12, 2014 :
    Thanks so much, this happened to me today D: For other users: I received a message saying that my USB Device was Unknown but all you have to do is keep power cycling and power+volume up to make the device register with the qualcomm drivers.

  16. TigerXC
    Lollipop Sep 12, 2014

  17. beyondthebat
    Donut Sep 17, 2014

  18. tofucattlehunter
    Froyo Sep 28, 2014

    tofucattlehunter , Sep 28, 2014 :
    Well, great Instructions!
    After messing with the Qualcomm drivers for almost three hours now, I have my One in the list. After clicking start it turns red after seconds, like described above. I've tried it with my Virtual XP Machine but it doesn't work as well. Are there any other solutions?

    Btw: I didn't modify my One (Custom ROM, Root etc..) I just tapped it to wake it up. Since then, it wont respond to anything. Only the computer recognizes it as "QHSUSB_BULK"..

    SrMike likes this.
  19. FilanaPaprika
    Cupcake Sep 29, 2014

    FilanaPaprika , Sep 29, 2014 :
    I tried unlocking the bootloader and I actually got to unlock the USB debugging. When I wanted to reboot the device, it just shut down completely and it simply doesn't work anymore. No fastboot, no power on, nothing...I tried following these steps but the Msm8974DownloadTool.exe simply does not find it. However, running the ''big square'' it does return some information; everything is ok, apart from the following files:

    userdata.img: FAILED
    userdata_64G.img: FAILED
    boot.img: FAILED
    persist.img: FAILED
    recovery.img: FAILED

    Is there anything that can be done? I'm going crazy over this and can't seem to make it work like you described. Any help would be greatly appreciated.

    Sorry for posting this in your inbox and here, but I would really like some help from other users as well :).

    Have a nice day!

    CybeastEXE likes this.
  20. Elrey311
    Ice Cream Sandwich Sep 29, 2014

    Elrey311 , Sep 29, 2014 :
    Are you sure you are in fastboot mode? You have to disconnect the device from the computer to get it in fastboot mode. Do you have adb working properly?

    latuch likes this.