Solution: Recover From Hard Bricked OnePlus One

  1. victorazn
    Cupcake Jan 13, 2015

  2. madroix
    Eclair Jan 14, 2015

    madroix , Jan 14, 2015 :
    Seriously I can't thank you enough for this! I was totally screwed and then this came along. I was able to get the drivers to work on Win 7 and once I had Color OS i was able to get back to CM11s quickly. A thousand times thank you!

  3. salman.arif
    Froyo Jan 14, 2015

    salman.arif , Jan 14, 2015 :
    Thumbs up :)
    Worked for 100%. I got my phone hard bricked when I tried to install CM11S (the one for international version) on my Chinese version of OPO. Maybe there was a conflict between the two versions, or something like that. I got a bit worried at start but when I searched over XDA and OPO Forums, I came to know that this looks out to be a curable issue. This ColorOS solution brought my OPO back to life.
    Based on my experience, following are some of the tips I would like to share:
    1. Despite of trying several times this solution did not work for me on windows 7/8. The reason was obviously the unsigned drivers, which win 7/8 were blocking as they are unsigned. So I did it on Windows XP, and it worked in the first round.
    2. Since Windows XP is hard to find now a days on any system, so instead of installing it on my laptop, I created a virtual machine of based on Windows XP OS. As it was a virtual machine, so the flashing took a bit long, but it was completed successfully.
    3. When the flashing was complete, the line turned Green, (this is the key, it is the indication that Yes, everything went fine). If it is not turning Green, then most probably there is an issue and device is not flashed properly (as it was happening with me when I installed some Qualcomm 9008 drivers on Windows 7).
    4. If after flashing, you are unable to load ColorOS (as it was the case with me) then don't panic. TBH, even after flashing ColorOS (most probably) you'll be going for CM11 or CM12 nightly. So just put your phone on Fast Boot and follow the steps as mentioned above.
    5. If you are flashing CM11 on your phone and following the steps as mentioned above, then you'll be required to have Android SDK. Otherwise, your device would not be recognized as a Fastboot device in CMD (for windows).

    Don't worry if you got your device bricked, there is always a chance of pulling your OPO back to life (unless there is a hardware failure).

    Thanks for the solution again :)

    rabby.fazlay likes this.
  4. manishvaja1
    Cupcake Jan 14, 2015

    manishvaja1 , Jan 14, 2015 :
    Give this man a medal !!
    After spending a whole day (literately) I finally got my device working!

  5. PcCrazyMods
    Eclair Jan 16, 2015

    PcCrazyMods , Jan 16, 2015 :
    After i succesfully install Color OS and start the phone up it vibrates and the red One + logo comes up. After that it goes black. I do get some more disks coming up and computer recognizes the phone as QHSUB_BULK.

    I can enter chinese fastboot and Color OS recovery. What can i do?

    1.png 2.png

  6. Timshaw
    Eclair Jan 17, 2015

    Timshaw , Jan 17, 2015 :
    I'm on the verge of giving up. I have limited knowledge. I've followed the instructions as close as I could. I've put the certificates into the folders described. Saved it in the default location where its pointing. updated the USB COMPOSITE DEVICE. The QUALCOMM wont let me update the driver as it says the DRIVER IS NOT DIGITALLY SIGNED. I'm pointing towards to FRE folder but theres no guidance as to whether that is actually the correct folder within COLOR.zip.

    I'm days away from giving this shell of a OPO to my toddler as a toy. Any help that I've missed over the pages and pages of corrections would be much appreciated.

  7. nathonline
    Ice Cream Sandwich Jan 18, 2015

    nathonline , Jan 18, 2015 :
    Mate I'm slightly in love with you? Its 1.02 am here and it looks like that was my only problem? Its running through it now.

  8. bclawx
    Eclair Jan 18, 2015

    bclawx , Jan 18, 2015 :
    The same thing happened to me with the unable to boot into ColorOS!

    Just held down vol up + power and went into fastboot and fastboot installed CM11s/CM12!

    salman.arif likes this.
  9. nishanth_k
    Honeycomb Jan 18, 2015

    nishanth_k , Jan 18, 2015 :

  10. Edbit33
    Jelly Bean Jan 18, 2015

  11. sharma.kiran356
    Cupcake Jan 20, 2015

  12. soriful
    Gingerbread Jan 21, 2015

  13. AAB4K
    Jelly Bean Jan 21, 2015

  14. carloswii5
    Cupcake Jan 23, 2015

    carloswii5 , Jan 23, 2015 :
    Hey buddy you still need help?

  15. Timshaw
    Eclair Jan 23, 2015

    Timshaw , Jan 23, 2015 :
    Yes Unfortunately. I've even emailed OnePlus and they have sent me a package similar to this. My issue is that my laptop (nor my daughters) reckonises my phone. It only comes up as Unknown USB and when try and update the driver from that location it just tells me that I should use a file compatible with x64. If the phone came up on the other part of the device manager list as that "Bulk" or something, I may be able to update that, but alas I do not have such a connection indication :-(

  16. carloswii5
    Cupcake Jan 23, 2015

    carloswii5 , Jan 23, 2015 :
    You held the power button and Vol +?

  17. Titokhan
    Honeycomb Jan 23, 2015

  18. redwingzfan21
    Cupcake Jan 23, 2015

    redwingzfan21 , Jan 23, 2015 :
    So i have the exact same problem. OnePlus support sent me some batch files to run and now my phone is either stuck on the OnePlus logo or it boots to TWRP. Cannot install via fastboot because it says the device is locked, yet I have TWRP on there still, so something is definitely messed up. Can anyone help?

  19. Timshaw
    Eclair Jan 23, 2015

    Timshaw , Jan 23, 2015 :
    Yes completely dead

  20. carloswii5
    Cupcake Jan 23, 2015

    carloswii5 , Jan 23, 2015 :
    Simple go to TWRP and enable MTP and then download any kitkat rom and then flash... Have you tried unlocking before flashing via fastboot?