Solution: Recover From Hard Bricked OnePlus One

  1. carloswii5
    Cupcake Jan 23, 2015

    carloswii5 , Jan 23, 2015 :
    So it doesnt vibrate after holding both buttons for about 10 seconds?

  2. redwingzfan21
    Cupcake Jan 24, 2015

    redwingzfan21 , Jan 24, 2015 :
    I did have it unlocked a while back. But sadly I don't have MTP on twrp :(. I am on

  3. Timshaw
    Eclair Jan 24, 2015

    Timshaw , Jan 24, 2015 :
    God no, I wish. I'd tried putting the stock cm11s and because not all the files were in the zip as described I wasnt able to complete the process. Resulting in losing my OS.Then tried a method by transferring files via the cmd screen, but again, as I made my way down the list of commands, some of them wouldnt work. It turned off and hasnt turned on since. When I say dead I mean dead, nothing. I charge it if Im going to attempt this thread's method or others but can never tell if theres anything there. Just an unknown USB bus controller connection when I plug it in

  4. carloswii5
    Cupcake Jan 24, 2015

    carloswii5 , Jan 24, 2015 :
    What about usb otg?

  5. carloswii5
    Cupcake Jan 24, 2015

    carloswii5 , Jan 24, 2015 :
    Even though it should appear as qhusb_bulk because that was the same thing that happened to me...

  6. michaeldepotter
    Gingerbread Jan 24, 2015

    michaeldepotter , Jan 24, 2015 :
    This tool saves my opo! I had to install de qualcomm drivers manually and that took me 2 hours to figure out. Maybe it should be added to the OP. Thanx!

  7. logitechor
    Eclair Jan 24, 2015

    logitechor , Jan 24, 2015 :
    I totally messed up flashing a bin file. The only thing I was able to get from the phone was the vibration of the power button. I used the steps here. After a couple of tries I was able to Comoros to cm12 nightly. Thank you.

  8. Chandan.Napster
    Ice Cream Sandwich Jan 24, 2015

  9. beennn1
    Eclair Jan 25, 2015

    beennn1 , Jan 25, 2015 :
    I cant seem to get teh downloadtool to work. It keeps giving me a loading setting xml file failed error

  10. aghazary
    Cupcake Jan 28, 2015

    aghazary , Jan 28, 2015 :
    Hi, I have a huge problem... :(:(:(
    My Oneplus One won't turn on after I wanted to root... And now I just can launch recovery and fastboot mode:(
    I can't connect my oneplus to my computer
    What can I do to fix this problem ?
    Please help me :(
    Last edited: Jan 28, 2015

  11. fehimkoylu
    Cupcake Jan 29, 2015

    fehimkoylu , Jan 29, 2015 :
    When you connect your phone to computer, you can see the phone as "QHS__BULK" or "Qualcomm HS-USB QDLoader" 9008 or 9006 in your computer's device manager. Read the first thread and apply carefully. I did this method yesterday and it is solved.

    If you have recovery or fastboot mode you can flash correct images of CM rom as described in the first thread.

  12. Mr Sprinkles
    KitKat Jan 29, 2015

    Mr Sprinkles , Jan 29, 2015 :
    So, i have a bit of an odd problem. I can't locate my bricked device. There is no QHUSB_BULK or anything of the sort. Can you help me out.

  13. Mystryman
    Cupcake Jan 30, 2015

    Mystryman , Jan 30, 2015 :
    I have read through this entire thread, but I think I am the only one with my specific problem. My problem is that my device will always boot into Cyanogen Recovery or ColorOS Recovery, even after running the tools. I have no Fastboot, no ADB, nothing, so using these are out of the question. These are the steps I have taken.

    I have setup everything correctly. I have a Windows XP VM running, and I can get both of these tools to run correctly:

    I run as administrator, get the device detected under HS-USB Diagnostics 9006, , install the Qualcomm 2012 driver and it gets recognized as QDLoader 9008. Once its in this mode, both tools will pick up the device and I can run them. They both return successful results as after a couple minutes of it flashing everything, green text appears, which is a good sign.When I unplug my device and reboot it, it still boots right back into Cyanogen Recovery or ColorOS Recovery. It's almost as if nothing has happened or changed, even though I have a strong feeling the flashing was successful.

    Oddly enough, in both recovery's, I cannot access internal storage at all. I initially thought the flash storage had died, but when I plug it into my computer when its in QHSUSB_BULK, windows recognizes ~4 partitions on the device, though only 1 is viewable. In windows Disk Management, I can see all the partitions on the device.

    I've gone through just about everything I can and am at my wits end. Anyone have any idea's as to what is causing this and a solution if available?

    Much thanks for any help.
    Last edited: Jan 30, 2015

  14. nikhil.tavase
    Eclair Jan 31, 2015

  15. Jumpi1234
    Jelly Bean Jan 31, 2015

    Jumpi1234 , Jan 31, 2015 :
    to go back to stock ROM without root use this guide:
    Download the factory image here: https://cyngn.com/products/oneplusone/ (the zip folder).
    Now extract it and put the files in the platform-tools folder in the Android sdk. Now open cmd and go to the platform tools folder. Put your opo in fastboot mode (power button + volume up and connect it to your pc. Now type the following commands in the cmd window:

    fastboot flash modem NON-HLOS.bin
    fastboot reboot-bootloader
    fastboot flash sbl1 sbl1.mbn
    fastboot reboot-bootloader
    fastboot flash dbi sdi.mbn
    fastboot reboot-bootloader
    fastboot flash aboot emmc_appsboot.mbn
    fastboot reboot-bootloader
    fastboot flash rpm rpm.mbn
    fastboot reboot-bootloader
    fastboot flash tz tz.mbn
    fastboot reboot-bootloader
    fastboot flash LOGO logo.bin
    fastboot reboot-bootloader
    fastboot flash oppostanvbk static_nvbk.bin (this partition seems to have appeared in the 44S build)
    fastboot reboot-bootloader
    fastboot flash system system.img
    fastboot reboot-bootloader
    fastboot flash userdata userdata_64G.img (or userdata.img if you have the 16GB version)
    fastboot reboot-bootloader
    fastboot flash boot boot.img
    fastboot reboot-bootloader
    fastboot flash recovery recovery.img
    fastboot reboot-bootloader
    fastboot flash cache cache.img
    fastboot reboot

    Your running stock cm11s without root now.

    You can now flash twrp and a custom Rom again.

  16. pok
    Cupcake Feb 2, 2015

  17. Darthpenguin
    Cupcake Feb 2, 2015

    Darthpenguin , Feb 2, 2015 :
    This solution worked for me. I thought my phone was bricked for good. The tools in the zip file are in Chinese but I was able to work around it. :) thanks.

  18. KyleVPirate
    Ice Cream Sandwich Feb 3, 2015

    KyleVPirate , Feb 3, 2015 :
    It'll be great if someone made a Toolkit specifically for the OnePlus One similiar to the Nexus toolkit.
    While yes you can do everything manually if you know what you are doing, sometimes it'll be easier if you had it done for you. Just saying, not everyone knows about code but following instructions work nicely, especially videos.

  19. Kurian Mathew
    Honeycomb Feb 5, 2015

    Kurian Mathew , Feb 5, 2015 :
    sir I have similar problem, I can see ******_bulk o my pc but can't go to fastboot, I ended up here by manually flashing cm11 44s signed fastboot.zip.

  20. androidbrick_com
    Cupcake Feb 5, 2015