7
Solution: wifi dropping issue

?

Did the solution solved the connection dropping issue???

  1. YES

  2. NO

Results are only viewable after voting.
  1. anuragsonu
    Eclair Jan 26, 2017

    anuragsonu , Jan 26, 2017 :
    I m facing new problem...... It switch on automatically.after showing pop up on middle of screen "no internet connection" .. I don't know how... Any solutions... Plz..
     

    #41
  2. G_T._A._CxNO
    Gingerbread Jan 26, 2017


    #42
  3. Sudhanthira86
    Cupcake Jan 26, 2017


    #43
  4. mnorouzi
    Froyo Jan 27, 2017

    mnorouzi , Jan 27, 2017 :
    what did you do exactly??
    did you have connection dropping issue???
     

    #44
  5. F_Saitama_Skillz_tfDh
    Donut Jan 29, 2017

    F_Saitama_Skillz_tfDh , Jan 29, 2017 :
    I can confirm this method works.
    I was experiencing connection drops but after disabling ipv6 on my mikarotic router, problem stops.
     

    #45
  6. tiagogaspar8
    Froyo Jan 29, 2017

    tiagogaspar8 , Jan 29, 2017 :
    I have IPv6 and use it in my work.... so I can't disable it.
    But I have no problems with it... the only problem I have is that I can't choose if I want I to use a private extensions or not.[e]1f601[/e][e]1f601[/e][e]1f601[/e]
     

    #46
  7. F_Adrien_Badts_MfUS
    Cupcake Jan 31, 2017

    F_Adrien_Badts_MfUS , Jan 31, 2017 :
    It worked for me! Cheers!
    But what I don't understand it's that my gf has never had wifi problem with her 1+3. It was just mine...
     

    #47
    mnorouzi likes this.
  8. KingDavid1
    Cupcake Feb 4, 2017

    KingDavid1 , Feb 4, 2017 :
    This issue needs an actual fix on Oneplus' end. I am in the process of an RMA for this issue, but am afraid to send my phone in because of the horrible reviews I've read about the repair process.

    I will attempt this IPv6 fix but it is hardly a permanent solution.
     

    #48
  9. Spike83420
    Gingerbread Feb 4, 2017


    #49
  10. Spike83420
    Gingerbread Feb 4, 2017

    Spike83420 , Feb 4, 2017 :
    Seems like it's always the same ppl with bugs,I believe it's op quality control to blame,you get a good one your golden and you don't well.... Sucks I guess. NVR not one bug have I had yet to date
     

    #50
  11. mnorouzi
    Froyo Feb 10, 2017

    mnorouzi , Feb 10, 2017 :
    hi guys, the new update puts a toggle in wifi advance settings menu to turn of the ipv6 support and it will fix the problem.
    but I'm not sure why the remove the problem instead of solving it.
    So you can not use ipv6 on ur phone for those places or routers that you have dropping issue
     

    #51
  12. lechevalierr
    Donut Feb 17, 2017

    lechevalierr , Feb 17, 2017 :
    I'm on the OPO but this problem has plagued me since COS 13. Disabled IPv6 on my router yesterday and the problem got solved instantly. I share the sentiment that IPv6 could have been fixed instead of being disabled but at least Wi-Fi is working again so I'll just be content. :grimacing:
     

    #52
  13. alexdrummer79
    Cupcake May 2, 2017

    alexdrummer79 , May 2, 2017 :
    Solved!
    I was having wifi disconnections in all router I get connected, first two hours testing and I think is solved, I will report back if the problem comes back.

    Disable IPv6 in my Huawei Router
     

    #53
  14. sreenivasgupta.v
    Cupcake Aug 2, 2017

    sreenivasgupta.v , Aug 2, 2017 :
    Hi,

    I understand your solution...

    But think, can we apply this solution to public WiFi networks?

    I will be connecting to office WiFi... Can we tune such router settings in this case. Imagine a scenario where we will be moving a building to building and then whenever mobile disconnects and connects back, you will face an issue...

    In my case, whenever i move from a building to another, whenever WiFi is reconnected, the phone calls are disconnected to me...

    This is quite a serous issue...

    - Naga Sreenivas
     

    #54
  15. maddehaan
    Gingerbread Aug 2, 2017

    maddehaan , Aug 2, 2017 :
    Best practice on any system (unless in a HUGH corporate WLAN or directly connected to Internet), is to disable IPV6. It seriously brings NOTHING to your system or network but trouble: broadcasting issues, performance issues, packets loss, unreadable ips .. Just don't use it. No critical mass for it yet.
     

    #55
  16. mnorouzi
    Froyo Aug 18, 2017

    mnorouzi , Aug 18, 2017 :
    guys, the problem was solved 3 month ago.
    They addressed the problem.

    they put a temporary option to disable ipv6 on your phone and for the next update they solved it completely.

    you shouldn't have any problem if you updated your oxygen os
     

    #56
  17. mnorouzi
    Froyo Aug 18, 2017

    mnorouzi , Aug 18, 2017 :
    I answered above.

    The problem is solved completely
     

    #57
  18. sanjeev398
    Cupcake Oct 15, 2017

    sanjeev398 , Oct 15, 2017 :
    I had the same issue on my Oneplus One for so long and today i just tried to dig it and fixed the issue successfully. Please follow the instruction below and i hope most of you will be able to fix it.

    1. Go to settings on your Oneplus phone.
    2. Wifi
    3. Click on the advanced (In my phone it is on top right with the 3 doted horizontal lines)
    4. click on the "Wifi frequency band"
    5. set the frequency to 2.4 GHz only.

    Good luck... :)
     

    #58