0
Network/Connectivity [SOLVED] Data issues with Austrian carrier, unable to add APN

  1. John Titor
    Donut Jul 5, 2019

    John Titor , Jul 5, 2019 :
    Hi!
    I have just received my OnePlus 7 Pro and i am havin issues connecting to my carrier mobile data network. SMS/Voice works fine, however data seems to not be working. I have consulted the carrier just a minute ago, however i don't expect a quick answer from their side.
    What also strikes me as confusing is that i seem to be unable to add custom APN settings to my phone. Every time i try it displays "Access Point Name settings are not available for this user" and when i try adding an APN entry according to the carriers specifications, it won't save it, even when clicking the save option.
    Unfortunately i am at loss here and i need this working quickly.
    The carrier is called "Magenta T" which is a merged carrier when T-Mobile Austria and UPC Austria merged a few months ago. It is now mainly under T-Mobile administration and T-Mobile is said to be compatible in the compatibility check.
    APN settings are, according to the magenta website:
    Name: "T-Mobile A Internet"
    APN: "gprsinternet"
    Proxy: ""
    Port: ""
    Username: "t-mobile"
    Password: "tm"
    MCC: "232"
    MNC: "03"
    Authentification Type: "PAP"
    APN-Type: "default, supl"


    I received this information from their website at https://www.magenta.at/hardwaresupp...nstellungen/choice/t-mobile-apn-einstellungen (German)
    Since they do not have a walk through dedicated to the OP7+, i chose to get the info from the huawei p20 walk trough

    However, as i said, i am unable to save these infos

    Thanks in advance for any help!
     

    #1
  2. John Titor
    Donut Jul 5, 2019

    John Titor , Jul 5, 2019 :
    Okay so i have solved this issue on my own. In hindsight it was pretty simple, borderline stupid, but'll leave this up anyways so folks from austria have a place to find a solution to this, although it probably affects a pretty small minority


    the issue was that i was trying to use T-Mobile APN's for a UPC sim card. The correct apn is: internet.at.upcmobile.com. After setting APN to this, it worked like a charm..
    Lowkey embarrassed it took me that long to figure it out but yee
     

    #2
    ziggyson8911 likes this.