0
Camera SOLVED - Lag in activating camera when double-pressing power button

  1. Palal
    Donut Jul 24, 2019

    Palal , Jul 24, 2019 :
    Hi guys,

    This has been bugging me for some time, but I'm only writing about it now:

    When I got my OP5, double-pressing the power button activated the camera immediately! It was great in catching those action shots.

    During some OS update, this noticeable lag developed - a few milliseconds. But this delay means that those great spontaneous shots are no longer possible. The same thing happens on OP6T.

    Is this something that can somehow be fixed?
     

    #1
  2. Arjun Choudhry
    Honeycomb Jul 24, 2019

    Arjun Choudhry , Jul 24, 2019 :
    If you are from India, I think it is because the phone waits a couple of milliseconds to check whether there is a third press on the power button, as that is used to contact emergency services. It has been made compulsory by the government that all phones sold in India are to support this feature.
     

    #2
  3. Palal
    Donut Jul 25, 2019

    Palal , Jul 25, 2019 :
    I am not in India, but that would explain it. Now the question is - is there any way to get rid of it?
     
    Last edited: Jul 25, 2019

    #3
  4. Palal
    Donut Jul 31, 2019

    Palal , Jul 31, 2019 :
    So you were on the right track - it's related to emergency activation. There are 2 options - 3x press and 5x press. On all OP5 5x press is activated by default unless you're in India (then it's 3x). There's an option to disactivate completely. This brought back the extremely fast camera activation.
     

    #4