0
Other [Solved] Stuck in fastboot, no recovery

  1. tavkomann
    Cupcake Apr 3, 2019

    tavkomann , Apr 3, 2019 :
    Hello everybody,

    I guess I have ran into very serious problems today. I still do not get how to properly install TWRP and root modern devices. It was so easy with my old Samsung Galaxy S3. So, when I got my OnePlus 6 I struggled a lot with rooting it, but finally I managed it somehow (using Magisk). After the December update (OTA), root and TWRP were removed, of course. Therefore, I decided to install it again today. I have done this:

    1. fastboot boot twrp.img
    2. flash twrp.zip
    3. boot into TWRP
    4. flash magisk.zip
    5. reboot into system
    However, I was stuck in a boot loop and I could not fix it. So I decided to dirty-flash the December OTA. After that I wasn't able to boot into TWRP anymore. Whatever I tried, only the LED turned blue and nothing happened. I tried to erase system and boot partitions, but this did not resolve the issue. I also flashed the stock boot image to both slots.

    Now, nothing seems to work anymore. The recovery is gone. The phone only boots into fastboot. The bootloader is still unlocked though. I cannot boot into the same TWRP image that has worked before anymore. It says "failed to load/authenticate boot image". Hence, I am not able to flash the stock rom. Or is the stock rom also available as an image? I have only found it as a flashable zip.

    Any ideas how I can proceed now? I'm pretty much stuck and do not know what else I can do. I know, there is an unbrick guide, but it seems to be completely outdated. I am already working more than two hours on it, but the more I do, the worse it seems to get...

    Please help me. I would be very greatful.

    Edit: I was able to solve this issue. Please see my answer below. I would still like to know what I have done wrong and why I ran into this problem. Thanks!

    Edit 2: The problem was probably caused by an old Magisk version (16). Notice to myself: Always check the versions of what you are flashing... However, WiFi and fingerprint sensor do not work, now. Will try a clean flash.

    Edit 3: A clean flash fixed WiFi and fingerprint sensor.
     
    Last edited: Apr 3, 2019

    #1
  2. Kytharsis
    Marshmallow Apr 3, 2019

    Kytharsis , Apr 3, 2019 :
    You might need to use the unbrick tool. This will return your phone to complete stock and will wipe your data. Next time, use blu_spark instead of regular TWRP.
     

    #2
    tavkomann likes this.
  3. tavkomann
    Cupcake Apr 3, 2019

    tavkomann , Apr 3, 2019 :
    Guys, I just found out that one can unzip the rom from XDA and then flash all the individual images using fastboot. That actually worked and all my data is still there :) Will never forget that shock...

    @Kytharsis Thank you, I have never heard of blu_spark. What is the difference to TWRP? I mean, last time I was able to flash regular TWRP – why did it not work this time?

    So, the problem is solved, but can anyone tell me what I have done wrong? I still want to root my phone and do not want to go through all this procedure again. I think, I have thoroughly followed the root instructions on XDA, but why did it not work? Has anyone got a clue?

    Thanks for all your help!
     
    Last edited: Apr 3, 2019

    #3
  4. tavkomann
    Cupcake Apr 3, 2019


    #4
  5. Kytharsis
    Marshmallow Apr 3, 2019

    Kytharsis , Apr 3, 2019 :
    blu_spark is a custom TWRP fork by XDA user eng_stk that seems to work better on OP phones than official TWRP. From what I've seen, official TWRP doesn't work properly with Pie for whatever reason where blu_spark does - something to do with decryption issues.
     

    #5
    tavkomann likes this.
  6. tavkomann
    Cupcake Apr 3, 2019

    tavkomann , Apr 3, 2019 :
    Ah, okay. Thank you. However, I guess Magisk was the problem for me. It was still an old v16 Magisk. Probably have to do a clean flash to get WiFi and fingerprint sensor working again.
     

    #6
    Kytharsis likes this.
  7. Roger.T
    Jelly Bean Apr 3, 2019

    Roger.T , Apr 3, 2019 :
    Use the last stable 18.1 or Beta 19.0 from Magisk..
    Then it works. Magisk 16 is not for Pie....
     

    #7
    tavkomann and Kytharsis like this.
  8. tavkomann
    Cupcake Apr 3, 2019

    tavkomann , Apr 3, 2019 :
    @Roger.T Yeah, I know. Thought, the version on my phone was newer... Next time, I check it before using it.

    A clean flash fixed WiFi and fingerprint sensor as expected. Now, I can restore my titanium backup. Thank you all, the problem is solved!

    BTW, is there any button to close the thread?
     

    #8
  9. DrJMun
    Jelly Bean Apr 4, 2019

    DrJMun , Apr 4, 2019 :
    Nice job of keeping the thread updated as you progressed. That's helpful
     

    #9
    tavkomann likes this.
  10. Pdscoelho
    Cupcake Aug 1, 2019

    Pdscoelho , Aug 1, 2019 :
    I've flashed back to a stock but i'm still having issues with all my sensors like the gyro, magnetic, proximity, accelorometer etc. They're not being picked up at all.


    What should I try? Oh btw this is a oneplus 7 Pro
     

    #10
  11. Kytharsis
    Marshmallow Aug 1, 2019

    Kytharsis , Aug 1, 2019 :
    Wrong subforum.
     

    #11
  12. R1564682223578
    Cupcake Sep 11, 2019

    R1564682223578 , Sep 11, 2019 :
    I'm new to rooting and stuff so i reeaaally need help. Can you tell me how you flashed all the images via fastboot?
     

    #12
  13. Kytharsis
    Marshmallow Sep 11, 2019

    Kytharsis , Sep 11, 2019 :
    Make sure you have the proper drivers installed and then flash them via CMD Prompt.
     

    #13
  14. R1564682223578
    Cupcake Sep 11, 2019

    R1564682223578 , Sep 11, 2019 :
    Ok i'm sorry for being so stupid but what drivers do i need? I don't remember what driver i installed but it was to be able to see the Android Bootloader Interface in device manager

    Edit: ok fixed no need for help anymore
     
    Last edited: Sep 11, 2019

    #14
  15. Kytharsis
    Marshmallow Sep 11, 2019

    Kytharsis , Sep 11, 2019 :
    Awesome.
     

    #15