0
SOLVED - stuck on fastboot after wiping data using twrp oneplus 7

  1. vkaushik87
    Cupcake Jul 31, 2021

    vkaushik87 , Jul 31, 2021 :
    So it’s my first time rooting an android phone and I have run into a problem. i decide to install the pixel experience OS as the Oxysgen os was facing an issue where the screen took more than 5 sec to unlock after pressing the button.
    so i went through the process to unlock and root it, and it was going fine until you have to download and flash TWRP to the phone. I did it and it worked, and so I booted into TWRP and went to wipe the phone and I chose to wipe>> Data, Cache, Dalvik cache.
    After which i rebooted and then it is stuck on the fastboot. Even selecting the recovery option takes me to the fastboot option.
    The next step is to select the pixel zip to install

    I dont know where i went wrong.

    i followed https://www.getdroidtips.com/pixel-experience-oneplus-7/

    im connected to the PC via usb using the platform tools CMD wehre its giving an error "no device/emulator found" when running the command adb reboot bootloader.
    but the fastboot devices returns me with the serial of the phone.
     
    Last edited: Jul 31, 2021

    #1
  2. vkaushik87
    Cupcake Jul 31, 2021

    vkaushik87 , Jul 31, 2021 :
    just to let you know.
    i have installed the TWRP and Magisk successfully before doing all of this.

    dont know why im stuck on this
     

    #2
  3. ghostofcain
    Marshmallow Jul 31, 2021

    ghostofcain , Jul 31, 2021 :
    You should be issuing fastboot commands in bootloader not ADB. The correct command is fastboot reboot bootloader, but as you're already in the fastboot why are you trying to reboot into it?

    BTW the instructions you are following are for a OP7, do you have a OP7, or OP7T?
     

    #3
    Tokolozi likes this.
  4. vkaushik87
    Cupcake Aug 2, 2021

    vkaushik87 , Aug 2, 2021 :
    yes i have a OP7
    i followed the guide and i reached till the wiping data stage and got stuck with the fastboot. Dont know how to install the pixel experience OS ZIP in the internal memory

    Also, i tried running the command you dais and it guides me back to the fastboot. i need to go the TWRP menu
     

    #4
  5. vkaushik87
    Cupcake Aug 2, 2021

    vkaushik87 , Aug 2, 2021 :
    i think i further killed my dead phone.
    i tried installing the factory image and ran the flash all.bat file and now the phone is stuck on "Qualcomm Crashdump Mode" with error details below it "dmverity device corrupted force dump kernel restart"

    is there a way i can recover from this?
     

    #5
    Caomhin likes this.
  6. Tokolozi
    Most Original Avatar Aug 2, 2021

    Tokolozi , Aug 2, 2021 :
    There should be a tool to return to compete stock image.
    @Caomhin has the magic links usually.
     

    #6
    Caomhin likes this.
  7. Caomhin
    OnePlus 9 Series Expert Community Expert Aug 2, 2021

    Caomhin , via OnePlus 9 Pro , Aug 2, 2021 :
    This can unbrick a Oneplus 7 series phone. said:
    Be sure to read ALL the details in the post, and also ensure you choose the correct files for your Phone Model & REGION.
    ⚡You do this at your own RISK ⚡
    Unbrick OnePlus 7/7 Pro/7T/ 7T Pro using MSM Download Tool
    https://www.droidwin.com/unbrick-oneplus-7-pro-7t-pro-using-msm-download-tool/
     

    #7
  8. ghostofcain
    Marshmallow Aug 2, 2021

    ghostofcain , Aug 2, 2021 :
    So why exactly are you posting this to the OP7T forum?

    The command you where trying to run originally would also reboot you to fastboot. The command you want is "fastboot reboot recovery" but it sounds like maybe your recovery is corrupt try reflashing TWRP, or simply booting into it, then flashing the PE zip.
     

    #8
  9. vkaushik87
    Cupcake Aug 9, 2021


    #9