2
[SOLVED] WiFi Issue with OnePlus 2

  1. danyalsumra
    Gingerbread Sep 2, 2015

    danyalsumra , Sep 2, 2015 :
    So I got my OnePlus 2. Super excited to use it. I couldn't go through with the start up wizard. It kept stopping at checking connection. Finally I was able to skip it. Now I can use my network data but I can't use my wifi. I have the correct password cause I tested it with my OnePlus One. So at this point I can't transfer my photos/videos. I can't download apps. I can't do anything. I searched the forums but no solution. What do I do?

    FIX:
    Power Off Phone
    Hold down POWER+VOLUME DOWN buttons
    Clear Cache
    Reboot
     
    Last edited: Sep 2, 2015

    #1
    spoiler0369 and 66nicole66 like this.
  2. Waterdroid
    Community Veteran Sep 2, 2015

    Waterdroid , Sep 2, 2015 :
    Tried a factory reset? And did you order your OP2 from oneplus.net or somewhere unofficial?
     

    #2
    crist125 likes this.
  3. marteebee
    Ice Cream Sandwich Sep 2, 2015


    #3
  4. danyalsumra
    Gingerbread Sep 2, 2015

    danyalsumra , Sep 2, 2015 :


    I ordered it here on oneplus. I fixed it!!! I help down the power and volume down button and I cleared Cache. Now my Wifi is working. Woohoo!!!
     

    #4
  5. Waterdroid
    Community Veteran Sep 2, 2015


    #5
    Ceasedd and Onyx11 like this.
  6. Arbingr8
    Honeycomb Sep 3, 2015

    Arbingr8 , Sep 3, 2015 :
    Found one more bug. While listening music in headphone sound changes if i enable wifi.... Oxygen give us some life...
     

    #6
  7. mattfohs2006
    Cupcake Sep 5, 2015

    mattfohs2006 , Sep 5, 2015 :
    I am having this same issue, just received my One Plus 2 in the mail today. I have tried clearing the cache to no effect though. Just stuck on the checking connection screen in the startup wizard.
     

    #7
  8. mattfohs2006
    Cupcake Sep 5, 2015

    mattfohs2006 , Sep 5, 2015 :
    Update: I was able to complete a factory reset in recovery in addition to clearing the cache and my Wifi is now working.
     

    #8
    Dave_sharp likes this.
  9. Dave_sharp
    Froyo Sep 8, 2015

    Dave_sharp , Sep 8, 2015 :
    Guys this is fixed. PLEASE REMOVE SIM card also and on Wifi if it gets auto selected then use forget command to de-link from the network. After that all is just skip, skip, skip :)
    Enjoy:)
     

    #9
  10. sreeraj
    Eclair Sep 15, 2015

    sreeraj , Sep 15, 2015 :
    Had the same issue during my OP2 setup process. Thanks for the workaround, it works! But seriously, Oneplus team should resolve this issue ASAP, it's a major bug!! Surprising such a major bug was missed completely by the Oneplus team
     

    #10
    dvdmttlr likes this.
  11. lsingbiel
    Cupcake Sep 18, 2015

    lsingbiel , Sep 18, 2015 :
    Did clearing the cache really fix this issue for everyone? I did that (and eventually tried doing a full factory reset) but neither solution actually resolved these WiFi connectivity issues. If it looks fixed, it's only because it decided to briefly work and will always stop working within seconds or minutes. The OP2 always indicates that it's connected to WiFi, but more often than not I can't receive or send data through the WiFi. Apps such as Chrome, Amazon, SpeedTest.net will sometimes receive data briefly, but then eventually stop being able to receive data and time out. SpeedTest might work briefly, then the download stops and eventually displays a message indicating "Network communication issues." If I disconnect WiFi altogether, the LTE connection works fine. My router is a TP-Link Archer C7 V2, with the latest firmware, and all my other devices connect to it just fine. The only consistent thing with the OnePlus Two's WiFi is its inconsistency.

    The funny thing is I can use the WiFi hardware in reverse, where I use the OP2 in tethering / hotspot mode (sharing the T-Mobile LTE connection through the OP2's WiFi hardware). It's been sharing that connection for several hours now, and I haven't had a single issue with my other phone that I connected to the OP2's hotspot. Since that uses the same wifi hardware, perhaps this is an odd 2.0.2 software bug?
     

    #11
  12. urxz
    Ice Cream Sandwich Sep 18, 2015


    #12
  13. Nariko
    Cupcake Sep 18, 2015


    #13
  14. Akshay30
    Cupcake Sep 22, 2015


    #14
  15. mc-wallace
    Donut Sep 22, 2015

    mc-wallace , Sep 22, 2015 :
    I still have wifi problems, I cleared cache and I made a factory reset, but my OPT is out of range of my wifi, although its laying next to my OPO , which has a normal wifi connection. I have to be nearly in the same room with the wifi box to get a connection with the OPT.
     

    #15
  16. art8385
    Cupcake Sep 24, 2015

    art8385 , Sep 24, 2015 :
    Hi there

    i'm having the same problem can't get passed checking connection. I've seen you wipe cache? Ive held down the volume and power button but there is no particular option to wipe cache . is there another option i should click on that does this? Or is there another way to solve this problem? Many thanks
     

    #16
  17. coclapin
    Gingerbread Sep 24, 2015


    #17
  18. art8385
    Cupcake Sep 24, 2015

    art8385 , Sep 24, 2015 :
    Hi There

    I am having the same issue ! Can i ask how you did the factory reset and clear cache?

    Thanks
     

    #18
  19. Luke1991
    Cupcake Sep 24, 2015

    Luke1991 , Sep 24, 2015 :
    Had same issue, finally managed to get past setup but Wi-Fi is still intermittent
     

    #19
  20. ix3coco
    Froyo Oct 7, 2015

    ix3coco , Oct 7, 2015 :
    I noticed the same bug... were you ever able to fix it?
     

    #20