0
[Solved] Wrong next Alarm in Clock Widget

  1. DavideR3da
    Cupcake Mar 27, 2018

    DavideR3da , Mar 27, 2018 :
    Hi, in to the digital clock widget the next alarm is wrong. See the attachments.

    OxigenOs 5.0.4

    [UPDATE]
    - No other clock app
    - Already tried to remove and add clock widget again
    - Already tried to wipe cache from recovery
    - If there are no alarm, alarm indicator remains on status bar until reboot. After reboot same issue after setting an alarm


    Screenshot_20180327-233747.jpg Screenshot_20180327-233741.jpg
     
    Last edited: Mar 28, 2018

    #1
  2. The187Hitman
    Honeycomb Mar 27, 2018


    #2
  3. F_Gav_Douglas_ufnX
    Cupcake Mar 27, 2018

    F_Gav_Douglas_ufnX , Mar 27, 2018 :
    Do you have another clock app installed? You're alarm indicator in the status bar is on, meaning you have an alarm set. But not on the digital clock widget from your screenshot.
     

    #3
  4. Lungu Ionut
    Gingerbread Mar 28, 2018

    Lungu Ionut , Mar 28, 2018 :
    Usually wather/clock widgets get corrupted when it comes to minutes and locations.. Please try to remove it and add it again on the home screen.
     

    #4
  5. DavideR3da
    Cupcake Mar 28, 2018

    DavideR3da , Mar 28, 2018 :
    When the alarm is on, the widget is ok
     

    #5
  6. DavideR3da
    Cupcake Mar 28, 2018

    DavideR3da , Mar 28, 2018 :
    No other clock app. Now I investigate about the alarm indicator on status bar..
     

    #6
  7. DavideR3da
    Cupcake Mar 28, 2018

    DavideR3da , Mar 28, 2018 :
    Already tried to remove and add it again.
     

    #7
  8. Kiekos
    Gingerbread Mar 28, 2018

    Kiekos , Mar 28, 2018 :
    This is 100% caused by another app. There was a thread some time ago here where a user reported the same issue. The alarm clock icon would be visible at the top and in the widget even though no alarm was set. After he uninstalled the faulty app, everything went back to normal. I'm just not sure if I'll be able to find the thread, but if I do, I'll link it here.

    EDIT: I think it was this one: https://forums.oneplus.net/threads/...-on-the-status-bar-and-on-lock-screen.476616/

    But while looking I also found another thread where a user reported an app he did not name that was using "alarm API whatever thing" and it was causing the OS to think there was an alarm, you can read this here: https://forums.oneplus.net/threads/alarm-icon-showing-without-setting-an-alarm.667068/

    So this could be pretty much any app - you should go through installed apps and check what might be causing this.
     
    Last edited: Mar 28, 2018

    #8
  9. DavideR3da
    Cupcake Mar 28, 2018

    DavideR3da , Mar 28, 2018 :
    Thank you! I found the problem, it's related to "Alert mode" option of Tick Tick APP! The next alarm was related to the next reminder in Tick Tick.
     

    #9
  10. Prachigupta167
    Cupcake May 28, 2019

    Prachigupta167 , May 28, 2019 :
    Hi I am facing same problem. But I am not able to figure out which App is creating this alarm. Can you tell how did you find out
     

    #10
  11. Mr_Cyrox
    KitKat May 28, 2019

    Mr_Cyrox , May 28, 2019 :
    Don't bump old threads if you don't have a solution or anything else useful besides "Me too" or with absolutely no details whatsoever....
    This is against the forum rules which you accepted when creating your first post on this forum...
    (For some reason this specific rule is not mentioned in the rules)
     

    #11
  12. R1627963266739
    Cupcake Aug 3, 2021

    R1627963266739 , Aug 3, 2021 :
    This was very useful, thank you. I had an alarm showing in the clock widget but no alarm set in the Clock/Alarm app. As with the OP, the alarm appeared in the status bar and clicking on it brought me to the app which had the alarm set (Just Reminder in my case).
     

    #12