161
Step by step guide to flash TWRP & install LineageOS (no root required)

?

Does this guide work?

  1. Yes

    82.6%
  2. No

    9.4%
  3. No, but I know why and i'm gonna tell you!

    8.0%
  1. pSouza1
    Eclair Feb 23, 2017

    pSouza1 , Feb 23, 2017 :
    This is a very helpful guide :)

    I would like to make a suggestion..
    1 - TWRP
    2 - LineageOS
    3 - Google Apps
    4 - Root :) . They have their own root file in the extras section (on the LineageOS page). This is a step-by-step guide and, to be perfect, this is the only step missing (of course it's optional, but it would be nice :p )
     

    #21
    Habib.khan316 likes this.
  2. Habib.khan316
    Honeycomb Feb 23, 2017

    Habib.khan316 , Feb 23, 2017 :
    One of the main reason I didn't include rooting in this guide is coz I don't think its necessary for the average day-to-day user to root their device. Tbh even myself when I previously rooted my phone, I barely used the options that come with rooting a device. I wanted this thread to be targeted at the more 'noob-ish' users and keep it as simple.

    Do tell me otherwise.

    I have unrooted my device and prefer keeping it simple.

    But i do agree with you that the guide would be more 'complete' with a step-by-step guide on how to root. Maybe in the future I will write a guide on that if there are enough requests for one ;)

    Thanks for your feedback and do answer the poll for other users to have a bit more faith in this guide :D
     
    Last edited: Feb 23, 2017

    #22
  3. dustiebin
    Cupcake Feb 23, 2017

    dustiebin , Feb 23, 2017 :
    Hello,
    thanks for the guide.. hopefully it will be useful for me to upgrade my 1+1

    my only issue is that I do not have any Windows PC/laptops that I can use.

    I have a Mac mini and a Ubuntu laptop -- is there an alternative to getting the info in step one onto my phone via Mac or Ubuntu please?

    many thanks
     

    #23
  4. wilsmits
    Jelly Bean Feb 23, 2017


    #24
  5. Habib.khan316
    Honeycomb Feb 23, 2017

    Habib.khan316 , Feb 23, 2017 :
    Yes there is but...

    I'm not too sure on how to do it on a Mac as I've never tried it on one. As far as I'm aware the steps are kinda similar. Here's a post on XDA that might be of some help:

    https://forum.xda-developers.com/showthread.php?t=1917237

    Please let us know if you have it figured out :D
     
    Last edited: Feb 23, 2017

    #25
  6. Habib.khan316
    Honeycomb Feb 23, 2017


    #26
  7. dustiebin
    Cupcake Feb 23, 2017

    dustiebin , Feb 23, 2017 :
    Thanks.. I will check this when I get home and let you know!
    My 1+1 is not routed so not able to use the play store option...
     

    #27
    Habib.khan316 likes this.
  8. vachanchaudhari
    Froyo Feb 23, 2017


    #28
  9. Habib.khan316
    Honeycomb Feb 23, 2017

    Habib.khan316 , Feb 23, 2017 :
    That's for you to find out and decide.
    You can flash any other OS following the same steps but except at STEP 11a, you should download the OS you prefer.
     

    #29
    arthurlimthomas and Arachniac1 like this.
  10. KforHorizon
    KitKat Feb 23, 2017

    KforHorizon , Feb 23, 2017 :
    I don't mean to offend you in anyway, but, No root is required to flash any ROM. No root is required to flash a custom or a stock recovery for that matter. What you actually require is an Unlocked Bootloader.
    The title is clickbaity and the guide has been out there since ages especially for Bacon.
    What you've actually done i think is, tried to give the not very knowledgeable forum members a sense of belief that flashing a custom ROM is not that difficult (which is a good thing) but still this thread is a duplicate.
     

    #30
    theshinybeast likes this.
  11. Habib.khan316
    Honeycomb Feb 23, 2017

    Habib.khan316 , Feb 23, 2017 :
    And that is exactly what I've done...

    I've seen many posts, and non of them are 'noob-proof'. They're just a bunch of instructions to follow with no reasoning. I believe this thread can help educate too.

    A lot of people think you have to root to flash custom recovery and custom ROMs. As you can see in the 3rd para, I mention that rooting is not required. I've seen posts where they say you need to root to do the following, which scares of a lot of users. In other words I havnt seen a post as noob friendly and also give reason for the steps taken, which in return will reduce the amount of mistakes first timers will do if they understand why they're doing what they're doing.

    One more thing, this guide can be used for ALL OnePlus devices, but I chose to post it in the bacon community because not many OP3/3T users flash their new devices as OnePlus is still constantly updating the OxygenOS for them.

    Therefore, I don't actually see the point of your post. Instead you could be contributing to the thread if you have something helpful to say to the community.

    What I see is 'like-baity' post :p

    On the other hand you could like the thread if you think I've done a good job educating and also answer the poll :D
     
    Last edited: Feb 23, 2017

    #31
  12. KforHorizon
    KitKat Feb 24, 2017

    KforHorizon , Feb 24, 2017 :
    Change the TWRP link for the 3/3T. The official link doesn't have the latest TWRP for both of these devices which will get users into trouble.
     

    #32
    theshinybeast likes this.
  13. Habib.khan316
    Honeycomb Feb 24, 2017

    Habib.khan316 , Feb 24, 2017 :
    Thanks for addressing this.

    I prefer using/providing Official links.

    If you think its necessary, do provide us the links! :D
     

    #33
    arthurlimthomas likes this.
  14. anilsai
    Donut Feb 25, 2017


    #34
  15. Ljay79
    Cupcake Feb 26, 2017

    Ljay79 , Feb 26, 2017 :
    Hello
    I have a problem in my oneplus one 64gb
    Model: A0001
    CyanogenMOd: 11.0-XNPH38R
    Android: 4.4.4
    If a start the phone i went to the system well , can take photos and use normal, but if i try to erase to factory reset, he reboots and show the initial logo but after 10 seconds the phone starts to fade out red and green pixels shows and in the end starts to become blue and all went black, but the light stills on.
    I have to reboot again to go to normal mode.
    if i try volume up and power it show the fastboot mode logo, but if i try volume down and power only show the login logo and start´s again to fade out the screen .
    So i think i don´t have recovery mode. I don´t now what i did but i need help , because it´s my first time with android.
    i try to use oneplus one toolkit and oneplus one oxygen kit but if i do a unlock bootloader it goes to the fade out screen and i can´t do nothing.
    can anyone help
     

    #35
  16. Koteshyadav
    Froyo Feb 26, 2017

    Koteshyadav , Feb 26, 2017 :
    You must have disabled the recovery
     

    #36
    Habib.khan316 and Ljay79 like this.
  17. Ljay79
    Cupcake Feb 26, 2017

    Ljay79 , Feb 26, 2017 :
    I dont now. I cant flash nothing.
    I try unlock and i went to recovery and fade out the screen, i try everything
     

    #37
  18. Habib.khan316
    Honeycomb Feb 26, 2017

    Habib.khan316 , Feb 26, 2017 :
    Try enabling 'Advanced Restart' in 'developer options'. Then RESTART your phone to RECOVERY from the power button menu by holding the power button till the menu opens.

    Let us know if that works
     

    #38
  19. Habib.khan316
    Honeycomb Feb 26, 2017

    Habib.khan316 , Feb 26, 2017 :
    I personally prefer the nano package as I don't use about 90% of google products and if I need any I can just download them latter. This keeps my device away from all the bloatware and maximise efficiency.

    To answer your question... If there is an issue with their product, they should provide you that information on their forums, so do your research there. I can't promise you it will work as I have not personally used that package, but I don't see as of now why it wouldn't.

    Hope that answers your question :)
     

    #39
  20. Claud1u992
    Eclair Feb 26, 2017

    Claud1u992 , Feb 26, 2017 :
    At the part where i have renamed the twrp file into recovery and i have to SHIFT+RIGHT CLICK, i dont have the Open CMD PRompt here option. Do I have an alternative for that or how might I be able to open the cmd?
     

    #40