148

Step by step guide to flash TWRP & install LineageOS (no root required)

?

Does this guide work?

  1. Yes

    82.8%
  2. No

    9.9%
  3. No, but I know why and i'm gonna tell you!

    7.4%
  1. Andy Gingerbread Jul 2, 2018

    Andy, Jul 2, 2018 :
    Yep, a big help thanks. All up and running on 15.1. An early birthday present for my Oneplus One which will be 4 in a few days time :)
     

    Mykson likes this.
  2. yddtime Froyo Jul 3, 2018

    yddtime, Jul 3, 2018 :
    Correct. You only need to use ADB on a PC to unlock the bootloader so that that you can install TWRP (or equivalent). This is why I specifically put "FROM YOUR PHONE" in step 2 of my instructions. Once you have a custom recovery you can use that to install any ROM directly from the phone. I've noticed a lot of questions in most forums about using ADB and the commands so if you can avoid using it then you should (unless you are a developer in which case you probably don't need instructions at all).
     

  3. Dani9394 Cupcake Jul 11, 2018

    Dani9394, Jul 11, 2018 :
    One question. If i wipe up my data to install the os and the installation fails? How do i recover my phone? Thx
     

  4. Dani9394 Cupcake Jul 11, 2018

    Dani9394, Jul 11, 2018 :
    It is possible to wipe everything and to receive the error from installing the rom? If yes, how can it be solved? I wait an answer please. Thank you.
     

  5. Mykson Ice Cream Sandwich Jul 11, 2018

    Mykson, Jul 11, 2018 :
    Backup all your data and files before doing anything!
    If you've already installed TWRP, make sure you downloaded the LOS zip and GApps package to your phone.
    Only wipe:
    • Dalvik
    • Cache
    • System
    • Data
    Don't wipe: internal storage

    After wiping, install the two files from your internal storage and boot into system.
    There shouldn't be any error if you follow these steps.
     

  6. Dani9394 Cupcake Jul 12, 2018


  7. The1Lion Lollipop Jul 13, 2018

    The1Lion, Jul 13, 2018 :
    Just an FYI, I was using 14 and updating once a month. When I tried to jump from early June nightly to the latest July nightly I got error 7, even doing it manually and clearing all data. I then updated to the mid June last LOS 14 nightly and then the FIRST LOS 15 and it worked without any issue ;)
     

  8. sofferg Donut Jul 21, 2018

    sofferg, Jul 21, 2018 :
    I have a Oneplus One running CyogenMod 11.0-XNPH44S, Android 4.4.4

    I never updated the OS because the phone was running perfectly until about 5 months ago when certain app updates caused boot loops. I solved the problem with several factory resets and manually installed older versions of the apps I really needed, but now the old versions are getting obsoleted and will no longer work. So it looks like I have to update the ancient OS now if I want to use these apps.

    Will the OS update procedure recommended here work with my ancient OS? Or should I first update to a more recent official OS? If I do the latter, should I update to Oxygen OS 2.1.4, CM 12, or CM 13?

    Does anyone know if Oxygen OS 2.1.4 avoids the boot loop problems? Is it possible that the newest app updates don't cause these loops? Is there a way to test the newest updates without having to do a factory reset each time the app update trashes the phone? I have adb and fastboot on my mac and am able to access the phone with them.

    Sorry for all these questions.

    I am not that tech-savy and don't want to have to wipe my phone if I don't have to. It works very well except for these apps. I contacted Oneplus technical support who told me that CyogenMod 11.0-XNPH44S is the best OS for Oneplus One because the other official updates can damage the hardware. However, they offered to update the phone via remote session to Oxygen OS 2.1.4, CM 12, or CM 13 if I assumed responsibility for any hardware damage.

    Thanks so much for any advice.
     

  9. andrew28 Eclair Jul 25, 2018

    andrew28, Jul 25, 2018 :
    I have a problem with the installation of Lineage OS 15.1 on Oneplus One. The Google Play services do not work after the installation of both the OS 15.1 and the GApps package via TWRP. I can not log into Google and the prompt "Google Play Services has stopped" keeps popping up every few seconds. I've already tried different versions of Lineage OS and different GApps packages but none of them work.
    Is there any way to fix this?
     

  10. shoenix Gingerbread Jul 26, 2018

    shoenix, Jul 26, 2018 :
    +++++++1.

    Though in my case i am more interested in a CLEAN INSTALATION FROM ZERO.
     

  11. G_Ab_van_de_Kieft_PFis Cupcake Aug 9, 2018

    G_Ab_van_de_Kieft_PFis, Aug 9, 2018 :
    Thanks a lot for this clearly explanation!
    It helped me to succesfully upgrade my OPO.
     

    yddtime likes this.
  12. ASCHENTE_V Ice Cream Sandwich Aug 9, 2018

    ASCHENTE_V, Aug 9, 2018 :
    If I'm on beta 30 for op 3T, should I return to stable and only then unlock bootloader and install twrp or I can do it directly from beta?
     

  13. Rafi Ali Gingerbread Aug 11, 2018


  14. yddtime Froyo Aug 13, 2018


  15. rangav Froyo Aug 17, 2018

    rangav, Aug 17, 2018 :
    I followed up to step 11c and I am stuck. 11d says copy the lineageos zip to the device from computer. My phone is in twrp screen with lot of options but my computer is not showing the phone to transfer the file. Please help.

    11c. Click Wipe>Format Data
    This step will completely format your device and turn it into a CARROT! :p

    11d. Connect the device to your computer and copy the LineageOS ZIP file onto the device.
     

  16. afrith.noor Cupcake Aug 21, 2018

    afrith.noor, Aug 21, 2018 :
    1534842685615.jpg

    LOS15.1

    1534842685753.jpg

    Picture-in-Picture mode

    1534842685975.jpg

    Split Screen


    Mission accomplished!

    Thanks for the guide. OPO upgraded to Oreo 8.1 Lineage OS 15.1
     
    Last edited: Aug 21, 2018

  17. goncalo.dumas Froyo Sep 11, 2018


  18. Slatter191 Lollipop Sep 15, 2018

    Slatter191, Sep 15, 2018 :
    Hi there,

    Am unable to flash twrp on my RN's OPO. Is on stock Cyanogen OS 6.1.

    Unlocked the bootaloader, but get this on flashing twrp.........

    Any input would be appreciated!

    Thanks.





    C:\android-sdk-windows\platform-tools>fastboot devices
    c660d7a4 fastboot

    C:\android-sdk-windows\platform-tools>fastboot oem device-info
    ...
    (bootloader) Device tampered: true
    (bootloader) Device unlocked: true
    (bootloader) Charger screen enabled: false
    (bootloader) Display panel:
    OKAY [ 0.000s]
    finished. total time: 0.000s

    C:\android-sdk-windows\platform-tools>fastboot flash recovery 3.2.1-0.img
    error: cannot open '3.2.1-0.img'


    C:\android-sdk-windows\platform-tools>
     

  19. basavak Cupcake Sep 24, 2018

    basavak, Sep 24, 2018 :
    I was experimenting to upgrade my OPO to OxygenOS, and later tried upgraging to LineageOS. IT worked for me. Steps are crystal clear.. just followed the steps. :)
     

  20. basavak Cupcake Sep 24, 2018

    basavak, Sep 24, 2018 :
    Rename your recovery image from "recovery 3.2.1-0.img" to "recovery.img" It will work. THere is space in your filename, so fastboot is giving error because of that.