147

Step by step guide to flash TWRP & install LineageOS (no root required)

?

Does this guide work?

  1. Yes

    82.8%
  2. No

    9.9%
  3. No, but I know why and i'm gonna tell you!

    7.4%
  1. yddtime Froyo Sep 26, 2018

    yddtime, Sep 26, 2018 :
    Do you have the 3.2.1-0.img file in the C:\android-sdk-windows\platform-tools folder? Is the img file in your download folder instead? It needs to be in the same folder as where you executing the command if you aren't putting in the full path for the filename.
     

  2. bikeflier Cupcake Oct 15, 2018

    bikeflier, Oct 15, 2018 :
    Thank you for the instructions.
    I couldn't get ADB to get phone to enter into fastboot but it worked by using volume up and power key combination to get fast boot.
    It is best to copy lineage.zip file and GApps.zip onto phone and install lineage then GApps one after the other without rebooting. I used GApps mini as any larger GApps file caused an error 70 when installing. You can use Play Store later to install other Google Apps.
    Everything so far is running fine and battery life definitely improved from Oxygen OS and Android 5.
     

  3. smrtphn Ice Cream Sandwich Oct 20, 2018


  4. jazzo Ice Cream Sandwich Oct 30, 2018

    jazzo, Oct 30, 2018 :
    The LineageOS on their website appear to have only nightly, do they provide any stable version?
     

  5. KiranSamarth Cupcake Nov 22, 2018


  6. debbenSakye Cupcake Dec 23, 2018

    debbenSakye, Dec 23, 2018 :
    i did not find this option in my developer option
     
    Last edited: Dec 23, 2018

  7. debbenSakye Cupcake Dec 23, 2018

    debbenSakye, Dec 23, 2018 :
    i did not find this option in my developer option Screenshot_20181224-030524.png Screenshot_20181224-030419.png Screenshot_20181224-030520.png Screenshot_20181224-030432.png Screenshot_20181224-030515.png Screenshot_20181224-030426.png Screenshot_20181224-030501.png Screenshot_20181224-030510.png Screenshot_20181224-030438.png Screenshot_20181224-030449.png
     

  8. takearun Cupcake Mar 2, 2019


  9. ASCHENTE_V Ice Cream Sandwich Mar 2, 2019

    ASCHENTE_V, Mar 2, 2019 :
    takearun

    Hi,

    I have a very old OPO. I tried following the steps and tried to install lineage-16.0-20190302-nightly-bacon-signed.zip
    In TWRP mode, I get this error,

    View attachment 980646

    Can you please help.

    Thanks,
    Arun



    Update your twrp to the latest version by following my instructions. Download the twrp zip file from the official web site to your pc, then move it into internal storage of your phone, press install in twrp, choose the zip file and confirm flash. The latest version for opo is 3.2.3-0.
     
    Last edited: Mar 2, 2019

    amandadam likes this.
  10. amandadam Honeycomb Mar 3, 2019

    amandadam, Mar 3, 2019 :
    Screenshot_20190302-190928_Settings.png
    View attachment 980685
    https://wiki.lineageos.org/devices/bacon/install
    https://wiki.lineageos.org/upgrading.html
    https://opengapps.org/
    I wiped Dalvik,system and cache,coming from Lineage 15.1.
    I got stuck on boot screen after flashing the rom and gapps, so I reflashed the rom and bingo.
     
    Last edited: Mar 3, 2019

  11. wilsmits Jelly Bean Mar 3, 2019


  12. takearun Cupcake Mar 3, 2019

    takearun, Mar 3, 2019 :
    Thank you so much for all your suggestions, I was able to successfully install LineageOS.
    Now hoping the battery life is better, after a nights charge, it would suddenly run out of charge in the morning.

    Anyways, these are the issues I faced,

    1. Step 9d - fastboot reboot - kept taking me back to cyanogenmod recovery and so I had to skip this step.
    That got me to TWRP recovery.

    2. I forgot that I had the older version of TWRP, I was trying that because cyanogen recovery kept showing up.
    And so I downloaded the latest TWRP like suggested by the team above.

    3. On my mac the android phone didn't show up as a USB device and so I had to do a,
    ./adb push ../lineage-16.0-20190302-nightly-bacon-signed.zip /sdcard
    to send the files, followed the same command to send the GApps file.

    4. Like @amandaman, I was stuck on the boot screen as well, wiping Dalvik,system and cache, got me out of that issue.

    In general once I got into the ./adb shell command and I started seeing the files on the phone, things started to make more sense.

    Thanks a lot for all your help, really appreciate it.
    Arun
     
    Last edited: Mar 3, 2019

    wilsmits likes this.
  13. dj.devint Eclair Mar 13, 2019


  14. yddtime Froyo Mar 13, 2019


  15. wilsmits Jelly Bean Mar 13, 2019


  16. yddtime Froyo Mar 13, 2019

    yddtime, Mar 13, 2019 :
    Yes it works, I did it already. Note that the instructions I referenced are for upgrading from LineageOS X to LineageOS Y. If you are coming from COS then you need to start at the first post of this thread.
     

  17. wilsmits Jelly Bean Mar 14, 2019

    wilsmits, Mar 14, 2019 :
    OK thanks
     

  18. fdemichelis1 Gingerbread Jun 24, 2019

    fdemichelis1, Jun 24, 2019 :

    Hi,
    Tks for the excellent tutorial
    I'm wondering if these steps could br used also to perform a clean installation of the new Oxy 9.0.3 based on Android Pie
    The reason is that I update via Ota my OP 3T, but the system has bocome very unstable and slow and I'd like to do a real clean installation of the new s.o. to try to solve all the problems. I could do a factory reset, but many told me that these procedure doesn't reinstall the s.o. and doasn't perform a very clean installation.

    Thanks for your help

    In general, do you know how to
     

  19. Sridhar Ananthanarayanan Lollipop Jun 24, 2019

    Sridhar Ananthanarayanan, Jun 24, 2019 :
    Procedure is the same for all ROMs.
     

  20. fdemichelis1 Gingerbread Jun 25, 2019

    fdemichelis1, Jun 25, 2019 :
    Tks for your answer

    I have just a couple of questions

    1) In order to have a deep clean installation, do you think that if I add in your step 11c: Wipe Dalvik , Wipe System, Wipe Data & Cache could compromise the process (in particular Wipe System)?
    2) Does your method work even if I install a non rooted stock ROM?

    Thanks in advance for your help and patience

    Regards
     
    Last edited: Jun 25, 2019