0
Stock messaging app can't attach photo

  1. sicone54
    Cupcake Dec 10, 2017

    sicone54 , Dec 10, 2017 :
    When I click the + next to enter text bar, the only option that is clickable is the camera one. It won't let me attach a photo from the gallery. The only way to send a photo is to go to the gallery then share it to the messaging app.

    I don't see any update for the app, so I'm not sure how to fix this.
     

    #1
  2. goldenlight
    Gingerbread Dec 10, 2017

    goldenlight , Dec 10, 2017 :
    looks like the only way to do it is by taking a picture or going into gallary and sharing picture.

    You can also download google messaging
     
    Last edited: Dec 12, 2017

    #2
    superdutynick likes this.
  3. Chromer19
    Honeycomb Dec 11, 2017

    Chromer19 , Dec 11, 2017 :
    I went into my messages app and clicked the plus symbol and got mad y different options, including adding photos from the gallery.
     

    #3
  4. pablofg1978
    Head Moderator Head Moderator Dec 11, 2017

    pablofg1978 , Dec 11, 2017 :
    I can, the third option is to add images from the gallery.
     

    #4
  5. sicone54
    Cupcake Dec 11, 2017

    sicone54 , Dec 11, 2017 :
    Ya I know, that's the problem. It's not selectable. It's grayed out.
     

    #5
  6. sicone54
    Cupcake Dec 22, 2017

    sicone54 , Dec 22, 2017 :
    SO I'm guessing there is no information on this? Am I just unable to use this the stock app?
     

    #6
  7. pgrey
    Ice Cream Sandwich Dec 22, 2017

    pgrey , Dec 22, 2017 :
    Check your permissions. I bet the messaging app asked for access to photos and files, and got "dismissed accidentally".
    Make sure it has access to both of these, or reset its permissions and it'll ask you again.
     

    #7
  8. elitekernel
    Gingerbread Dec 22, 2017

    elitekernel , Dec 22, 2017 :
    After checking the permissions, ensure you have all the correct Carrier settings, APN type. - Try a network reset, if all else fails factory reset, and ensure APN settings.
     

    #8
  9. sicone54
    Cupcake Dec 31, 2017

    sicone54 , Dec 31, 2017 :
    Not entirely sure I know what settings you're referring to.

    I'm also confused as to why Carrier/Network settings would have an impact on this. If the attached pic wasn't sending then carrier/network settings would make sense. But the option to even attach a picture through the gallery icon isn't working. Which makes me think it would be an actual phone issue. I guess I could try a factory reset, though that's not ideal.
     

    #9
  10. superdutynick
    Gingerbread Jan 1, 2018

    superdutynick , Jan 1, 2018 :
    Second that... Google messaging is better IMO.
     

    #10
  11. Stealth777
    Gingerbread Jan 1, 2018

    Stealth777 , Jan 1, 2018 :
    I'm using Facebook messenger, kinda like it. it gives you a option in the top right (sms) and it gives all your contacts a picture not just a number. two days now and I'm liking it.
     

    #11
  12. Prezes_raf
    Cupcake Feb 21, 2018

    Prezes_raf , Feb 21, 2018 :
    I had the same problem and for me changing permissions for SMS/MMS applications works.
     

    #12
  13. sicone54
    Cupcake Feb 21, 2018

    sicone54 , Feb 21, 2018 :
    I checked permissions. The stock app has sms permissions and I don't see any options for MMS permission. I gave it permission for the camera thinking maybe that's connected to the gallery but that didn't work.
     

    #13
  14. I1610406794533
    Cupcake Jan 11, 2021

    I1610406794533 , Jan 11, 2021 :
    just found it! when you go into messages, don't put the cursor in the typing box, so it is collapsed. first click on the plus sign and you will see photos you can attach
     

    #14
  15. BeardyBiceps , via OnePlus 5T Midnight Black , Jan 15, 2021 :
    Yes agree
     

    #15