1
Strange issue when applying UV glue for glass screen protector via OnePlus 8 Pro

  1. WhaTheF
    Eclair Jul 6, 2020

    WhaTheF , via OnePlus 8 Pro , Jul 6, 2020 :
    So I have installed a UV glue tempered glass screen protector about 3 times now, 2 from the same manufacturer and one from a different one on my OP8Pro
    1594043269489.jpg

    1594043269586.jpg


    One each, almoat exactly at the same spot on my screen i get a rainbow/bubble & micro-bubble patch when the glue spreads (it shrinks after several minutes but some bubbles remain) .

    Is this an issue with my screen? Missing/rubbed-off oliophobic coating?
    I never used my screen without some kind of screen protector so not sure how this might happen.

    Any one had similar issue?
     

    #1
    666Syco likes this.
  2. cssrc1974
    Jelly Bean Jul 6, 2020


    #2
  3. anesh007
    Ice Cream Sandwich Jul 6, 2020


    #3
  4. Roger.T
    Ice Cream Sandwich Jul 8, 2020


    #4
  5. A1591880373878
    Cupcake Jul 12, 2020


    #5

  6. #6
  7. Vaisakh_Kc
    Cupcake Jul 12, 2020


    #7
  8. WhaTheF
    Eclair Jul 12, 2020

    WhaTheF , via OnePlus 8 Pro , Jul 12, 2020 :
    Didn't notice any effect on the front camera and didn't see any uv glass that comes with a hole.

    In my opinion it's worse with a hole since it attracts dust and dirt that just gathers in the hole.
     

    #8
    Vaisakh_Kc likes this.
  9. 666Syco , via OnePlus 8 Pro Ultramarine Blue , Jul 13, 2020 :
    I have the same issue and I have 2 OnePlus 8 Pro's. bought multiple brands of tempered glass and I've used Whitestone Loca from a pixel 2 XL kits (spare/leftovers) tubes of Loca. What I do is Cure just the top of the tempered with the UV lamp and then I lift the bottom with an angled squeegee made of hard plastic. once I lift it and it rests back down and the bubble dissipates leaving very minimal bubbles, if any. Pain in the ***, but it works.
     

    #9
    WhaTheF likes this.