12
[Submitted] Stuttering/frame skip while scrolling [Oxygen 10 BUG on all 7T]

  1. Tex99
    Froyo Jan 14, 2020

    Tex99 , Jan 14, 2020 :
    HOW TO REPRODUCE:
    -90hz (more visible) or 60hz
    -Light theme (also with dark but it's easier too see on light)
    -Animation 0.5 or 1 (it's the same)
    -Open settings and do little scroll with the finger (don't leave the finger on display)
    -Look at the written texts ("Battery" for example, video 2): they don't do a fluid transition up or down, they don't flow on the screen, but they "appear-disappear", it seems that they jump some pixels. Infact there is multiple frame skip every time that you scroll.

    It happens every time you scroll without leaving the finger on display (see the video) on every apps and it's present from the launch (every oxygen 10 version has this issue)
     
    Last edited: Jan 14, 2020

    #1
  2. Tex99
    Froyo Jan 14, 2020

    Tex99 , Jan 14, 2020 :
    BUG:
    There is always a stuttering/frame skip while scrolling on every Oneplus 7T/7TPRO/7PRO with Android 10, on every app and every time you scroll.
    1) This is the complete video and here the stuttering is so visible, moreover you can see how to reproduce it (watch it on pc at full quality 1080p60 and full screen):

    2) If you watch this slowmotion video you can see how the written "Batteria" (when it appears stutter in red) does a sort of jump because of frame skip (I also added a frame count so you can be sure that the video is original):


    3) I did other test on my 7T with "Profile Rendering HWUI" and as you can see from the screenshots, If you do little scrolls there are serious frames drop (see the spikes):
    -Screenshots at the end of the post-


    HOW TO REPRODUCE:
    -90hz (more visible) or 60hz
    -Light theme (also with dark but it's easier too see on light)
    -Animation 0.5 or 1 (it's the same)
    -Open settings and do little scroll with the finger (don't leave the finger on display)
    -Look at the written texts ("Battery" fro example): they don't do a fluid transition up or down, they don't flow on the screen, but they "appear-disappear", it seems that they jump some pixels. Infact there is multiple frame skip every time that you scroll.

    TEST:
    Tests I did on both 60hz and 90hz and light theme (easier to see than dark mode) on settings app:
    1- Oneplus 7T frosted silver OOS 10.0.6/10.0.7: stuttering is PRESENT
    2- Oneplus 7T frosted silver OOS 10.0.1: stuttering is PRESENT
    3- Oneplus 7T glacier blu OOS 10.0.1: stuttering is PRESENT
    4- Oneplus 7T glacier blu OOS 10.0.1: stuttering is PRESENT
    5- Oneplus 7T PRO OOS 10: stuttering is PRESENT
    6- Oneplus 7 PRO OOS 10.0.2: stuttering is PRESENT
    7/8- Oneplus 7 PRO OOS 9 and Oneplus 6T with OOS 9: stuttering is NOT PRESENT

    OTHER REPORTS AND TESTIMONIALS:
    1)
    https://forums.oneplus.com/threads/...g-on-all-7t-7tpro-7pro.1148402/#post-21228630
    2) https://forum.xda-developers.com/oneplus-7t/help/lag-scroll-7t-series-android-10-t4012171

    RESULTS:
    I'm pretty sure that this bug is due to Oxygen Os on Android 10 (on 7 Pro with Pie is not present) and it is present on all 7T/7TPRO/7PRO.
    Clear system cache, factory reset, block 90hz etc.. are all useless solutions (I tried).
    OnePlus still didn't fix the issue, in these condictions the 90hz are pretty useless.

    "Profile Rendering HWUI" screenshots:
     
    Last edited: Jan 14, 2020

    #2
    Pandatek, Fatumboy, Abb4d0n and 3 others like this.
  3. coltis
    Donut Jan 14, 2020

    coltis , Jan 14, 2020 :
    This is (very) present on my phone too. OP7 Pro, 10.0.3
    Only the app drawer and the emoji section of the keyboard is smooth. Every other thing that requires scrolling is extremely stuttery.
    Occasionally returning to the home screen creates lag too.

    The "buttery smooth" slogan makes no sense.
     

    #3
    G_WindShot_TlyM and Tex99 like this.
  4. 5urv1v0r
    Froyo Jan 14, 2020

    5urv1v0r , Jan 14, 2020 :
    Have the same problem. Scrolling vertically is very choppy. I
    have searched in different forums and there are similar complaints. Some users are relating it to screen static while others are relating it to the pre-installed screen protector. I hope OnePlus get back with feedback.
     

    #4
    coltis, G_WindShot_TlyM and Tex99 like this.
  5. Tex99
    Froyo Jan 15, 2020

    Tex99 , Jan 15, 2020 :
    yeah I read about static screen protector but I don't think it's related, it seems to be related to software I think because some users said that with aosp rom they don't have this issue, only with Oxygen.
    If you want to add links here of other testimonials on other forums you are welcome (also if you want to share this feedback link to them so maybe it became more visible to oneplus).
    thank you for report
     

    #5
    G_WindShot_TlyM likes this.
  6. G_WindShot_TlyM
    Cupcake Jan 15, 2020

    G_WindShot_TlyM , Jan 15, 2020 :
    very noticeable for me too, i also made a thread about it and got an answer that they are "working on it". That was a month ago, this issue was enough for me to switch to omnirom and i really recommend it since this issue doesn't seem very high priority to fix. overall omni is alot smoother witch seems very odd due to all reviewers saying oos is "buttery smooth"
     

    #6
    Tex99 likes this.
  7. coltis
    Donut Jan 15, 2020

    coltis , Jan 15, 2020 :
    Can you guys try to fully uninstall Swiftkey (not just disable it), replace it with Google Keyboard, disable accessibility access for all apps and set Firefox as the standard browser instead of Chrome?

    After searching a lot these seem to be normal causes for scrolling lag. My phone seems moderately smoother after doing this.
    Play Store seems to have lag on all android phones, so don't use that as a measure.

    I've been in contact with support, and their response was "That sounds annoying, cross your fingers that the next update fixes it". Extremely disappointed.
     

    #7
    Tex99 likes this.
  8. G_Igor_Ekaterinburger_Mk
    Cupcake Jan 16, 2020


    #8
    Endruuu and Tex99 like this.
  9. 5urv1v0r
    Froyo Jan 16, 2020

  10. N1575894262100
    Cupcake Jan 20, 2020


    #10
    Tex99 likes this.
  11. Endruuu
    Gingerbread Jan 21, 2020


    #11
    Tex99 likes this.
  12. Tex99
    Froyo Jan 29, 2020

    Tex99 , Jan 29, 2020 :
    I tried to remove default screen protector but as I thought it doesn't change the situation, the stuttering remains sadly
     

    #12
    Pandatek likes this.
  13. KhaosVFX
    Cupcake Feb 14, 2020

    KhaosVFX , Feb 14, 2020 :
    Same issue here, really present on 1.0.0.7 while browsing Chrome and Reddit. I believe the issue is in the OS itself, flashing a custom kernel did not help. Other users have reported installing Custom ROMs such as Omni alleviates this issue!
     

    #13
    Tex99 likes this.
  14. Pandatek
    Eclair Feb 21, 2020

    Pandatek , via OnePlus 6T , Feb 21, 2020 :
    getting exactly the same issue... what's going ? how come OnePlus is not fixing this?? it started happening since Android 10 upgrade.
     

    #14
    Tex99 likes this.
  15. Tex99
    Froyo Feb 21, 2020

    Tex99 , Feb 21, 2020 :
    on which device ? btw It seems that only few people see it, that's incredible, and I'm pretty sure that oneplus will never fix it
     

    #15
    Pandatek likes this.
  16. Pandatek
    Eclair Feb 21, 2020

    Pandatek , via OnePlus 6T , Feb 21, 2020 :
    OnePlus 6t. latest Android 10 firmware.
    is that a fact only a few people can see it? or is that something that OnePlus is making up do they don't have to fix this bug?
    it never happened before, Android 10.
    where can I file a bug report like you?
     

    #16
    Tex99 likes this.
  17. Tex99
    Froyo Feb 21, 2020

    Tex99 , Feb 21, 2020 :
    you have to open another thread and than a bug hunter will contact you
     

    #17
    Pandatek likes this.
  18. Pandatek
    Eclair Feb 21, 2020


    #18
    Tex99 likes this.
  19. Pandatek
    Eclair Feb 21, 2020

    Pandatek , via OnePlus 6T , Feb 21, 2020 :
    hey I tried to do it when I was at work but I couldn't get it to work to post a bug... can you let me know how to do it? quick guide?
     

    #19
  20. Pandatek
    Eclair Feb 21, 2020


    #20