0
Network/Connectivity Surfing the web works, MMS doesn't - Straight Talk T-Mobile MVNO

  1. M1546804634572
    Cupcake Jun 28, 2019

    M1546804634572 , Jun 28, 2019 :
    Hello..
    I had a previous issue where I was only getting 10mB/sec in speed tests; either MVNO or wireless. So I ended up doing a full wipe and reinstalled everything. Speeds are back to normal.

    But since then, I'm unable to send MMS messages. I've tried different SMS apps, tried different APN settings, etc. I've activated a new SIM card and did another full wipe, but this hasn't resolved anything.

    I have contacted Straight Talk, but they haven't been any help. "Wait two hours, restart your phone and you should be go". Uh, nope.

    Any ideas? Could it be an issue with the s/w of the phone?

    Thanks..
     

    #1
  2. GuidoNervi
    Gingerbread Jun 29, 2019

  3. M1546804634572
    Cupcake Jun 30, 2019

    M1546804634572 , Jun 30, 2019 :
    Thank you for the reply. But for some reason the phone will not save the APN settings. I can put in the required fields and save, but then when I enter all the information in the listing and save, the newly created APN which I created and saved previously is gone.

    UGH.
     

    #3
  4. Randallflagg0
    Cupcake Jul 4, 2019

    Randallflagg0 , Jul 4, 2019 :
    I can find ways to make it save by changing a few small settings but none of them fix MMS.
     

    #4
  5. Brewerp
    Cupcake Jul 5, 2019

    Brewerp , Jul 5, 2019 :
    I am having this same issue for 2 weeks now, ive tried everything as well with no results. thinking about switching services but im not sure if that will fix the problem.
     

    #5
  6. G_Dave_McEvoy_XSVa
    Cupcake Jul 6, 2019

    G_Dave_McEvoy_XSVa , Jul 6, 2019 :
    I have same issue. changed APN settings, apps, wipe cache...I'm thinking it started when I updated to 9.0.6, but also updated to 9.0.7 but persists. Thinking of going back to 9.0.5 but hate to lose data.
     

    #6