2
Switching off Wireless

  1. LyndaLauf
    Eclair Aug 22, 2017

    LyndaLauf , Aug 22, 2017 :
    Can anyone tell me how to switch OFF Wireless?
    I commute on the train and use 4G.
    I listen radio - news etc.... and constantly in the middle of a report I'm listening to - the Wireless kicks in and stops the radio - as it's expecting me to login to the useless wireless on the train.
    I have 128 apps on my phone and I'm not happy to individually find out which app is starting the wireless.
    Surely there must be a way to switch OFF The wireless and make sure it is completely switched off and does not start again until I and NOT the app chose to do so??
    I've done all the other stuff already - smart connect etc is all switched off.

    HELP - so I can finally listen to news without this stopping.
     

    #1
  2. saikiran4ever
    Jelly Bean Aug 22, 2017

    saikiran4ever , Aug 22, 2017 :
    Didn't you really find these options?
    - Settings > Wifi > Turn off
    - Quick settings panel > Wifi > Turn off
     

    #2
  3. LyndaLauf
    Eclair Aug 22, 2017

    LyndaLauf , Aug 22, 2017 :
    I really did find those - I would not put this post if it was that easy.
    Can anyone please help?
     

    #3
    G_gaurav_khurana_NzCT likes this.
  4. ajshanker
    Ice Cream Sandwich Aug 22, 2017

    ajshanker , Aug 22, 2017 :
    Hi,
    did you try the developer mode option for wifi?
    switch on cellular data always active. so that the wireless wont interfere with connection. also enable/disable wifi roam scans.
    attaching screenshot.
    1503387123603.jpg

    hope this helps.
     

    #4
    AltLin16 likes this.
  5. LyndaLauf
    Eclair Aug 22, 2017

    LyndaLauf , Aug 22, 2017 :
    OK - activated Developer mode.
    I'm now in the office but I will try this tonight on the train and see if I can finally keep my 4G.
    I'll play with the other options as well and see how I get on.

    this looks a brilliant tip and I hope it will work.

    should have an option - Disable WiFi completely. (This option will not allow any app to enable WiFi again - until Enabled)

    Thanks a lot for the guidance and I will update this tomorrow with my findings.
     

    #5
  6. jkb114
    Lollipop Aug 22, 2017

    jkb114 , Aug 22, 2017 :
    So let me get this right. You are traveling along using 4g then this wifi network gets into range, your phone automatically connects to it, then because it requires you to login or something, it'll disrupt your listening as you no longer have a data connection?

    If that's the case just make it forget the wifi network so it wont automatically connect to it
     

    #6
  7. LyndaLauf
    Eclair Aug 22, 2017

    LyndaLauf , Aug 22, 2017 :
    As soon as any network gets into range. Even BT WiFi for which I have an account.
    Your suggestion is not the solution I'm looking for because everytime you forget a network and you need it later you have to re-enter the passwords again.
    I just want the option of keeping the wireless off completely and regardless.
    I should have the option to decide - not the phone or any app.
    It's become a nuisance - I'm savvy enough to understand when I have to pay and when not for data - wirelessly or 4G.
    My responsibility - so let me make the decision - or at least give me the option to do so.

    When your in a crowded train and every Tom Dick and Harriet is on the trains WiFi - I would be lucky if I can sent a WhatsApp message - that's how useless it becomes to everyone - not just me. Whereas 4G is pretty good - because people are using the trains WiFi.
    Let's hope they all stay in the train's WiFi and don't do what I do and all go on 4G - I get the same problem.
     

    #7
    G_gaurav_khurana_NzCT likes this.
  8. jkb114
    Lollipop Aug 22, 2017

    jkb114 , Aug 22, 2017 :
    So just switch your wifi off then ?
     

    #8
    G_Mister_thakur_WmDP likes this.
  9. AltLin16
    Ice Cream Sandwich Aug 22, 2017

    AltLin16 , Aug 22, 2017 :
    Well I'd simply say that if the WiFi is off it should stay off unless you switch it on or authorize an app to do that. Thats' the way my OP3 with Nougat behaves. Moreover, there aren't any app permissions to switch it on, neither checking the permissions for a single app nor if I go in the general app configuration, that shows no wi-fi related group. And if i use a pertinent app like wi-fi manager or Fing it notifies me about wi-fi being off and then lets me use the system switch to turn it on. So i don't see how your problem would be related to apps, unless you find them listed there.
    Tap-on-Settings-icon-under-apps-settings.jpg
    App-permissions-under-configure-apps-settings.jpg
     
    Last edited: Aug 22, 2017

    #9
  10. LyndaLauf
    Eclair Aug 22, 2017

    LyndaLauf , Aug 22, 2017 :
    tell me how and we all done?

    that is exactly why I posted this thread - it keeps switching it back on and then overides my 4G and I'm stumped.
    I go into Settings and I do switch it off.

    I'm not English but do not know how to explain this problem any better?
     

    #10
    G_gaurav_khurana_NzCT likes this.
  11. LyndaLauf
    Eclair Aug 22, 2017

    LyndaLauf , Aug 22, 2017 :
    ok - so then explain to me why my WiFi constantly switches itself back on - despite me switching it off?
    it's a mystery to me?

    if it stayed off - like it seems to do on everyone's phone that is responding to this post - I would not have a problem - nor would this post exist.

    I've looked online for days and days and I've searched and searched - I cannot find anywhere where it gives me the option.

    the only useful comment I've had is the Developer option that I'm looking forward to try tonight.
     

    #11
    G_gaurav_khurana_NzCT likes this.
  12. AltLin16
    Ice Cream Sandwich Aug 22, 2017

    AltLin16 , Aug 22, 2017 :
    well I tried to be useful ruling out one option. I gather you don't see any wifi permission either checking like above ? Just to be sure we see the same thing. It still helps you to identify which apps to what without checking each. I just installed an app called wifi automatic. had non impact even where i told it to switch on wifi. There might be rogue apps which avoid these controls. If the developer options don't work either it could be a hardware issue.
     

    #12
  13. LyndaLauf
    Eclair Aug 22, 2017

    LyndaLauf , Aug 22, 2017 :
    thanks and I understand and am greatful yiu spend time on this.
    But I'm slightly getting a little frustrated and I hope you do understand.
    it's just as if people think I don't know what I'm doing but trust me - this post is my last resort.
    it cannot be faulty hardware as everything is functioning as it should - including the WiFi - it comes in and works.

    the problem is that it comes on - even when it should stay off.
    Then it overides the 4G - so now I have to go through WiFi or switch is off again.
    it just keeps coming back on - I switch it off - it keeps coming back on - I switch it off - etc.. etc...
    hope you get the idea.

    it is particularly annoying when you are listening to news or any other talk on the radio. when you just want to hear the answer of what they are saying - the bloody WiFi kicks in and stops it again.

    so how can I switch off WiFi so it does stay switched off and does not come back on and on and on.
     

    #13
    G_gaurav_khurana_NzCT likes this.
  14. AltLin16
    Ice Cream Sandwich Aug 22, 2017

    AltLin16 , Aug 22, 2017 :
    No sweat, by own experience I know that this stuff gets frustrating. Sorry if i gave the impression that we think you don't know what you're doing. To summarize:

    The problem is clear, you turn the WiFi off and then it kicks in by itself. Nobody here so far has the same problem as one switch turns it off. Completely. No other main switch seems to be known. Apps don't seem to be able to switch on wifi. Normally. Also the developer options mentioned, would manage the interaction with the wifi but normally not turn it on, but let us know what impact they have. Just make sure you also disable the scanning by the location services, toggle under Wifi configuration.

    A switch that doesn't stay in place could still be a particular hardware problem, maybe be triggered by something in the set-up.
     

    #14
  15. shermanheng4862
    Cupcake Aug 22, 2017


    #15
  16. ritchiedrama
    Ice Cream Sandwich Aug 22, 2017

    ritchiedrama , Aug 22, 2017 :
    Strange if I turn WiFi off on the quick panel tile it never comes back on and also turn off WiFi scanning as the post above shows. I don't see why anything else would be needed. Goodluck fixing it.
     

    #16
  17. LyndaLauf
    Eclair Aug 22, 2017

    LyndaLauf , Aug 22, 2017 :
    Can we PLEASE STOP the people answering on this post that it ALL works for them!!!!

    Mine DOES NOT - and if you search in this community for the simple 2 words 'Wifi off' you will see there is an epidemic of OnePlus phones with the same issue.

    Fine if yours works - fantastic and please go and celebrate it but just give me answers as to why mine isn't.

    thanks
     

    #17
  18. ritchiedrama
    Ice Cream Sandwich Aug 22, 2017

    ritchiedrama , Aug 22, 2017 :
    Suck my bollocks ya ****.
     

    #18
    brainfreze likes this.
  19. LyndaLauf
    Eclair Aug 22, 2017


    #19
  20. LyndaLauf
    Eclair Aug 22, 2017

    LyndaLauf , Aug 22, 2017 :
    dear richiedrama - looking back I was out of order.
    I'm frustrated that I cannot fix this - and that shows.
    you meant well with your answer and this is appreciated.
    I was testing it in the train tonight and changed things in Developer mode and nothing changes this stupid WiFi from starting up again and again.
    This was the time I read your message and answered.
    My apologies and hope you accept this.
     

    #20