2
Switching off Wireless

  1. G_Mister_thakur_WmDP
    Honeycomb Aug 22, 2017

    G_Mister_thakur_WmDP , Aug 22, 2017 :
    this is not the problem.either switch of the wifi or remove password for wifi connection.it's normal for all phones.Wifi consume less batttery so every phone gives preference for wifi network.if you will switch 4g or wifi and both are connected.mobile automatically gives preference for wifi connection.
     

    #21
  2. G_Mister_thakur_WmDP
    Honeycomb Aug 22, 2017


    #22
  3. AltLin16
    Ice Cream Sandwich Aug 22, 2017

    AltLin16 , Aug 22, 2017 :
    that's been suggested above but it's good to have a print now. not clear if it's been tried. if it resolves it would still be a bug as the idea here is to scan with WiFi off. similarly the developer options work with WiFi on so the hope was rather that it helps to handle better the changes if you just leave it on. another question for OP what OOS build are you using? finally it's a new fone so you contact customer support.
     

    #23
  4. AltLin16
    Ice Cream Sandwich Aug 22, 2017

    AltLin16 , Aug 22, 2017 :
    there are indeed threads about WiFi off or dropping against the users will but that would be the opposite of the problem here.
     

    #24
  5. LyndaLauf
    Eclair Aug 23, 2017

    LyndaLauf , Aug 23, 2017 :
    OK - tried last night and this morning in the train again with different developer modes.

    1503501604690.jpg

    WiFi continues to dominate and no matter what option I select - it comes back on and takes over.
    I'm beginning to think that no matter which way I look at this - I will have to start uninstalling each app and check if theee is one that makes the WiFi start up again?
    unless anyone can confirm that apps cannot do this???
     

    #25
  6. LyndaLauf
    Eclair Aug 23, 2017

    LyndaLauf , Aug 23, 2017 :
    is there a tool that could be used that would log as to why or what uses the WiFi - or actions the WiFi to kick in?
    it would not have to log for hours as it kicks in every 3 to 5 minutes.
     

    #26
  7. laceofspades
    Donut Aug 23, 2017


    #27
  8. LyndaLauf
    Eclair Aug 23, 2017

    LyndaLauf , Aug 23, 2017 :
    maybe we should swap phones with those users. [e]1f601[/e]
     

    #28
    AltLin16 likes this.
  9. LyndaLauf
    Eclair Aug 23, 2017

    LyndaLauf , Aug 23, 2017 :
    it's already not enabled.
     

    #29
  10. LyndaLauf
    Eclair Aug 23, 2017

    LyndaLauf , Aug 23, 2017 :
    I've enabled 'Enable WiFi verbose loggin'
    this I hope will log some data of the WiFi.
    however, all well and dandy, but I'm no developer and would not have a clue where it puts these logs to check and in what format - i.e. text or what?
    does anyone know or can help?
    I'm on the train again now and still having problems.
     

    #30
  11. felipemendes
    Jelly Bean Aug 23, 2017

    felipemendes , Aug 23, 2017 :
    I think the solution is around here. There is no configuration for wifi directly, but there is Configuration>Apps>Gear>Configure Apps>Special access (under advanced)>Modify System Settings.

    Disable all but the obvious, and check again.
     

    #31
    AltLin16 and OliveJeans like this.
  12. OliveJeans
    Eclair Aug 23, 2017

    OliveJeans , Aug 23, 2017 :
    well friend, first you need to chill a little bit [e]263a[/e]️
    of course it can be frustrating. and if it does, smash the phone against the wall or something like that but do not harsh on others who are actually trying to help or point out, that there no such issue. this is indeed a very uncommon and strange behavior of the phone.

    but to your issue: there are actually apps which do can change any kind of settings (Tasker, any kind of launchers, nfc tasks, etc. are just a few) and its not a normal 'permission'. those apps require rights called "modify system settings" or "device administrator" which you have to grant at first use of these apps.

    to check that go to "settings -> apps -> gearwheel(upper-right corner) -> special access" there are two options you should check: "device administrator" and "modify system settings" go there and uncheck any app which is turned on but you don't use/need.

    hope it fixes that, otherwise i guess you will have to uninstall every app one by one or even wipe your phone (factory reset)

    cheers


    1503513771671.jpg
     

    #32
    AltLin16 and felipemendes like this.
  13. AltLin16
    Ice Cream Sandwich Aug 23, 2017

    AltLin16 , Aug 23, 2017 :
    interesting, these rights are not listed under the individual apps and I didn't know or expect WiFi to be a system setting. the wifi manager I tried seems to be requiring it only to activate a hot.spot thigh and would would switch on or off wifi independently of it. hopefully it helps here.
     

    #33
  14. LyndaLauf
    Eclair Aug 23, 2017

    LyndaLauf , Aug 23, 2017 :
    BRILLIANT and thanks. let's hope this fixes it.
    OK - tomorrow I'm in the car and not train - I'm in the train Friday again.
    I found 27 apps with Modified System settings.
    17 have a 'Yes' against them
    10 have a 'No' against them.

    On Friday when I'm on the train I will have them ALL at 'No'
    I've made a note of the 10 apps 'No' - so I can get it back as was just in case.
    I will then test it again and see if the WiFi stays off completely.
    If it does - then I will change the 'No' one at a time to 'Yes' and see what the culprit is.

    I'll report back - keeping fingers crossed and thanks for the calming words - I'm in better space now.
     

    #34
  15. ScRuFFy7
    Eclair Aug 24, 2017

    ScRuFFy7 , Aug 24, 2017 :
    Are you using a custom kernel. Some toggles have incompatibility issues between the ROM and kernel. So what ROM and kernel are you using?
     

    #35
  16. felipemendes
    Jelly Bean Aug 25, 2017

    felipemendes , Aug 25, 2017 :
    How did it go?
     

    #36
  17. LyndaLauf
    Eclair Aug 25, 2017

    LyndaLauf , Aug 25, 2017 :
    did not go on the train today either - will have to wait until Tuesday now - it's a Sunday here in the UK on Monday. Sorry but as soon as I've tried it I will post the outcome on here. let's hope it does the trick.
    in the meantime if others have the same issue - please try it before me and post the results you get from it.
     

    #37
  18. AltLin16
    Ice Cream Sandwich Aug 25, 2017

    AltLin16 , Aug 25, 2017 :
    so essentially you only have this problem travelling on train and not say when you have WiFi turned off but walk into some spot with a net?
     

    #38
  19. LyndaLauf
    Eclair Aug 29, 2017

    LyndaLauf , Aug 29, 2017 :
    well - I was too optimistic for this to work I suppose.
    first I got all apps set to 'No'
    then I connected and I thought this is it.
    it did not interrupt and this lasted for about 30 minutes and yes - the WiFi kicked in again.
    however, it did not stop my news and 4G -
    so I thought it was done. but then another 20 minutes and it started again.
    so what it has done - is instead of switching on every 3 to 4 minutes - it now takes 30 to 40 minutes - but it still comes in and does NOT stay off.

    I'm a bit further- but it's not solved - unfortunately.

    I'm using a OnePlus 5 with its own original out of the box android.
    not sure if it's custom build - it's why I'm on the community as it's an OnePlus community.
    so I really hope this can be fixed and give me as user control back over WiFi or 4G -
     

    #39
  20. felipemendes
    Jelly Bean Sep 4, 2017

    felipemendes , Sep 4, 2017 :
    Man, this is crazy.

    I was a bit busy with the hurricane Harvey so did not look a lot in these discussions. Let's see.

    Wouldn't it be the 17 apps with the "Yes" (allowed to modify system settings) you should worry about? In case this was a typo and you revoked permission of the 17 apps allowed to modify system settings, maybe you can try separating these apps in two groups, then uninstalling 8 (or 9) and checking again. If the problem persists, try installing back and uninstalling the 9 (or 8) left. If you find the right group, divide again until you find the criminal.
     

    #40