6
"System" storage filling up all the storage space on the phone

  1. Figgeduni
    Eclair Nov 19, 2021

    Figgeduni , Nov 19, 2021 :
    Hi, have the problem that a lot of other people seem to have based on my google searches.

    Basically, something is filling up the "System" storage automatically over time until the phone runs out of storage. Currently I have 92GB used up out of 128GB from "System" files, and since you can't go in and see what is taking up the space I have a reached a dead end. I have tried formating, clearing caches, removing photos, emptied the trash folder under the collection tab in the Gallery app and so far nothing is working, it just keeps growing again until it reaches near full storage.

    The worst part is that from all my googling around there has been ZERO (0) comments from any OnePlus official on it, not even acknowledging the problem. For me this will be the first and last OnePlus, but for now I still wanna be able to use the phone so looking for help (but mostly just want to let the people at OnePlus know that this is a serious problem that is affecting alot of people and need to be fixed ASAP).
     

    Attached Files:


    #1
  2. Aaron2017
    General Support Expert Award 2021 Nov 19, 2021

    Aaron2017 , Nov 19, 2021 :
    It is indeed something i have seen quite a few times on the forum. However, i haven't seen any solution yet so i think you better contact support (if you haven't already) or visit a service center, if you're able to, to see what they have to say about this.
     

    #2
    Rahmat88 likes this.
  3. Swejuggalo
    OnePlus 9 Series Expert Community Expert Nov 19, 2021

    Swejuggalo , via OnePlus 9 Pro Morning Mist , Nov 19, 2021 :
    Also note that everything listed under system is not necessarily system. It's also unclassified files that could be created by something that is lumped together with system.
    Latest version of SD Maid is able to look at system with it's Storage Analyzer, at least in 12. It may prove useful.

    1637323667966.jpg
    https://play.google.com/store/apps/details?id=eu.thedarken.sdm

    But get it checked, report it via the feedback tool and report any additional findings.
    I'd would do some trial and error by for example a clean install and start with a minimalistic setup for a while. Only the most important apps. If this does not have the growing system storage issue install more apps but not all at once. Do a trial period once again. Still nothing? Install more and so on... If an app is the trigger, it can be found.

    I must one of the few that gladly would like to get the issue only to be able to investigate it. Weird I know 😜
     

    #3
  4. Figgeduni
    Eclair Nov 19, 2021

    Figgeduni , Nov 19, 2021 :
    Thanks for the answer. Downloaded SD Maid and tried the Storage Analyzer but under the "Device" option it shows storage used as 107GB/110GB used but once i click in on it it says only 5.9GB is used. Is that cause SD Maid can't read everything thats in it or?
     

    Attached Files:


    #4
  5. Swejuggalo
    OnePlus 9 Series Expert Community Expert Nov 19, 2021

    Swejuggalo , via OnePlus 9 Pro Morning Mist , Nov 19, 2021 :
    What do you see here?

    1637328551893.jpg
    I've enabled this.

    1637328562789.jpg
    Even if the device reports it as system the actual files can be elsewhere.

    1637328599554.jpg

    1637328599574.jpg
     

    #5
  6. Swejuggalo
    OnePlus 9 Series Expert Community Expert Nov 19, 2021

    Swejuggalo , via OnePlus 9 Pro Morning Mist , Nov 19, 2021 :
    Some content may be inaccessible and might even require root. But this is the most info I have been able to dig out without root.
    The current version can not currently scan obb folder but that might change. CX File Explorer can read parts of it.
    1637328914560.jpg
    1637328914581.jpg
     

    #6
  7. Figgeduni
    Eclair Nov 19, 2021

    Figgeduni , Nov 19, 2021 :
    Thanks, didn't know you had to choose which paths to show. Now i got the 3 same folders as you in the first picture. Now it shows 1.3GB in the System folder and 107GB in both the /storage/emulated/0 and /data folder but the /data folder is locked so can't search through that and searched through all of the /storage/emulated/0 folder without finding anything unusual so I assume there is something in the /data folder.

    You have any clue if there is a way to get into the /data folder?
     

    #7
  8. Swejuggalo
    OnePlus 9 Series Expert Community Expert Nov 19, 2021

    Swejuggalo , via OnePlus 9 Pro Morning Mist , Nov 19, 2021 :
    That would be root only I guess.
     

    #8
  9. puccellino
    Lollipop Nov 20, 2021

    puccellino , Nov 20, 2021 :
    As others have said, it's been seen many times, with no definitive official answer to resolve. The interesting thing is it happens on to some devices. The only solution I've seen is a regular reset.

    It might be worth your while to reboot and try opening in safe mode and see what happens. Is the space taken up at the same rate?
     

    #9
    Rahmat88 likes this.
  10. Figgeduni
    Eclair Nov 26, 2021

    Figgeduni , Nov 26, 2021 :
    Cba anymore to do random self diagnostics. Talking with a representative and sent logs to them, now waiting for an answer (been a week now without any answers...)
     

    #10
  11. Swejuggalo
    OnePlus 9 Series Expert Community Expert Nov 26, 2021

    Swejuggalo , via OnePlus 9 Pro Morning Mist , Nov 26, 2021 :
    A rooted user has found modem dump files being created over time and never gets removed. First of it should never grow indefinitely. Secondly the reason for them to be created to begin with could be a limited case scenario or hardware fault. This may be the case for other things than just modem though.

    https://forums.oneplus.com/threads/...do-i-solve-these-issue.1518111/#post-23820352

     

    #11
    Rahmat88 likes this.
  12. Figgeduni
    Eclair Dec 2, 2021

    Figgeduni , Dec 2, 2021 :
    Thanks for the reply. Been soon 2 weeks without any follow up answer from the support after I posted the log, so might have to root this shit to actually get it resolved...
     

    #12
  13. Swejuggalo
    OnePlus 9 Series Expert Community Expert Dec 2, 2021

    Swejuggalo , via OnePlus 9 Pro Morning Mist , Dec 2, 2021 :
    Could already have been fixed in Oxygen OS 12.

    Root certainly helps in digging around and finding the flaw. If this means it helps Oneplus is fixing it easier I don't know.
     

    #13
    puccellino likes this.
  14. Figgeduni
    Eclair Dec 3, 2021

    Figgeduni , Dec 3, 2021 :
    Well if it has been fixed a simple "It has been fixed in Oxygen OS 12" answer on my post wouldn't be that much to ask for.
     

    #14
  15. Swejuggalo
    OnePlus 9 Series Expert Community Expert Dec 3, 2021

    Swejuggalo , via OnePlus 9 Pro Stellar Black , Dec 3, 2021 :
    I'm running 12 myself... But I never had the issue. So I can't really say yes or no. Would be interesting to hear from someone having the issue in previous versions that has installed 12
     

    #15
    puccellino likes this.
  16. puccellino
    Lollipop Dec 5, 2021

    puccellino , Dec 5, 2021 :
    I do believe @B_Wrath , has this issue. He mentioned once it was caused by media files continuously creating cache or similar files. We can ask him to check it out if he's on A12.

    If I'm honest, I doubt the issue has been solved, I've seen people from the 7T upwards having this issue.
     

    #16
  17. B_Wrath
    Junior Moderator Junior Moderator Dec 5, 2021

    B_Wrath , Dec 5, 2021 :
    I still have it on A12. It's crazy. I will can't figure out why it counts it twice.
     

    #17
    Sergelala and puccellino like this.
  18. Swejuggalo
    OnePlus 9 Series Expert Community Expert Dec 5, 2021


    #18
  19. Figgeduni
    Eclair Dec 7, 2021

    Figgeduni , Dec 7, 2021 :
    Update, since I haven't recieved any answer to the logs i posted nor found any solution i tried to root the phone to be able to see and remove whatever took up the space and now I have managed to brick the phone totally.

    Thanks for the great phone and support OnePlus! First and absolutely last time ever buying a OnePlus phone.

    EDIT: Managed to solve the phone and get it back running after many hours of googling and help from a friend, although its still not rooted and currently running OnePlus 9 Pro ROM instead of OnePlus 9...
     
    Last edited: Dec 7, 2021

    #19
  20. U1622219124054
    Cupcake Dec 16, 2021

    U1622219124054 , Dec 16, 2021 :
    Same issue here. Same wall of silence from this amateur outfit.

    In my case it always happens when I'm in a roaming network in Germany. Takes 2-3 days, then System gets fulelr and fuller, until the phone doesn't even start. Something is running like hell since the phone gets quite hot. So something is probably logging like crazy.

    Sent two sets of logs, one where it was full, and one where it had actually stopped filling up the memory. But of course no one has replied.

    it has happened on the two latest releases.

    First and last Oneplus for me. Next time I'm going to suck it up and get an iPhone. It sucks, but it works.
     

    #20
    Sergelala likes this.