1
Text message delays badly

  1. Aidenx
    Cupcake Oct 31, 2019

    Aidenx , Oct 31, 2019 :
    I have recently upgraded to Android 10, the Oxygen 10.
    And I'm currently in BC Canada with Fido, I got text delay very bad.
    I tried to receive message, sometimes, did not even receive anything.
    Also I tried to send message to myself, it took me about 2 minutes on "sending", then another minute to receive.
    I have checked the message centre number as well with no issues.
    Is there anyone with the same problem?
    Any solutions?
    Thank you.
     

    #1
    OnePlusJisOJ23 likes this.
  2. arabinow
    Froyo Oct 31, 2019

    arabinow , via OnePlus 7 Pro , Oct 31, 2019 :
    I'm in the same boat. Fido in Ontario. I'm waiting for the next update if it doesn't fix it im going to just buy a new phone. it is really frustrating.
     

    #2
    Aidenx likes this.
  3. emoravac
    Cupcake Nov 1, 2019

    emoravac , Nov 1, 2019 :
    Same problem since OS upgrade.
    Resending doesn't help.
    Switching from 4g to 3g or 2g works.
    Roger's not seeing any issues on Their end.
    Also tried changing sms app to Signal.
    Same issue
     

    #3
  4. yywking
    Cupcake Nov 1, 2019

    yywking , Nov 1, 2019 :
    I have just figured out what the issue is: the SMS app. switching to Android messager fixed the delay, hopefully a patch will be pushed out to sort this out.
     

    #4
  5. Aidenx
    Cupcake Nov 1, 2019

    Aidenx , Nov 1, 2019 :
    Do you u mean the 3rd party message APP?
     

    #5
  6. yywking
    Cupcake Nov 1, 2019

    yywking , Nov 1, 2019 :
    not really 3rd party, but the original Android messager, which you can download from the store. something is buggy in the OnePlus one after OxygebOS 10 upgeade obviously
     

    #6
  7. Aidenx
    Cupcake Nov 1, 2019

    Aidenx , Nov 1, 2019 :
    totally, I rolled back from Android 10 to 9 before, then it pushed the upgrade notification, then I still upgraded, too many bugs.
     

    #7
  8. arabinow
    Froyo Nov 1, 2019

    arabinow , via OnePlus 7 Pro , Nov 1, 2019 :
    I have only been using Android messages and the delay is still there. it comes and goes based on network connection issues. test it for a day and see. I bet you will find it still a problem
     

    #8
  9. mackie011
    Cupcake Nov 21, 2019

    mackie011 , Nov 21, 2019 :
    I'm having this problem and it's persisting and I am not sure how to fix it. Rogers in Canada. I can't have a phone that texting doesn't work. Paid over $1000 for this and support isn't helping me either.
     

    #9
  10. arabinow
    Froyo Nov 21, 2019

    arabinow , via OnePlus 7 Pro , Nov 21, 2019 :
    oxygen os 10.0.2 totally solved this for me and I'm in Toronto on Fido ..if you haven't received the update use oxygen updater. I was frustrated as well and didn't want to wait for the official ota update. I'm glad I didn't.
     

    #10
  11. S1581341256164
    Cupcake Feb 10, 2020

    S1581341256164 , Feb 10, 2020 :
    I was able to solve it this past weekend. I had to look in a roundabout way.
    1. Settings
    2. Searches for Messages
    3. Tap on Messages at the bottom of the screen
    4. Tap on Mobile Data & Wi-Fi
    5. Switch on the option for Unrestricted Data Usage
     
    Last edited: Feb 10, 2020

    #11
  12. X1594011382717
    Cupcake Jul 6, 2020

    X1594011382717 , Jul 6, 2020 :
    Install Google Message and swap the default messager while waiting for the update. Same shyt for onePlus phone in many upgrades, put this in your test plan oneplus team.
     

    #12
  13. G_Daren_Messenger_owBj
    Cupcake Aug 1, 2020 at 5:17 PM


    #13